<!doctype html>
<!--[if lt IE 7]>      <html class="ie6" lang="en"> <![endif]-->
<!--[if IE 7]>         <html class="ie7" lang="en"> <![endif]-->
<!--[if IE 8]>         <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>         <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en">         <!--<![endif]-->
<head><script type="text/javascript">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</script>
	<meta charset="UTF-8">
	<title>Best Swim Cover-Ups 2019 | 43 Cover-Ups to Shop | StyleCaster</title>

    <link rel="apple-touch-icon" sizes="192x192" href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/apple-touch-icon-192x192.png" />
    <link rel="shortcut icon"  href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.ico" />

    <link rel="icon" sizes="32x32" type="image/png"  href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.png" />
    <link rel="icon" sizes="192x192" type="image/png" href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-192x192.png" />

	        <script type='text/javascript'>
            /**
             * Restoring jQuery object if 3rd party plugins is removed/override jQuery
             */
            (function (w) {
                // Latest jQuery value
                var latestValue = undefined;

                // First jQuery value
                var firstValue = undefined;

                // Add getter and setter for jQuery
                Object.defineProperty(w, 'jQuery', {

                    // jQuery getter
                    get: function () {
                        // if latest version jQuery is a function then return latest jQuery version
                        // if latest version jQuery is not a function then return first jQuery version
                        return ( 'function' === typeof latestValue ) ? latestValue : firstValue;
                    },

                    // jQuery setter
                    set: function (value) {
                        // override latesr jQuery version
                        latestValue = value;
                        // set up first jQuery version
                        if ('undefined' === typeof firstValue && 'function' === typeof value) {
                            firstValue = value;
                        }
                    }
                });

            })(window);
        </script>
        
	
<meta name="description" content="Swimsuit shopping is a delightful part of summer, but just as delightful? Swim cover-up shopping. Here, 43 of the cutest swim cover-ups on offer right now—because your go-to bathing suit deserves a cover-up that complements it." />
<meta name="keywords" content="swimwear, swim cover-ups, shopping" /><meta name="msvalidate.01" content="7A34A1C1904BAFB83691E8B3718CA9A2" />
<meta property="article:publisher" content="https://www.facebook.com/stylecaster" />
<meta name="google-site-verification" content="yB_5UwT5pPNnn93Mba5HIaFkNtbrafDQWP_Rj34Iw08" />

<script type="text/javascript">dataLayer = window.dataLayer || []; /* Google Tag Manager */</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_meta = {"lob":"","page-type":"article","env":"desktop","primary-category":"Fashion","primary-vertical":"","vertical":"","category":["Fashion","Shopping"],"tag":["Shopping","swim cover-ups","swimwear"],"author":["Lindsey Lanquist"],"logged-in":"","subscriber-type":"","country":"us","is_eu":false,"post-options":null};

/* ]]> */
</script>
		<script>
			(function(d,w){
				var i, parts, name, c, rdecode = /(%[0-9A-Z]{2})+/g, rspace = /\+/g, ac = (d ? d.split('; ') : []);
				for(w.pmc_cookies = {}, i = 0; i < ac.length; i++) {
					parts = ac[i].split('='), name = parts[0].replace(rdecode, decodeURIComponent), c = parts.slice(1).join('=');
					if(c.charAt(0) === '"') { c = c.slice(1, -1); } c = c.replace(rdecode, decodeURIComponent).replace(rspace, ' '); w['pmc_cookies'][name] = c;
				}
			})(document.cookie, window);

			pmc_meta=pmc_meta || {}, pmc_meta.omni_visit_id = window.pmc_cookies.omni_visit_id || "pmc." + new Date().getTime() + '.' + (function(l,b,a,c,i,d){for(i=0;i<256;i++){l[i]=(i<16?'0':'')+(i).toString(16);}if(c&&c.getRandomValues){try{d=new Uint32Array(4),c.getRandomValues(d);}catch(e){d=0;}}d=d||[b()*a>>>0,b()*a>>>0,b()*a>>>0,b()*a>>>0];a=d[0],b=d[1],c=d[2],d=d[3];return l[a&0xff]+l[a>>8&0xff]+l[a>>16&0xff]+l[a>>24&0xff]+'-'+l[b&0xff]+l[b>>8&0xff]+'-'+l[b>>16&0x0f|0x40]+l[b>>24&0xff]+'-'+l[c&0x3f|0x80]+l[c>>8&0xff]+'-'+l[c>>16&0xff]+l[c>>24&0xff]+l[d&0xff]+l[d>>8&0xff]+l[d>>16&0xff]+l[d>>24&0xff];})([],Math.random,0x100000000,window.crypto||window.msCrypto);
			var d = new Date(); d.setTime(d.getTime() + ( 60 * 60 * 1000 )); var expires = d.toGMTString(); var path = "/"; var domain = window.location.hostname;
			document.cookie = 'omni_visit_id=' + encodeURIComponent(pmc_meta.omni_visit_id) + ( expires ? '; expires=' + expires : '' ) + ( path ? '; path=' + path : '' ) + ( domain ? '; domain=' + domain : '' );
		</script>
				<script type="text/javascript">
		if( window.hasOwnProperty( 'pmc_meta' ) ) {
			if( !window.hasOwnProperty( 'dataLayer' ) || !window.dataLayer.hasOwnProperty('push') ) {
				window.dataLayer = [];
			}
			window.dataLayer.push( pmc_meta );
		}
		</script>

		           <meta id="ad_wrapper_script" data-unit-name="fashion/shopping"/>
           <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />            <script type="text/javascript" src="//content.jwplatform.com/libraries/ZNyazssg.js"></script>
                <!-- Facebook Pixel Code -->
        <script>
            !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
                n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
                n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
                t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
                document,'script','//connect.facebook.net/en_US/fbevents.js');
            // Insert Your Facebook Pixel ID below.
            fbq('init', '1130306277008218');
            fbq('track', 'PageView');
        </script>
        <noscript>
            <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1130306277008218&amp;ev=PageView&amp;noscript=1" />
        </noscript>
        <!-- End Facebook Pixel Code -->

        <!--Additional template-specific events for Facebook Pixel-->
                            <script id="facebook-page-type" data-facebook-page-type="page-vertical_slideshow">
                if ( typeof fbq != 'undefined' ) {
                    fbq('track', "page-vertical_slideshow");
                }
            </script>
        
                <script>
            (function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//comfortablecheese.com/0d54dab07da3e2c70e4c904001da3e0bcca526db5e6852893a5d2314eea316b18afeeb8af05e9b4e159a27858787b043438981d6a081e3ab397073de7b62');
        </script>
        		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=stylecaster.com&amp;id=35011528&amp;t=1559146277&amp;back=https%3A%2F%2Fstylecaster.com%2Fswim-cover-ups%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.anrdoezrs.net' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//scstylecaster.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Feed" href="https://stylecaster.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Comments Feed" href="https://stylecaster.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; 43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without Them Comments Feed" href="https://stylecaster.com/swim-cover-ups/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1556893897h&ver=5.2.2-alpha-45379"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJylUM1uwjAMfqEFUxhwmvYsiWvAJU6yOAH17Ze2Gpq2qZddIvv7sx14JIMxFAoFpJrk64WDwiNhFKPCnsYf3QZVX+Bvm+cbKQxUksWbmbunnAP62je6AdCzFnA+ziqXbR5By+hpIxzWBmDM1HBJtkwKoZ4teZImW7NJOn65pvLatlu9YznYuZRJ1bRXuIop1zbot2+B4c4JkuAzY6ovPjrrzbkGLBzDcvs3It4pZ+7XQxXN/DdotVA2u213hFSdZ5zjzs3xH//wUSmPpsRG5ynnXd66w+G0e+1O++3wCaDFyx0=?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJytkNFOwzAMRX+I1EvX8ob4ljTzUoMbh9ph2t+TdQKEEBMSvF1b18f2hVNxUbJhNrAZF1R4pQIandqZMQY1XF2/8/dQ6sQUIapCCakZlXJi7FrjDv6McSG+VFIykvxfyP3OHcJZb+EK10S5TQRim9fq9p3fQCc6JLROo1S7AgiyGDWGfohv5KW6d2JCcSwxXB76UrgjB1pvja44saQm03bKZ/mbT44h4iTyDGpt3TWVLbFuoR+TnQdILFPgi+FxefDjOPih9/349AbLask1?cssminify=yes' type='text/css' media='all' />
<script type="text/javascript" src="https://s1.wp.com/wp-content/themes/vip/pmc-plugins/pmc-global-functions/js/pmc-utils.js?m=1559073512h"></script>			<script type="text/javascript">
			var pmc_do_analytics_pagecount = true;		//flag to allow analytics code to count a page view
			var pmc_common_urls = {
				parent_theme_uri: 'https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/',
				current_theme_uri: 'https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/',
				fb_channel_uri: 'https://s1.wp.com/wp-content/themes/vip/pmc-plugins/partner/facebook/channel.html'
			};
			</script>
<script type='text/javascript'>
/* <![CDATA[ */
var pmc_comscore_options = {"pageview_candidate_url":"\/\/stylecaster.com\/wp-content\/themes\/vip\/pmc-plugins\/pmc-comscore\/xml\/comscore-pageview-candidate.xml"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sc_ajax_script = {"ajaxurl":"\/wp-admin\/admin-ajax.php","siteurl":"https:\/\/stylecaster.com"};
var scMainData = {"isPreview":"false"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var scAdvertisingConfig = {"vertical":"fashion\/shopping","globalTargeting":{"liveinsite":"segments","url":["https:\/\/stylecaster.com\/swim-cover-ups\/"],"dm_content":"false","tag":["Shopping","swim cover-ups","swimwear"],"Article_Category":["Fashion","Shopping"],"ct":["vertical_slideshow"],"ci":"1003542"},"pageType":"single","isSponsored":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytkt1qwzAMRl9orteVhN2M3Yxd7xUcRUmV+q+WnJA9/dLSMMZCOljAYMs+HH0C6yEq8mBzjay7aZ0zpvG27Tp+0GuActQmI7hz5GcYghf0cmFjYHHIbFpceHWhIosqM6YJ8DK1acIC9zMS+Z5wuIt1KNHASSVk+vzVXY445dI9RR0dqGhzS56v59aGyljVZA9CwV9n/r5fGnRFBsExhISzZK5XFAyKZbQIhgWTenrclzrmyhJcJA0aydNMOia0wdSY7iT6o84Z8uqIpt5GZ2o1JBPjVvEY3t4//qXq0dchzb9kIglOo4LMEtxGGan1Od5cr+5lXxTPh6Isi0P3BSogQb0='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scstylecaster.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://stylecaster.com/swim-cover-ups/" />
<link rel='shortlink' href='https://wp.me/p2mU64-4d4a' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fstylecaster.com%2Fswim-cover-ups%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fstylecaster.com%2Fswim-cover-ups%2F&amp;for=wpcom-auto-discovery" /><link rel='openid.server' href='https://scstylecaster.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://scstylecaster.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://stylecaster.com/osd.xml" title="StyleCaster" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="author" content="Lindsey Lanquist">        <meta id="ad_wrapper_script" data-unit-name="fashion/shopping" />
                <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
        		<script class="gtm-script-container" type="text/javascript">
			;(function(){
				// save url from which user came to the site to cookies.
				// We set cookie with help js because wordpress vip prohibits the cookies on the server side
				if (document.referrer && document.referrer.split('/')[2] != document.domain) {
					setCookie('sc_gtm_original_url', document.referrer, null);
				}

				_gtmq = [{
					'page_version': isLayout.get(),
					'full_URL': "https:\/\/stylecaster.com\/swim-cover-ups\/",
					'base_URL': "https:\/\/stylecaster.com\/swim-cover-ups\/",
					'query_Parameters': "",
					// --- DEPRECATED START ---
					// let's leave it in the comments to keep the store
					// 'is_Parallax': ,
					// 'is_OriginalVideo': ,
					// 'is_OriginalPhoto': ,
					// 'is_Slideshow': ,
					// 'is_ContentCreator': ,
					// 'is_Shoppable': ,
					// --- DEPRECATED END ---


										'site_section': "stylecaster",
					
					'source_site_of_post' : "stylecaster",

					'dm2sc': "0",

					// post params
											'post_author': "Lindsey Lanquist",
						'post_published': "05 2019",
						'post_published_full': "05-29-2019 11:00",
						'post_published_date': "2019-05-29",
						'post_url': "https://stylecaster.com/swim-cover-ups/",
						'post_title': "43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without Them",
						'histurl': null,
						// add type to characterize same events on different slideshows
																			'post_tags': "|374266436||374270603||199099|",
																			'post_categories': "Fashion|Shopping",
																			'main_categories': "Fashion",
																			'sub_categories': "Shopping",
													'article_id': "1003542",
												'slide_num': null,
												'virtual_page_url': "\/swim-cover-ups\/",
						'post_position_in_page': '1',
					
					// tag page params
					
					// result search page params
					
					// category page params
					
					// author page params
					
					// archive page params
					
					// meta data
					'meta_title': jQuery("title").text(),

					// page params
					'page_type': "single-vertical_slideshow",
					'referrer_original': getCookie('sc_gtm_original_url') ? getCookie('sc_gtm_original_url') : '',

										// Original WP post data
					'wp_post_type' : "post",
					
					'user_ip': "",
					'user_agent': navigator.userAgent
				}];

				// add utm params to _gtmq
				var temp;
				if (temp = getUrlParam(window.location.href, 'utm_source')) {
					_gtmq[0].utm_source = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_medium')) {
					_gtmq[0].utm_medium = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_campaign')) {
					_gtmq[0].utm_campaign = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_term')) {
					_gtmq[0].utm_term = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_content')) {
					_gtmq[0].utm_content = temp;
				}
			})();
		</script>
				<script>
			(function(w){
				w.dataLayer_SKM = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Shopping","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":1003542,"contentArticleTitle":"43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without Them","contentPublishedDate":"2019-05-29","contentPublishedMonthYear":"2019-05","contentPublishedTimestamp":"2019-05-29-11-00-05","contentOriginalPublishedTimestamp":"2019-05-29-11-00-05","cmsAuthorId":"737903","momentumAuthorId":"_na_","contentAuthorName":"Lindsey Lanquist","articleCategories":"Fashion|Shopping","contentTags":"Shopping|swim cover-ups|swimwear","geoTarget":"US","pageFormat":"Vertical Slideshow","editorialCategories":"Shopping","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_","scrollable":true,"infiniteScrollPageNum":1},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
				w.dataLayer_NA = "_na_";
				w.dataLayer_INTRO_SLIDE = "Intro";
			})(window);
		</script>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="StyleCaster" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Style News and Trends" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://stylecaster.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/f95e80beb275448b98a924f84cc3473a?s=16" /><script type="text/javascript">
/* <![CDATA[ */
var pmc_site_config = {"rot13_hostname":"fglyrpnfgre.pbz","hostname":"stylecaster.com","is_proxied":null};

/* ]]> */
</script>
		<script type='text/javascript'>
			var pmc_tracking_url = "https://s3.amazonaws.com/heartbeat.pmc.com/track?host=stylecaster.com&path=%2Fswim-cover-ups%2F&ct=article&lob=&loc=us&env=desktop&post_id=1003542";
			var pmc_tracking_image = new Image();
			if ( 'undefined' !== typeof pmc_meta && 'string' === typeof pmc_meta.omni_visit_id ) {
				pmc_tracking_url = pmc_tracking_url + '&omni_visit_id=' + pmc_meta.omni_visit_id;
			}
			if ( 'string' === typeof window.location.hash && window.location.hash.length ) {
				pmc_tracking_url = pmc_tracking_url + "&h=" + encodeURIComponent( window.location.hash );
			}
			pmc_tracking_image.src = pmc_tracking_url + "&ts=" + Date.now();
		</script>
		<meta property="og:site_name" content="StyleCaster" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="134683123322801" />
<meta property="og:url" content="https://stylecaster.com/swim-cover-ups/" />
<meta property="og:title" content="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without Them" />
<meta property="og:description" content="No shoes, no shirt, no service—but make it fashion." />
<meta property="article:published_time" content="2019-05-29T15:00:05+00:00" />
<meta property="article:modified_time" content="2019-05-29T15:00:08+00:00" />
<meta property="article:author" content="Lindsey Lanquist" />
<meta property="article:section" content="Fashion" />
<meta property="article:tag" content="Shopping" />
<meta property="article:tag" content="Shopping" />
<meta property="article:tag" content="swim cover-ups" />
<meta property="article:tag" content="swimwear" />
<meta property="og:image" content="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="540" />
<script type="text/javascript">
/* <![CDATA[ */
var pmc_krux = {"lob":"","page-type":"article","env":"desktop","primary-category":"Fashion","primary-vertical":"","vertical":"","category":["Fashion","Shopping"],"tag":["Shopping","swim cover-ups","swimwear"],"author":["Lindsey Lanquist"],"logged-in":"","subscriber-type":""};

/* ]]> */
</script>
<style type="text/css" id="syntaxhighlighteranchor"></style>
                <script type="text/javascript" src="https://ads.blogherads.com/bh/1/1/1/2208790/header.js" async="async"
                    data-cfasync="false"></script>
            <script type="text/javascript" src="https://ads.blogherads.com/static/blogherads.js" async="async"
                    data-cfasync="false"></script>
            
	<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@stylecaster" /><meta name="twitter:creator" content="@stylecaster" /><meta name="twitter:title" content="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them"/><meta name="twitter:description" content="No shoes, no shirt, no service—but make it fashion."/><meta name="twitter:image" content="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png"/><meta property="twitter:account_id" content="55678606" />        <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
        <!--[if lt IE 9]>
        <script src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/html5shiv.min.js"></script>
        <script src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/respond.min.js"></script>
        <![endif]-->
                <meta property="fb:pages" content="48566051011" />
        <meta property="fb:article_style" content="scdefault">
        </head>
<body class="post-template-default single single-post postid-1003542 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light pmc-desktop pmc-no-tablet pmc-no-mobile geo-us" data-paged="1" data-siteurl="https://stylecaster.com"><noscript><img src='//us72er.com/pzfdff?MXwLWAcGFURIS1NLFUQbDUUITlsFBRJHTlBRHwgSAkkPUFgDEgMIBklORxcTEQtFCE4XFl8VSUJSBQodFwJJD1BLUxk'/></noscript>
<!-- pmc-tags-top Comscore -->	<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035310&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
	</noscript>

<!-- end pmc-tags-top Comscore -->
<div class="wrapper">
    
        <header class="header hide-when-active-popup" id="siteheader" data-gtm-link-location="Header"  >
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </header>
    
        <div class="siteheadersticky header" id="siteheadersticky" data-gtm-link-location="Header">
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </div>
        
            <div class="header" id="singleheader"  data-gtm-nav-show="0" data-gtm-link-location="PostNavBar">
        <div class="container shadow">
            
<div class="main">
    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    <div class="logo_delimiter"></div>
    <div class="logo hidden-phone">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>
    <div class="post_header_title">
                    <span>Share</span>
                <div class="social_menu square">
            <ul id="single-header-social-menu" class="social-menu-container" data-gtm-button-location="PostNavBar">
                <li class="sc-icon-facebook menu-item">
                    <a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/swim-cover-ups/">Facebook</a>
                </li>
                <li class="sc-icon-pinterest menu-item">
                    <a class="pretty_social" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" data-type="pinterest" data-url="https://stylecaster.com/swim-cover-ups/">Pinterest</a>
                </li>
                <li class="sc-icon-twitter menu-item">
                    <a class="pretty_social" data-type="twitter" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster">Twitter</a>
                </li>
                <li class="sc-icon-tumblr menu-item">
                    <a class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster">Tumblr</a>
                </li>
            </ul>
        </div>
        <h2 itemprop="name">43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them</h2>

    </div>
</div>


<div class="main_menu">
    <div class="hot-block">
        <i class="icon-fire"></i>
        <span>What's hot</span>        
    </div>
    <div class="post_prev_next_vav">
        <span class="trigger next">
            <i class="sc-icon-arrow-right"></i>
        </span>
        <span class="trigger back inactive">
            <i class="sc-icon-arrow-left"></i>
        </span>
    </div>
    <div id="sliderNexPrev" class="iner">
        <div class="post_prev_next next hidden-phone hidden-tablet-portrait scpin-no">
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/summer-booties/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/05/summer-booties-feat.gif?w=120&#038;h=120&#038;crop=1" alt="Summer Booties Exist, and They&#039;re Exactly as Cute..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Summer Booties Exist, and They&#039;re Exactly as Cute...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/summer-heels-statement-making/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/05/statementshoes-feat.gif?w=120&#038;h=120&#038;crop=1" alt="Statement-Making Summer Heels to Shop, Because Treat..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Statement-Making Summer Heels to Shop, Because Treat...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/summer-going-out-tops/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/05/summer-going-out-tops.jpg?w=120&#038;h=120&#038;crop=1" alt="59 Summer Going-Out Tops That Are Equal Parts Hot..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									59 Summer Going-Out Tops That Are Equal Parts Hot...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/universal-standard-size-inclusive/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/05/universal-standard.jpg?w=120&#038;h=120&#038;crop=1" alt="Universal Standard Is Now the First Retailer to Carry..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Universal Standard Is Now the First Retailer to Carry...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/best-memorial-day-sales-2019/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/05/memorialday-feat.png?w=120&#038;h=120&#038;crop=1" alt="All of The Memorial Day Weekend Sales You Need to..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									All of The Memorial Day Weekend Sales You Need to...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
			        </div>
    </div>
</div>        </div>
    </div>
    
    <div class="wrapper-header-ad-slot hidden-phone">
	<div class="header-ad-slot">
		<div class="header slideshow-header sc-top-ad">
			<div class="container">
				<div class="mobile_menu_trigger">
					<div class="border-menu"></div>
				</div>
				<div class="logo_delimiter"></div>
				<div class="logo-small visible-desktop visible-tablet">
					<a href="https://stylecaster.com">StyleCaster</a>
				</div>
								<div class="slideshow-ad-top-block">
					<div id="oas_Top2" class="sc-ad-init" data-position="Top2" data-internal-section="SlideShow"></div>
				</div>
			</div>
		</div>
	</div>
</div>
    <!--Use list element of the schema org for pages there list is present-->
    
            <div class="page_content_container ">
        <div id="skin">
            <div class="isa_post_container" data-viglink-disable="false" data-is-sponsored="false" data-post-id="1003542" data-post-type="vertical_slideshow" data-post-authors="Lindsey Lanquist" data-categories-slug="fashion,shopping" data-categories="Fashion,Shopping" data-tags="Shopping,swim cover-ups,swimwear" data-page-title="Best Swim Cover-Ups 2019 | 43 Cover-Ups to Shop &laquo;  StyleCaster" data-gtm-article-type="vertical_slideshow" data-facebook-page-type="page-vertical_slideshow" data-page-title-gtm="Best Swim Cover-Ups 2019 | 43 Cover-Ups to Shop | StyleCaster" href="https://stylecaster.com/swim-cover-ups/" data-page-format="Vertical Slideshow">
    		<script>
			if( 'undefined' == typeof scGtmPremiumData ) {
				window.scGtmPremiumData = {};
			}
			window.scGtmPremiumData[1003542] = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Shopping","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":1003542,"contentArticleTitle":"43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them","contentPublishedDate":"2019-05-29","contentPublishedMonthYear":"2019-05","contentPublishedTimestamp":"2019-05-29-11-00-05","contentOriginalPublishedTimestamp":"2019-05-29-11-00-05","cmsAuthorId":"737903","momentumAuthorId":"_na_","contentAuthorName":"Lindsey Lanquist","articleCategories":"Fashion|Shopping","contentTags":"Shopping|swim cover-ups|swimwear","geoTarget":"US","pageFormat":"Vertical Slideshow","editorialCategories":"Shopping","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_"},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
		</script>
		        <div class="container">
        <div class="content-split sc-section_single sc-section-can-stiky">
            <aside class="sc-sidebar sc-sidebar-single visible-desktop">
              <div class="sc-adv-wrap">
                  <div class="sc-adv-wrap-help">
                      <div id="sc_adwrapperunit-4" class="widget widget_sc_adwrapperunit">
        <div class="sc-ad-init" id="oas_Middle3" data-position="Middle3"></div>
        
        </div>
                  </div>
              </div>
            </aside>
            <article class="main_content_area sc-main_content  vertical-slideshow" itemscope itemtype="https://schema.org/Article">
                <meta itemprop="mainEntityOfPage" content="https://stylecaster.com/swim-cover-ups/" />
                <meta itemprop="name" content="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" />
               <div class="sc-single-column">
                   <div class="article " data-current-url="https://stylecaster.com/swim-cover-ups/"  data-prev-url="https://stylecaster.com/miley-cyrus-feud-demi-lovato-selena-gomez/"   data-next-url="https://stylecaster.com/millie-bobby-brown-godzilla-premiere/" >
                       <header>
                           
                           
                           
                                                                                     <h1 itemprop="headline">43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them</h1>
                           
                           <div class="post_detail">
                               <div class="post_head_detials" data-gtm-button-location="Post Shared Count">
                                   <div class="sc-column">
                                               <ul class="sharecount-social-btns social_menu colored ">
            <li class="menu-item sc-icon-facebook"><a href="javascript:void(0);" class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/swim-cover-ups/">Facebook</a></li>
            <li class="menu-item sc-icon-pinterest"><a href="javascript:void(0);" class="pretty_social" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" data-type="pinterest" data-url="https://stylecaster.com/swim-cover-ups/">Pinterest</a></li>
            <li class="menu-item sc-icon-twitter"><a href="javascript:void(0);" class="pretty_social icon-twitter" data-type="twitter" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster">Twitter</a></li>
            <li class="menu-item sc-icon-tumblr"><a href="javascript:void(0);" class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/swim-cover-ups/">Tumblr</a></li>
                            <li class="menu-item sc-icon-comment"><span class="sc-comments-count spot-im-replies-count" data-post-id="1003542">0</span></li>
                    </ul>
                                           </div>

                                   <div class="sc-column">

                                       <div class="sc-post-avatar"><img alt='Lindsey Lanquist' src='https://1.gravatar.com/avatar/15e154be39d0edcc8dce09ac41035951?s=96&#038;d=identicon&#038;r=G' class='sc-desaturate-image scpin-no avatar avatar-96' height='0' width='0' /></div>
                                                                              <span class="sc-post-author">by<span itemprop="author"><a href="https://stylecaster.com/author/llanquist/" title="Posts by Lindsey Lanquist" class="author url fn" rel="author">Lindsey Lanquist</a></span></span>

                                       
                                                                              <span itemprop="datePublished" content="2019-05-29T11:00:05-04:00" class="sc-post-date hidden-phone">1 hour ago</span>
                                       <meta itemprop="dateModified" content="2019-05-29T11:00:08+00:00" />
                                               <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
            <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                <meta itemprop="url" content="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/base64/Stylecaster-logo.png">
                <meta itemprop="width" content="600">
                <meta itemprop="height" content="60">
            </div>
            <meta itemprop="name" content="StyleCaster">
        </div>

                                           </div>
                               </div>
                           </div>

                           
                <div class="sc_feature_image_container " itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <img src="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" title="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" alt="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" />
            <meta itemprop="url" content="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" />
            <meta itemprop="width" content="712" />
            <meta itemprop="height" content="400" />
                    </div>

                            <div class="photo-detail">Photo:
                                    <span class="source">Alyssa Crane.</span>
                            </div>
        
                
                           
                           
                       </header>
                       <div class="post_content format clearfix" data-gtm-pin-location="PostContent" itemprop="articleBody">
                                                          <p class="scroll-to-see-more d-none">Scroll To See More Images</p>
                                                      <?xml encoding="utf-8" ?><p style="text-align:left;" class="big_first_letter">When summer’s on its way, it’s easy to stock up on swimsuits and little else. Because swimsuits are fun. Swimsuits are cute. Swimsuits instantly transport us to a world of shining sun and high temperatures—a reality that hasn’t been ours for far too long. The only issue? Rarely does one go to the beach, or pool, or lake in a swimsuit and only a swimsuit—nay, we adorn ourselves with <a href="https://www.popsugar.com/fashion/Best-Beach-Cover-Ups-2019-45899173" target="_blank" rel="noopener" target="_blank">swim cover-ups</a> and other swim-centric clothing. Which is exactly why it’s important to work a little <a href="https://www.refinery29.com/en-us/swimsuit-cover-up" target="_blank" rel="noopener" target="_blank">swim cover-up shopping</a> into your swim<em>suit</em> shopping.</p>
<p>I’d be lying if I suggested I was the right one to cast stones on this one. I have failed to <a href="https://www.travelfashiongirl.com/best-swimsuit-coverups/" target="_blank" rel="noopener" target="_blank">stock up on swim cover-ups</a> in what can only be described as a <em>chronic</em> fashion. I relied exclusively on one Forever 21 dress for far too long; having a go-to can make getting dressed a whole lot easier, but depending on how often you’re wearing it, it can also make things <em>hella</em> monotonous. (I could tell things had taken a turn for the worse when I no longer wanted to pose for beachside Instagrams because I was so thoroughly bored of my tried-and-true cover-up. A frivolous litmus test, to be sure—but this is 2019 we’re talking about.)</p>
<p>The good news here is that <a href="https://seasideplanet.com/best-cover-up-beach/" target="_blank" rel="noopener" target="_blank">swim cover-up shopping can be just as fun</a> and transportive as swimsuit shopping—if you’ll let it. Because the reality of <a href="https://www.coastalliving.com/lifestyle/products/swimsuit-cover-ups" target="_blank" rel="noopener" target="_blank">swim cover-ups is that they’re as cute, vibrant</a> and exciting as bathing suits—and the selection is pretty damn varied, too. Give <a href="https://people.com/style/cute-bikini-swimsuit-cover-ups-amazon/" target="_blank" rel="noopener" target="_blank">our swim cover-up picks</a> a perusal, and you’ll quickly notice you’re replacing your favorite bikini with your <a href="https://www.today.com/style/best-swimsuit-cover-caftan-2017-t114711" target="_blank" rel="noopener" target="_blank">new favorite swim cover-up</a> in all your imagined, idyllic Instagrams-to-be.</p>
<p><a href="https://www.rankandstyle.com/top-10-list/best-swim-cover-ups-under-100" target="_blank" rel="noopener" target="_blank">This summer’s swim cover-ups</a> are fodder for attention, outfit inspiration and so much more. So instead of buying a 30th one-piece, consider snagging a caftan, or romper, or crochet naked dress, instead,</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-1.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003544" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-1/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-1.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-1" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-1.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-1.jpg?w=683" class="aligncenter size-full wp-image-1003544" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-1.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>1. Roeqiya Garden Princess Caftan, $138 at <a href="https://www.anthropologie.com/shop/roeqiya-garden-princess-caftan" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Elegant enough to sport to a beachside restaurant without thinking twice.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-2.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003545" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-2/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-2.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-2" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-2.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-2.jpg?w=683" class="aligncenter size-full wp-image-1003545" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-2.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>2. Brooke Cover-Up Dress, $140 at <a href="https://www.anthropologie.com/shop/brooke-cover-up-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Low-key enough to throw over whatever you’re already wearing—cute enough to put a smile on your face as you do.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-3.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003546" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-3/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-3.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-3" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-3.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-3.jpg?w=683" class="aligncenter size-full wp-image-1003546" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-3.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>3. Melissa Odabash Eloise Cover-Up Robe, $334 at <a href="https://www.anthropologie.com/shop/melissa-odabash-eloise-cover-up-robe" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Sure to play as well with your favorite bikini as it will with your go-to tee-and-jeans combo.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-4.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003547" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-4/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-4.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-4" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-4.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-4.jpg?w=678" class="aligncenter size-full wp-image-1003547" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-4.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>4. Tiare Hawaii Amazonia Dress, $113 at <a href="https://www.revolve.com/tiare-hawaii-amazonia-dress/dp/TIAR-WD296/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>So elegantly sexy you might consider wearing it on your next date night, too.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-5.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003548" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-5/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-5.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-5" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-5.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-5.jpg?w=683" class="aligncenter size-full wp-image-1003548" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-5.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>5. Astrid Gauze Oversized Button-Front Top, $59 at <a href="https://www.urbanoutfitters.com/shop/uo-astrid-gauze-oversized-button-front-top" target="_blank" rel="nofollow noopener" target="_blank">Urban Outfitters</a></h2>
<p>A classic for a reason.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-6.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003549" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-6/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-6.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-6" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-6.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-6.jpg?w=683" class="aligncenter size-full wp-image-1003549" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-6.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>6. Mara Hoffman Fiona Dress, $375 at <a href="https://www.anthropologie.com/shop/mara-hoffman-fiona-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Turn heads without sacrificing comfort—or practicality.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-7.jpg?w=712&amp;h=1038"></noscript><img data-attachment-id="1003550" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-7/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-7.jpg" data-orig-size="712,1038" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-7" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-7.jpg?w=460" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-7.jpg?w=702" class="aligncenter size-full wp-image-1003550" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1038" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-7.jpg?w=712&amp;h=1038" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>7. We’re Chiffon It Tie-Dye Cover-Up Kimono, $25 at <a href="https://www.nastygal.com/were-chiffon-it-tie-dye-cover-up-kimono/AGG74186.html" target="_blank" rel="nofollow noopener" target="_blank">Nasty Gal</a></h2>
<p>It was only a matter of time before our collective obsession with tie-dye made its way to beachwear, too.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-8.jpg?w=712&amp;h=1044"></noscript><img data-attachment-id="1003551" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-8/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-8.jpg" data-orig-size="712,1044" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-8" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-8.jpg?w=457" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-8.jpg?w=698" class="aligncenter size-full wp-image-1003551" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1044" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-8.jpg?w=712&amp;h=1044" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>8. All Caught Up Maxi Hoodie, $108 at <a href="https://www.freepeople.com/shop/all-caught-up-maxi-hoodie/" target="_blank" rel="nofollow noopener" target="_blank">Free People</a></h2>
<p>Because 2019’s crochet trend lends itself oh-so naturally to the swim cover-up realm.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-9.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003552" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-9/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-9.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-9" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-9.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-9.jpg?w=683" class="aligncenter size-full wp-image-1003552" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-9.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>9. Joaan Cover-Up Caftan, $140 at <a href="https://www.anthropologie.com/shop/joaan-cover-up-caftan" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>For the shopper who doesn’t actually want their cover-up to cover <em>up</em> their swimsuit.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-10.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003553" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-10/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-10.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-10" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-10.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-10.jpg?w=683" class="aligncenter size-full wp-image-1003553" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-10.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>10. Mara Hoffman Rosario Striped Dress, $325 at <a href="https://www.anthropologie.com/shop/mara-hoffman-rosario-striped-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>So stunning you could probably repurpose it for wedding season—just saying.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-11.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003554" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-11/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-11.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-11" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-11.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-11.jpg?w=683" class="aligncenter size-full wp-image-1003554" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-11.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>11. Woven Fringe Ruana, $44 at <a href="https://www.urbanoutfitters.com/shop/uo-woven-fringe-ruana" target="_blank" rel="nofollow noopener" target="_blank">Urban Outfitters</a></h2>
<p>Low-key, and able to be repurposed in every summer context.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-12.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003555" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-12/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-12.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-12" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-12.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-12.jpg?w=683" class="aligncenter size-full wp-image-1003555" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-12.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>12. Sun Seeking Lace Swim Cover-Up Maxi Skirt, $44 at <a href="https://www.lulus.com/products/sun-seeking-brick-red-lace-swim-cover-up-maxi-skirt/732962.html" target="_blank" rel="nofollow noopener" target="_blank">Lulus</a></h2>
<p>Not sure if this’ll get you past “no shoes, no shirt, no service”—but it’s definitely cute enough to warrant a try.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-13.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003557" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-13/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-13.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-13" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-13.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-13.jpg?w=712" class="aligncenter size-full wp-image-1003557" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-13.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>13. Maternity Tie-Dye Jersey Beach Cover-Up, $29 at <a href="https://us.asos.com/asos-maternity/asos-design-maternity-pastel-tie-dye-jersey-beach-cover-up/prd/11257834" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>Keep it casual, retro and on-trend all at once.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-14.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003558" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-14/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-14.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-14" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-14.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-14.jpg?w=683" class="aligncenter size-full wp-image-1003558" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-14.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>14. Give ‘Em Shade Maxi Cover-Up Kimono, $35 at <a href="https://www.nastygal.com/give-em-shade-maxi-cover-up-kimono/AGG78710.html" target="_blank" rel="nofollow noopener" target="_blank">Nasty Gal</a></h2>
<p>The kind of thing you’ll want to throw on every morning on your next vacation.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-15.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003559" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-15/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-15.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-15" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-15.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-15.jpg?w=683" class="aligncenter size-full wp-image-1003559" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-15.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>15. Victory Cover-Up Maxi Dress, $180 at <a href="https://www.anthropologie.com/shop/victory-cover-up-maxi-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p><em>Definitely</em> nice enough to get you anywhere you need to go after the beach.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-16.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003560" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-16/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-16.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-16" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-16.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-16.jpg?w=683" class="aligncenter size-full wp-image-1003560" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-16.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>16. Seaside Retreat Cover-Up Maxi Dress, $42 at <a href="https://www.lulus.com/products/seaside-retreat-coral-red-and-magenta-maxi-cover-up/621492.html" target="_blank" rel="nofollow noopener" target="_blank">Lulus</a></h2>
<p>A poolside take on the slip dress.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-17.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003561" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-17/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-17.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-17" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-17.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-17.jpg?w=683" class="aligncenter size-full wp-image-1003561" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-17.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>17. Colorblock Sarong Swim Cover-Up, $14.90 at <a href="https://www.forever21.com/us/shop/catalog/product/f21/swimwear_all/2000336365" target="_blank" rel="nofollow noopener" target="_blank">Forever 21</a></h2>
<p>Sarongs are an absolute <em>look</em>.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-18.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003562" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-18/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-18.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-18" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-18.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-18.jpg?w=683" class="aligncenter size-full wp-image-1003562" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-18.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>18. Lioness Despacito Metallic Open Knit Maxi Dress, $89 at <a href="https://www.urbanoutfitters.com/shop/lioness-despacito-metallic-open-knit-maxi-dress" target="_blank" rel="nofollow noopener" target="_blank">Urban Outfitters</a></h2>
<p>A naked dress fit for the beach and the bar, alike.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-19.jpg?w=712&amp;h=809"></noscript><img data-attachment-id="1003563" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-19/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-19.jpg" data-orig-size="712,809" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-19" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-19.jpg?w=590" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-19.jpg?w=712" class="aligncenter size-full wp-image-1003563" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="809" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-19.jpg?w=712&amp;h=809" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>19. Frill Tile Print Top, $29 at <a href="https://us.asos.com/asos-tall/asos-design-tall-frill-beach-top-in-tile-print-two-piece/prd/10996483" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>Oh yeah, matching set cover-ups are <em>definitely</em> a thing.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-20.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003564" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-20/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-20.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-20" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-20.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-20.jpg?w=678" class="aligncenter size-full wp-image-1003564" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-20.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>20. Tularosa Rae Reversible Robe, $218 at <a href="https://www.revolve.com/tularosa-rae-reversible-robe/dp/TULA-WO134/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Sweet enough to toss over your favorite swimsuit—or your favorite dress, or your favorite jeans, or your favorite <em>anything</em>.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-21.jpg?w=712&amp;h=804"></noscript><img data-attachment-id="1003565" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-21/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-21.jpg" data-orig-size="712,804" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-21" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-21.jpg?w=593" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-21.jpg?w=712" class="aligncenter size-full wp-image-1003565" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="804" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-21.jpg?w=712&amp;h=804" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>21. South Beach Exclusive Leopard Print Jumpsuit, $48 at <a href="https://us.asos.com/south-beach/south-beach-exclusive-beach-jumpsuit-in-leopard-print/prd/10511195" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>The chicest way to dip your toes in the sand this summer.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-22.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003566" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-22/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-22.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-22" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-22.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-22.jpg?w=712" class="aligncenter size-full wp-image-1003566" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-22.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>22. Pink Stripe Wide-Leg Two-Piece, $40 at <a href="https://us.asos.com/asos-design/asos-design-wide-leg-beach-pants-in-pink-stripe-two-piece/prd/11202349" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>Definite fodder for your next summer ‘gram.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-23.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003567" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-23/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-23.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-23" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-23.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-23.jpg?w=683" class="aligncenter size-full wp-image-1003567" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-23.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>23. Meribina Cover-Up Dress, $150 at <a href="https://www.anthropologie.com/shop/meribina-cover-up-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Simultaneously low-key and statement-making—yes, please.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-24.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003568" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-24/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-24.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-24" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-24.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-24.jpg?w=678" class="aligncenter size-full wp-image-1003568" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-24.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>24. Lovewave Reeves Crop, $138 at <a href="https://www.revolve.com/lovewave-reeves-crop/dp/LEWA-WS3/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Cute in and out of its matching set. (But let’s be real—we’d definitely shop this one in its matching set.)</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-25.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003569" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-25/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-25.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-25" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-25.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-25.jpg?w=683" class="aligncenter size-full wp-image-1003569" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-25.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>25. Abstract Shapes Caftan, $350 at <a href="https://www.anthropologie.com/shop/abstract-shapes-caftan" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>A caftan sure to complement—not compete with—your go-to swimmy.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-26.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003570" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-26/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-26.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-26" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-26.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-26.jpg?w=678" class="aligncenter size-full wp-image-1003570" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-26.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>26. LPA Crochet High-Waist Culotte, $178 at <a href="https://www.revolve.com/lpa-crochet-high-waist-culotte/dp/LPAR-WP126/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Culottes are a veritably underrated way to do the crochet trend.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-27.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003571" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-27/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-27.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-27" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-27.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-27.jpg?w=683" class="aligncenter size-full wp-image-1003571" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-27.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>27. Charlie Oversized Button-Down Shirt, $54 at <a href="https://www.urbanoutfitters.com/shop/uo-charlie-oversized-button-down-shirt" target="_blank" rel="nofollow noopener" target="_blank">Urban Outfitters</a></h2>
<p>OK, this one’s at the top of my list.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-28.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003572" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-28/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-28.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-28" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-28.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-28.jpg?w=683" class="aligncenter size-full wp-image-1003572" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-28.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>28. Gauzy Long Cover-Up, $44 at <a href="https://www.urbanoutfitters.com/shop/uo-guazy-long-cover-up" target="_blank" rel="nofollow noopener" target="_blank">Urban Outfitters</a></h2>
<p>Lightweight enough to keep you going on summer’s most humid days.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-29.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003573" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-29/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-29.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-29" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-29.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-29.jpg?w=712" class="aligncenter size-full wp-image-1003573" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-29.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>29. Long-Sleeve Chiffon Maxi Beach Kimono, $45 at <a href="https://us.asos.com/asos-design/asos-design-recycled-long-sleeve-wrap-tie-chiffon-maxi-beach-kimono-in-black/prd/10817750" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>A little edgy, a little glamorous—all <em>kinds</em> of versatile.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-30.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003574" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-30/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-30.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-30" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-30.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-30.jpg?w=683" class="aligncenter size-full wp-image-1003574" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-30.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>30. Jai Vasicek Anika Cover-Up Kimono, $138 at <a href="https://www.anthropologie.com/shop/jai-vasicek-anika-cover-up-kimono" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>A cover-up that simply wants to render you a walking work of art. (Let it!!)</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-31.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003575" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-31/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-31.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-31" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-31.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-31.jpg?w=712" class="aligncenter size-full wp-image-1003575" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-31.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>31. Embellished Beach Short Two-Piece, $32 at <a href="https://us.asos.com/asos-design/asos-design-premium-embellished-mirror-bead-beach-short-two-piece/prd/9835455" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>Coordinate your cover-up with your swimsuit top—because you <em>can</em>.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-32.jpg?w=712&amp;h=1069"></noscript><img data-attachment-id="1003576" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-32/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-32.jpg" data-orig-size="712,1069" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-32" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-32.jpg?w=446" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-32.jpg?w=682" class="aligncenter size-full wp-image-1003576" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1069" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-32.jpg?w=712&amp;h=1069" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>32. Apricot Button-Front Midaxi Dress, $52 at <a href="http://us.topshop.com/en/tsus/product/apricot-button-front-midaxi-8530197" target="_blank" rel="nofollow noopener" target="_blank">Topshop</a></h2>
<p>A dress you could definitely rewear elsewhere.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-33.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003577" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-33/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-33.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-33" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-33.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-33.jpg?w=712" class="aligncenter size-full wp-image-1003577" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-33.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>33. PrettyLittleThing Stripe Wide-Leg Pants, $34 at <a href="https://us.asos.com/prettylittlething/prettylittlething-wide-leg-pants-in-stripe/prd/11538885" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>The beach equivalent of a power suit.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-34.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003578" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-34/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-34.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-34" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-34.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-34.jpg?w=712" class="aligncenter size-full wp-image-1003578" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-34.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>34. Channel Ombre Beach Cover-Up, $45 at <a href="https://us.asos.com/asos-design/asos-design-channel-waist-beach-cover-up-in-ombre-tie-dye/prd/10685177" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>Silky, and tie-dye, and colorful—oh my.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-35.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003579" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-35/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-35.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-35" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-35.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-35.jpg?w=683" class="aligncenter size-full wp-image-1003579" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-35.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>35. Mara Hoffman Luna Maxi Dress, $375 at <a href="https://www.anthropologie.com/shop/mara-hoffman-luna-maxi-dress" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>Leave it to Mara Hoffman to create what can only be described as the cutest swim cover-up I’ve ever seen.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-36.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003580" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-36/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-36.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-36" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-36.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-36.jpg?w=678" class="aligncenter size-full wp-image-1003580" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-36.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>36. Lovewave Reeves Dress, $188 at <a href="https://www.revolve.com/lovewave-reeves-dress/dp/LEWA-WD2/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>In case you prefer your orange stripes in dress form.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-37.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003581" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-37/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-37.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-37" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-37.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-37.jpg?w=683" class="aligncenter size-full wp-image-1003581" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-37.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>37. Fishnet Beach Maxi Kimono, $25 at <a href="https://www.nastygal.com/fishnet-beach-maxi-kimono/AGG74036.html" target="_blank" rel="nofollow noopener" target="_blank">Nasty Gal</a></h2>
<p>A no-fail piece you can throw over anything.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-38.jpg?w=712&amp;h=909"></noscript><img data-attachment-id="1003582" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-38/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-38.jpg" data-orig-size="712,909" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-38" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-38.jpg?w=525" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-38.jpg?w=712" class="aligncenter size-full wp-image-1003582" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="909" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-38.jpg?w=712&amp;h=909" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>38. Seafolly Sunflower Maxi Beach Dress, $177 at <a href="https://us.asos.com/seafolly/seafolly-sunflower-maxi-beach-dress-in-yellow/prd/11180574" target="_blank" rel="nofollow noopener" target="_blank">ASOS</a></h2>
<p>A classic sure to put a smile on your face every time you throw it on.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-39.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003583" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-39/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-39.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-39" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-39.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-39.jpg?w=678" class="aligncenter size-full wp-image-1003583" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-39.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>39. House of Harlow 1960 x Revolve Alhambra Crop, $148 at <a href="https://www.revolve.com/house-of-harlow-1960-x-revolve-alhambra-crop/dp/HOOF-WS284/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Would definitely repurpose this crochet crop for a night out.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-40.jpg?w=712&amp;h=1068"></noscript><img data-attachment-id="1003584" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-40/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-40.jpg" data-orig-size="712,1068" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-40" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-40.jpg?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-40.jpg?w=683" class="aligncenter size-full wp-image-1003584" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-40.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>40. Carolina K Helen Cover-Up Kimono, $368 at <a href="https://www.anthropologie.com/shop/carolina-k-helen-cover-up-kimono" target="_blank" rel="nofollow noopener" target="_blank">Anthropologie</a></h2>
<p>As vibrant and delightful as you are.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-41.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003586" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-41/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-41.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-41" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-41.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-41.jpg?w=678" class="aligncenter size-full wp-image-1003586" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-41.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>41. Beach Riot x Revolve Suki Skirt, $121 at <a href="https://www.revolve.com/beach-riot-x-revolve-suki-skirt/dp/BRIO-WQ5/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Be the wild thang you wish to see in the world.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-42.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003587" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-42/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-42.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-42" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-42.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-42.jpg?w=678" class="aligncenter size-full wp-image-1003587" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-42.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>42. Juliet Dunn Botanical Puff Mini Top, $97 at <a href="https://www.revolve.com/juliet-dunn-botanical-puff-mini-top/dp/JULR-WS2/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>Throw a pair of mom jeans in your beach bag, and this top could take you anywhere.</p>
<p></p><noscript><img src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-43.jpg?w=712&amp;h=1076"></noscript><img data-attachment-id="1003588" data-permalink="https://stylecaster.com/swim-cover-ups/swim-coverups-43/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-43.jpg" data-orig-size="712,1076" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"","camera":"","caption":"","created_timestamp":"0","copyright":"","focal_length":"0","iso":"0","shutter_speed":"0","title":"","orientation":"1"}' data-image-title="swim-coverups-43" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-43.jpg?w=443" data-large-file="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-43.jpg?w=678" class="aligncenter size-full wp-image-1003588" alt="STYLECASTER | 43 Swim Cover-Ups So Cute You'll Wonder How You Ever Lived Without Them" width="712" height="1076" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/04/swim-coverups-43.jpg?w=712&amp;h=1076" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><h2>43. House of Harlow 1960 x Revolve Opal Kimono, $178 at <a href="https://www.revolve.com/house-of-harlow-1960-x-revolve-opal-kimono/dp/HOOF-WO116/" target="_blank" rel="nofollow noopener" target="_blank">Revolve</a></h2>
<p>All kinds of chic.</p>
<p> </p>
<p class="p1"><span class="s1"><i>Our mission at STYLECASTER is to bring style to the people, and we only feature products we think you’ll love as much as we do. Please note that if you purchase something by clicking on a link within this story, we may receive a small commission of the sale. </i></span></p>                                                                                                                                   </div>
                       <script>
                           // wrapper for adding responsive styles, and fix embed overlapping sidebar
                           jQuery('.post_content .wpcom-protected-iframe').wrap('<p class="embed-video-wrapper"></p>')
                       </script>
                               <div class="post_share  comments-visible  pretty_socials clearfix" data-gtm-button-location="Post Share" data-gtm-pin-location="Post Share">
            <ul>
                <li class="facebook">
                    <div>
                        <a href="#" class="pretty_social sc-icon-facebook" data-type="facebook" data-url="https://stylecaster.com/swim-cover-ups/"><span>share</span></a>
                    </div>
                </li><!--
                --><li class="pinterest">
                    <div>
                        <a href="#" class="pretty_social sc-icon-pinterest" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" data-type="pinterest" data-url="https://stylecaster.com/swim-cover-ups/"><span>pin</span></a>
                    </div>
                </li><!--
                --><li class="twitter">
                    <div>
                        <a href="#" class="pretty_social sc-icon-twitter" data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them" data-type="twitter" data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster"><span>tweet</span></a>
                    </div>
                </li><!---
                --><li class="tumblr">
                    <div>
                        <a href="#" class="pretty_social sc-icon-tumblr" data-type="tumblr" data-url="https://stylecaster.com/swim-cover-ups/"><span>tumblr</span></a>
                    </div>
                </li>
                                    <li class="comments">
                        <div>
                            <a href="javascript:void(0);" class="pretty_social sc-icon-comment" data-type="comments"><span class="sc-comments-count spot-im-replies-count" data-post-id="1003542">0</span><span>comments</span></a>
                        </div>
                    </li>
                            </ul>
        </div>
                                       <section class="post_tags modal clearfix">
            <div class="post_tags_category">
                    <span class="more_tag">Tags:</span>
                    <ul>
                                                                                <li><a href="https://stylecaster.com/tag/shopping/" class="tag-item small">Shopping</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/swim-cover-ups/" class="tag-item small">swim cover-ups</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/swimwear/" class="tag-item small">swimwear</a></li>
                                            </ul>
            </div>
        </section>
                           </div>
                   <div class="sidebar_after_post_content">
                                          </div>

                   
        <div data-spotim-module="recirculation" data-spot-id="sp_YAI3K1BD"></div>
        <script async src="https://recirculation.spot.im/spot/sp_YAI3K1BD"></script>
        <script async src="https://launcher.spot.im/spot/sp_YAI3K1BD"
                data-spotim-module="spotim-launcher"
                data-post-url="https://stylecaster.com/swim-cover-ups/"
                data-post-id="1003542">
        </script>
        
                                  </div>
           </article>
        </div>
    </div>

    <div class="post-splitter"></div>
</div>
        </div>
    </div>

    
    <!--Use list element of the schema org for pages there list is present-->
    
    
    <footer class="footer" data-gtm-link-location="Footer">
        <div class="footer-wraper">
            <div class="stretch-clns">

  <div class="hp-column main-logo">
    <a href="https://stylecaster.com"><div class="logo"></div></a>
  </div>

  <div class="hp-column">
    <div class="footer_menu">
      <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" rel="noopener noreferrer" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://corporate.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" rel="noopener noreferrer">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" rel="noopener noreferrer">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" rel="noopener noreferrer">Press</a></li>
</ul></div>    </div>
  </div>

  <div class="hp-column">
    <div class="social_menu" data-gtm-button-location="Footer">
      <div class="menu-global-social-profiles-container"><ul id="menu-global-social-profiles" class="menu"><li id="menu-item-593286" class="sc-icon-mail menu-item menu-item-type-post_type menu-item-object-page menu-item-593286"><a target="_blank" rel="noopener noreferrer" href="https://stylecaster.com/signup/">Signup</a></li>
<li id="menu-item-218288" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-218288"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-218287" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-218287"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-593287" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-593287"><a target="_blank" rel="me" href="https://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-218289" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-218289"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-218291" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-218291"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>    </div>
  </div>

</div>

<div class="copy stretch-clns">
    <div class="hp-column sheknows-wrapper">
        <a class="sheknows-copy" href="http://www.sheknows.com/beauty-and-style" target="_blank"><span>Sheknows Media</span><i>Beauty and Style</i></a>
    </div>
    <div class="hp-column">
        <p class="copyright">
            copyright 2019 &copy; all rights reserved by stylecaster        </p>
        <div class="menu-copyright-menu-container"><ul id="menu-copyright-menu" class="menu"><li id="menu-item-341577" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341577"><a target="_blank" rel="noopener noreferrer" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735575" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735575"><a>Privacy Preference</a></li>
<li id="menu-item-341579" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341579"><a target="_blank" rel="noopener noreferrer" href="https://pmc.com/terms-of-use/">Terms Of Use Agreement</a></li>
<li id="menu-item-218296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218296"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694233"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>    </div>
</div>
<div class="footer-right-bottom-block">
	<div class="footer-copy-right">
		<p class="powered-by">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=stylecaster.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>
	</div>
</div>        </div>
    </footer>

    </div>
<div class="mobile_splash" id="sc-mobile-splash"></div>
<div class="mobile_menu">
    <div class="logo"><a href="https://stylecaster.com">StyleCaster</a></div>
    <div class="close_btn sc-icon-close"></div>
    <div class="mobile_menu_inner">
        <div class="mobile_menu_swipe">
            <div class="menu-new-main-navigation-container"><ul id="menu-new-main-navigation" class="menu"><li id="menu-item-218309" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-218309"><a href="https://stylecaster.com/fashion/">Fashion</a>
<ul class="sub-menu">
	<li id="menu-item-218313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218313"><a href="https://stylecaster.com/fashion-news/">Fashion News</a></li>
	<li id="menu-item-218314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218314"><a href="https://stylecaster.com/street-style/">Street Style</a></li>
	<li id="menu-item-476084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476084"><a href="https://stylecaster.com/tips-trends/">Tips + Trends</a></li>
	<li id="menu-item-218335" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218335"><a href="https://stylecaster.com/shopping/">Shopping</a></li>
	<li id="menu-item-476085" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-476085"><a href="https://stylecaster.com/celebrity-looks/">Celebrity Looks</a></li>
</ul>
</li>
<li id="menu-item-218321" class="beautyhigh-submenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218321"><a href="https://stylecaster.com/beauty/">Beauty</a>
<ul class="sub-menu">
	<li id="menu-item-441672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441672"><a href="https://stylecaster.com/beauty/makeup/">Makeup</a></li>
	<li id="menu-item-476090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476090"><a href="https://stylecaster.com/beauty/hair-nails/">Hair + Nails</a></li>
	<li id="menu-item-441674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441674"><a href="https://stylecaster.com/beauty/skin-care/">Skin Care</a></li>
	<li id="menu-item-503638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-503638"><a href="https://stylecaster.com/beauty/health-fitness/">Health + Fitness</a></li>
</ul>
</li>
<li id="menu-item-218316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218316"><a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-476086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476086"><a href="https://stylecaster.com/home/">Home</a></li>
	<li id="menu-item-476290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476290"><a href="https://stylecaster.com/travel/">Travel</a></li>
	<li id="menu-item-319491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319491"><a href="https://stylecaster.com/food-and-drink/">Food + Drink</a></li>
	<li id="menu-item-476088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476088"><a href="https://stylecaster.com/love-sex/">Love + Sex</a></li>
</ul>
</li>
<li id="menu-item-218842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218842"><a href="https://stylecaster.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-218330" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218330"><a href="https://stylecaster.com/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-218332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218332"><a href="https://stylecaster.com/tv-movies/">TV + Movies</a></li>
	<li id="menu-item-218331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218331"><a href="https://stylecaster.com/music/">Music</a></li>
	<li id="menu-item-476292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476292"><a href="https://stylecaster.com/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-513736" class="menu-item-sctv menu-item menu-item-type-taxonomy menu-item-object-category menu-item-513736"><a href="https://stylecaster.com/sctv/">SCTV</a></li>
</ul></div>
            <div class="newsletter_signup signup-form">
	<h5 class="subscribed-status">WANT <span>MORE?</span></h5>
	<h6 class="subscribed-message">Get STYLECASTER in your inbox</h6>
		<form method="post" class="sc-newsletter-form" autocomplete="off" data-location="expanded-menu" data-source="SignUp-Hamburger">
		<div id="email-validation"></div>
		<input name="additional_information" class="additional_information" type="text" placeholder="Enter Your Email Address" />
		<input name="email" class="email-field" type="text" placeholder="Enter Your Email Address">
		<!-- <div class="newsletter-item">
			<input type="checkbox" checked name="daily" class="daily_newsletter" id="daily_checkbox2" value="1" data-newsletter="daily" />
			<label for="daily_checkbox2"><span></span><p>STYLECASTER Daily</p></label>
		</div>
		<div class="newsletter-item">
			<input type="checkbox" checked name="beauty" class="beauty_newsletter" id="beauty_checkbox2" value="1" data-newsletter="beauty" />
			<label for="beauty_checkbox2"><span></span><p>STYLECASTER Beauty</p></label>
		</div> SPT-135: disabled because of always "yes" value -->
		<input type="submit" class="subscribe-button" value="Submit" />
		<input type="hidden" name="source" value="SC_Menu" />
	</form>
</div>

            <div class="social_menu">
                <div class="menu-expanded-menu-social-container"><ul id="menu-expanded-menu-social" class="menu"><li id="menu-item-609237" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-609237"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-609238" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-609238"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-609239" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-609239"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-609240" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-609240"><a target="_blank" rel="me" href="https://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-609241" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-609241"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>            </div>
            <div class="mobile_footer_menu">
                <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" rel="noopener noreferrer" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://corporate.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" rel="noopener noreferrer">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" rel="noopener noreferrer">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" rel="noopener noreferrer">Press</a></li>
</ul></div>            </div>
            <div class="mobile_copyright_menu">
                <div class="menu-expanded-menu-copyright-container"><ul id="menu-expanded-menu-copyright" class="menu"><li id="menu-item-646562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-646562"><a target="_blank" rel="noopener noreferrer" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735578" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735578"><a>Privacy Preference</a></li>
<li id="menu-item-646563" class="sc-new-line menu-item menu-item-type-custom menu-item-object-custom menu-item-646563"><a target="_blank" rel="noopener noreferrer" href="https://pmc.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-646564" class="no-delimiter menu-item menu-item-type-custom menu-item-object-custom menu-item-646564"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694234"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>            </div>
        </div>
    </div>
</div>
<script>
window.twttr = (function (d,s,id) {
    var t, js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.async=true;
    js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
    return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
}(document, "script", "twitter-wjs"));
</script>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>        <div id="oas_Bottom" class="blogher-ad" data-position="Bottom"></div>
        
<!-- wpcom_wp_footer -->
	<script>
		window.dataLayer_SKM = window.dataLayer_SKM || [];
		</script>
			<div id="amzn-assoc-ad-46b2a569-85af-49b7-bb16-f343ea35b2cc"></div>
		<script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=46b2a569-85af-49b7-bb16-f343ea35b2cc"></script>
		        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","name":"StyleCaster","url":"https:\/\/stylecaster.com"}</script>
                <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Organization","brand":"StyleCaster","name":"StyleCaster","telephone":"(646) 300-8372","foundingDate":2007,"pinterest":"https:\/\/www.pinterest.com\/stylecaster\/","facebook":"https:\/\/www.facebook.com\/stylecaster","twitter":"https:\/\/twitter.com\/StyleCaster","instagram":"https:\/\/www.instagram.com\/stylecaster\/","linkedin":"https:\/\/www.linkedin.com\/company\/stylecaster\/","logo":"https:\/\/s2.wp.com\/wp-content\/themes\/vip\/sc-stylecaster-2016\/public\/assets\/images\/stylecaster-logo.svg","parentOrganization":"Penske Media Corporation","address":"475 Fifth Avenue, New York, NY 10017"}</script>
        <div class="inline-slideshow-zoom-popup">
	<div class="slide-content"></div>
	<i class="sc-close-icon"></i>
</div>
		<div id="single-social-header" class="visible-phone">
			<span class="social-header-text">share</span>
			<ul data-gtm-button-location="Post Sticky Header" data-gtm-link-location="Post Sticky Header">
				<li class="sc-icon-facebook">
					<a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/swim-cover-ups/">Facebook</a>
				</li>
				<li class="sc-icon-pinterest">
					<a class="pretty_social"
					   data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them | StyleCaster"
					   data-media="https://scstylecaster.files.wordpress.com/2019/05/swimcoverups-feat.png" data-type="pinterest"
					   data-url="https://stylecaster.com/swim-cover-ups/">Pinterest</a>
				</li>
				<li class="sc-icon-twitter">
					<a class="pretty_social" data-type="twitter"
					   data-description="43 Swim Cover-Ups So Cute You&#8217;ll Wonder How You Ever Lived Without&nbsp;Them"
					   data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster">Twitter</a>
				</li>
				<li class="sc-icon-tumblr">
					<a class="pretty_social" data-type="tumblr"
					   data-url="https://stylecaster.com/swim-cover-ups/" data-via="StyleCaster">Tumblr</a>
				</li>
			</ul>
		</div>
		<div class="mobile-vertical-slideshow">
	<div class="close-mobile-slideshow-container">
		<a href="javascript:void(0);" class="close-mobile-slideshow"></a>
	</div>
	<div class="slideshow-scroll-container">
		<div class="sc-mobile-slideshow">
			<div class='main-gallery'>
				<div class="scroll-to-see">
					<span></span>
				</div>
				<div class="main-post-title"></div>
				<div class="social_menu">
					<ul id="mobile-slideshow-social-menu"  data-gtm-button-location="mobile slideshow header" class="social-menu-container">
						<li class="sc-icon-facebook menu-item">
							<a class="pretty_social" data-type="facebook" data-url="">Facebook</a>
						</li>
						<li class="sc-icon-pinterest menu-item">
							<a class="pretty_social" data-type="pinterest" data-description="" data-media="" data-url="">Pinterest</a>
						</li>
						<li class="sc-icon-twitter menu-item">
							<a class="pretty_social" data-type="twitter" data-description="" data-url="" data-via="StyleCaster">Twitter</a>
						</li>
					</ul>
				</div>
				<ul class="slides-list slide-images"></ul>
			</div>
			<div class="more-slideshows"></div>
			<ul></ul>
		</div>
	</div>
</div>

<script type="text/template" id="slide-view-template">
	<div class="mobile-slide" data-num="<%- slide.slideNumber %>" data-id="<%- slide.galleryId %>-<%- slide.slideNumber %>" data-name="<%- slide.title %>">
		<div class="slide-number"><%- slide.slideNumber %> <span>of</span> <%- countSlides %></div>
		<% if ( slide.type == "instagram") { %>
		<div class="embedded-instagram-container">
			<div class="embedded-instagram">
				<%= slide.instagram %>
			</div>
		</div>
		<% } else if( slide.type == "tumblr" ) { %>
		<div class="embedded-tumblr-container">
			<%= slide.tumblr %>
		</div>
		<% } else { %>
		<div class="slide-img">
			<img src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-original="<%- slide.mobileUrl %>" height="<%- slide.sizes.height %>" width="<%- slide.sizes.width %>" <% if ( slide.slide_alt) { %>alt="<%= slide.slide_alt %>"<% } %> />
			<noscript><img src="<%- slide.mobileUrl %>" alt="<%- slide.caption %>" /></noscript>
		</div>
		<% } %>
		<% if ( slide.caption || slide.author || slide.title || slide.is_sponsored ) { %>
		<div class="slide-description format">
			<% if ( slide.author ) { %>
				<p class="author ">
				<% if ( slide.creditLabel) { %>
					<%= slide.creditLabel %>:
									 <% } else { %>
					Photo:
				<% } %>
				<span><%= slide.author %></span></p>
			<% } %>
			<% if ( slide.is_sponsored ) { %>
				<p class="slide-sponsored">sponsored</p>
			<% } %>
			<% if ( slide.caption || slide.title ) { %>
				<div class="caption ">
					<% if ( slide.title ) { %>
						<p class="image-title"><strong><%= slide.title %></strong></p>
					<% } %>
					<%= slide.caption %>
				</div>
			 <% } %>
		</div>
		<% } %>
	</div>
</script>

<script type="text/template" id="more_slideshows-view-template">
	<div class="more-slideshow-background-image">
		<img src="<%- slideshow.thumbnail %>" alt="<%- slideshow.title %>"/>
	</div>
	<div class="more-slideshow-background"></div>
	<div class="more-slideshow-content">
		<span><%- slideshow.slideshowTitle %></span>
		<h2 class="slideshow-title" ><%= slideshow.title %></h2>
		<div class="social_menu">
			<ul class="social-menu-container">
				<li class="sc-icon-facebook menu-item">
					<a class="pretty_social" data-type="facebook" data-url="<%- slideshow.permalink %>">Facebook</a>
				</li>
				<li class="sc-icon-pinterest menu-item">
					<a class="pretty_social" data-description="<%= slideshow.pinterestShareCaption %>" data-media="<%= slideshow.pinterestShareImage %>" data-type="pinterest" data-url="<%- slideshow.permalink %>">Pinterest</a>
				</li>
				<li class="sc-icon-twitter menu-item">
					<a class="pretty_social" data-type="twitter" data-description="<%= slideshow.title %>" data-url="<%- slideshow.permalink %>" data-via="StyleCaster">Twitter</a>
				</li>
			</ul>
		</div>
		<a href="<%- slideshow.permalink %>#autoplay" class="start-slideshow" title="<%= slideshow.title %>">
			<%- slideshow.btnTitle %>
		</a>
	</div>
</script>

<script>
	// start slideshow immediately
	if ( location.hash == '#autoplay' && scGetDocumentWidth() < 768) {
		var elem = document.getElementsByClassName("mobile-vertical-slideshow");
		if (typeof elem[0] != 'undefined') {
			elem[0].style.display = 'block';
			document.getElementsByTagName('html')[0].className+='active-popup'
		}
	}
</script>
        <script type='text/javascript'>
            var _sf_async_config = _sf_async_config || {};
            /** CONFIGURATION START **/
            _sf_async_config.uid = 7673; // hardcoded Chartbeat ID
            _sf_async_config.domain = 'stylecaster.com';
            /** Doesn't track custom canonical path **/
                            _sf_async_config.useCanonical = true;
             
                        _sf_async_config.authors = "Lindsey Lanquist";
            
                        _sf_async_config.sections = "fashion,shopping";
                        /** CONFIGURATION END **/

                (function() {
                    function loadChartbeat() {
                        window._sf_endpt = (new Date()).getTime();
                        var e = document.createElement('script');
                        e.setAttribute('language', 'javascript');
                        e.setAttribute('type', 'text/javascript');
                                                    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
                                                document.body.appendChild(e);
                    }
                    var oldonload = window.onload;
                    window.onload = (typeof window.onload != 'function') ?
                        loadChartbeat : function() {
                        oldonload();
                        loadChartbeat();
                    };
                })();
        </script>
    <script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201922y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-15e154be39d0edcc8dce09ac41035951">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/scstylecaster.wordpress.com\/public.api\/connect\/?action=request&domain=stylecaster.com","logoutURL":"https:\/\/scstylecaster.wordpress.com\/wp-login.php?action=logout&_wpnonce=fa776403f4","homeURL":"https:\/\/stylecaster.com\/","postID":"1003542","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1551752381j'></script>
<noscript><img src="https://s3.amazonaws.com/heartbeat.pmc.com/track?host=stylecaster.com&#038;path=%2Fswim-cover-ups%2F&#038;ct=article&#038;lob=&#038;loc=us&#038;env=desktop&#038;post_id=1003542" border="0" width="0" height="0" style="z-index: 0; bottom: -1px; left: -1px; display: inline; position: fixed;" /></noscript>
	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="35011528" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://stylecaster.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="StyleCaster" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="aa869c9bee" /><input type="hidden" name="_wp_http_referer" value="/swim-cover-ups/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytlMtSwzAMRX8I16TTsmP4iLJnFEdJ1PqFLafk71E7HeiwYFPtbEc+uXpc23M2LkXGyPZY7YALOcxfm2N9snefQjPZt4litZ5OWO1nw4YzxMFj+RvMMwYJWSjbHNzPxct68qkHb8YWHVOSQ/nnGdacKHL9h1Odqbx6dFAZi9k+dy82t96TuxAWjEMqAhNVZTUMeRMoquFSc/PhTBk1qSh7fgg4InArElpnKNB7NBRgwqqpksYCAbmAO0mfVdRO8HHNXVVnZRKFwbhWOQVNciOD44hOVy8niVIqaCVGMyMMWh2qriTv35MSDaG42fSgpu7qRSVaSD2JcwLGplk8HHQ7chlvmXIaUK2Ot8xheGyw73xtcsFA7TH7/fIwyUteJlR6JQMIRdHCkizzekiOwN+4b+G12+933W7bbffHbxbFtzY='></script>
<script type='text/javascript' async="async" src='//www.anrdoezrs.net/am/8725733/include/joined/generate/onLoad/impressions/page/am.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/mu-plugins/2-vip/js/vip-analytics.js?m=1411795912h'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"channelUrl":"https:\/\/scstylecaster.wordpress.com\/wp-content\/themes\/vip\/plugins\/facebook\/channel.php","xfbml":true,"appId":"134683123322801"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<div id="fb-root"></div><script type="text/javascript">(function(d){var id="facebook-jssdk";if(!d.getElementById(id)){var js=d.createElement("script"),ref=d.getElementsByTagName("script")[0];js.id=id,js.async=true,js.src="https:\/\/connect.facebook.net\/en_US\/all.js",ref.parentNode.insertBefore(js,ref)}})(document)</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJy1ks1OQjEQhV/IUkEhbow7ExasfIK57XCZS/+YaSG8vb0E0ZCYGCm7pjn9eubM0YekTAwZQ9a+qORKT0E0WE9BdcDag2TkelJxj8xkUb7vJoM86L8TMoPZyvWjvEFfoXtKWoySfHRoTk/U7HG60Kl0joweqgKDjSx62BXkozLAsbwz2g90ajGp3/2bvEbIhas0IZOYmPAm3JdRMRydW8VAOXIjg9CjKslCFf0kUjCujLup4hIscp2C8TdFV/fQxXDblBdPPnbkUNV6ZDLglLixJZt4aBLiedsbkhrisY3jam+b45iJo4CNDF/oF5xy0KFrmYLEALc16Rp4qqiHnsydsMpiV/o2yd63Ynywy2oZV5CkjV8accpDShQaRQBmV0goUwwjZY0505n85l+n8/liNn2avzwPn2Z/KyE='></script>
<script type='text/javascript' src='https://platform.instagram.com/en_US/embeds.js?ver=5.2.2-alpha-45379'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/stylecaster.com\/wp-admin\/admin-ajax.php","nonce":"1364055409","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/scstylecaster.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fstylecaster.com%2Fswim-cover-ups%2F","blog_id":"35011528","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=35011528&v=wpcom&tz=-4&user_id=0&subd=scstylecaster","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyt01FPAyEMB/AvZI/d4nQvxs/CuN4NRmmlMDM/vZg7zR58UhISEvLvLyRtzbuA41QwFVPOSKjm6sWoAy23iM5qwQz73fhkpJ6idya0BKaJs5rwVjHfIDibuSrGgXwagj6Yv6Az2lJzi+qZRXxagHiqETuhLnOMULgd6UM6JmqVCqvdBy1WAOcZXenjkb0gX1tAun3Rk11QG0Bic6f2EJ98RPhgJlj9f7nyJRhtQ9RrfnyaffIFt2Y3+d71ycU6tVgrUfn9fV2W7RruU9+/ogoS6+JTm61to0zAItZd4GfFgr7Sy3g4PD+Ox+NuHz4B6tJiSQ=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?60" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'35011528','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'35011528','v':'wpcom','tz':'-4','user_id':'0','post':'1003542','subd':'scstylecaster'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=35011528&v=wpcomvt&tz=-4&user_id=0&post=1003542&subd=scstylecaster&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcweC5+TS4lUFRfaG98WnVnRmpSQyxOLitPcGlZM3Y1YnQ0UXd+M1NddTE4eXVIPzVfY2k3W1hiTWZkbzM4L1M9WWRDWXJ5dThdW0hkLWljOHNxX1I3ZFd0Y2Jta3pLZW04Z1hPP24/LzBvfl1OSXlQZi5beCZtemE/L1QzUEg0aH5aVUdyYTNvOExwUnJ3YnFrKyVFeWdjcUklUWJ3VitVN3k1OWIlL0QwWEFtfENOVTlwJjdBVVszeGR8fGxFa0dn'}]);
_stq.push([ 'clickTrackerInit', '35011528', '1003542' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script><!-- pmc-tags-bottom Comscore -->
	<script type="text/javascript">
var _comscore = _comscore || []; _comscore.push({ c1: "2", c2: "6035310", c3: "", c4: "", c5: "", c6: "", c15: "" }); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })();
	</script>
<!-- end pmc-tags-bottom Comscore --><!-- pmc-tags-bottom Instinctive -->	<script async src="https://load.instinctiveads.com/i.js" class="script-mobile"></script>
<!-- end pmc-tags-bottom Instinctive -->
</body>
</html>
<!--
	generated 164 seconds ago
	generated in 0.992 seconds
	served from batcache in 0.003 seconds
	expires in 136 seconds
-->
