<!doctype html>
<!--[if lt IE 7]>      <html class="ie6" lang="en"> <![endif]-->
<!--[if IE 7]>         <html class="ie7" lang="en"> <![endif]-->
<!--[if IE 8]>         <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>         <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en">         <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<title>Must-See Oscars 2019 Men&#8217;s Fashion | StyleCaster</title>

    <link rel="apple-touch-icon" sizes="192x192" href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/apple-touch-icon-192x192.png" />
    <link rel="shortcut icon"  href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.ico" />

    <link rel="icon" sizes="32x32" type="image/png"  href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.png" />
    <link rel="icon" sizes="192x192" type="image/png" href="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-192x192.png" />

	        <script type='text/javascript'>
            /**
             * Restoring jQuery object if 3rd party plugins is removed/override jQuery
             */
            (function (w) {
                // Latest jQuery value
                var latestValue = undefined;

                // First jQuery value
                var firstValue = undefined;

                // Add getter and setter for jQuery
                Object.defineProperty(w, 'jQuery', {

                    // jQuery getter
                    get: function () {
                        // if latest version jQuery is a function then return latest jQuery version
                        // if latest version jQuery is not a function then return first jQuery version
                        return ( 'function' === typeof latestValue ) ? latestValue : firstValue;
                    },

                    // jQuery setter
                    set: function (value) {
                        // override latesr jQuery version
                        latestValue = value;
                        // set up first jQuery version
                        if ('undefined' === typeof firstValue && 'function' === typeof value) {
                            firstValue = value;
                        }
                    }
                });

            })(window);
        </script>
        
	
<meta name="description" content="Every award show this year has boasted amazing men&#039;s fashion, and the 2019 Oscars are no different. All the celebrities came to slay, and we found the hottest looks from this year&#039;s Academy Awards." />
<meta name="keywords" content="men&#039;s fashion, men&#039;s fashion grammys 2019, men&#039;s fashion red carpet, grammys 2019 red carpet" /><meta name="msvalidate.01" content="7A34A1C1904BAFB83691E8B3718CA9A2" />
<meta property="article:publisher" content="https://www.facebook.com/stylecaster" />
<meta name="google-site-verification" content="yB_5UwT5pPNnn93Mba5HIaFkNtbrafDQWP_Rj34Iw08" />

<script type="text/javascript">dataLayer = window.dataLayer || []; /* Google Tag Manager */</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_meta = {"lob":"","page-type":"article","env":"desktop","primary-category":"Celebrity Looks","primary-vertical":"","vertical":"","category":["Celebrity Looks","Fashion"],"tag":["celebrity looks","Grammys 2019","men's fashion","red carpet"],"author":["Maggie Griswold"],"logged-in":"","subscriber-type":"","country":"us"};

/* ]]> */
</script>
		<script>
			(function(d,w){
				var i, parts, name, c, rdecode = /(%[0-9A-Z]{2})+/g, rspace = /\+/g, ac = (d ? d.split('; ') : []);
				for(w.pmc_cookies = {}, i = 0; i < ac.length; i++) {
					parts = ac[i].split('='), name = parts[0].replace(rdecode, decodeURIComponent), c = parts.slice(1).join('=');
					if(c.charAt(0) === '"') { c = c.slice(1, -1); } c = c.replace(rdecode, decodeURIComponent).replace(rspace, ' '); w['pmc_cookies'][name] = c;
				}
			})(document.cookie, window);

			pmc_meta=pmc_meta || {}, pmc_meta.omni_visit_id = window.pmc_cookies.omni_visit_id || "pmc." + new Date().getTime() + '.' + (function(l,b,a,c,i,d){for(i=0;i<256;i++){l[i]=(i<16?'0':'')+(i).toString(16);}if(c&&c.getRandomValues){try{d=new Uint32Array(4),c.getRandomValues(d);}catch(e){d=0;}}d=d||[b()*a>>>0,b()*a>>>0,b()*a>>>0,b()*a>>>0];a=d[0],b=d[1],c=d[2],d=d[3];return l[a&0xff]+l[a>>8&0xff]+l[a>>16&0xff]+l[a>>24&0xff]+'-'+l[b&0xff]+l[b>>8&0xff]+'-'+l[b>>16&0x0f|0x40]+l[b>>24&0xff]+'-'+l[c&0x3f|0x80]+l[c>>8&0xff]+'-'+l[c>>16&0xff]+l[c>>24&0xff]+l[d&0xff]+l[d>>8&0xff]+l[d>>16&0xff]+l[d>>24&0xff];})([],Math.random,0x100000000,window.crypto||window.msCrypto);
			var d = new Date(); d.setTime(d.getTime() + ( 60 * 60 * 1000 )); var expires = d.toGMTString(); var path = "/"; var domain = window.location.hostname;
			document.cookie = 'omni_visit_id=' + encodeURIComponent(pmc_meta.omni_visit_id) + ( expires ? '; expires=' + expires : '' ) + ( path ? '; path=' + path : '' ) + ( domain ? '; domain=' + domain : '' );
		</script>
				<script type="text/javascript">
		if( window.hasOwnProperty( 'pmc_meta' ) ) {
			if( !window.hasOwnProperty( 'dataLayer' ) || !window.dataLayer.hasOwnProperty('push') ) {
				window.dataLayer = [];
			}
			window.dataLayer.push( pmc_meta );
		}
		</script>

		           <meta id="ad_wrapper_script" data-unit-name="fashion/celebrity-looks"/>
           <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />            <script type="text/javascript" src="//content.jwplatform.com/libraries/ZNyazssg.js"></script>
                <!-- Facebook Pixel Code -->
        <script>
            !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
                n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
                n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
                t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
                document,'script','//connect.facebook.net/en_US/fbevents.js');
            // Insert Your Facebook Pixel ID below.
            fbq('init', '1130306277008218');
            fbq('track', 'PageView');
        </script>
        <noscript>
            <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1130306277008218&amp;ev=PageView&amp;noscript=1" />
        </noscript>
        <!-- End Facebook Pixel Code -->

        <!--Additional template-specific events for Facebook Pixel-->
                            <script id="facebook-page-type" data-facebook-page-type="page-vertical_slideshow">
                if ( typeof fbq != 'undefined' ) {
                    fbq('track', "page-vertical_slideshow");
                }
            </script>
        
                <script>
            (function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//comfortablecheese.com/0d54dab07da3e2c70e4c904001da3e0bcca526db5e6852893a5d2314eea316b18afeeb8af05e9b4e159a27858787b043438981d6a081e3ab397073de7b62');
        </script>
        		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=stylecaster.com&amp;id=35011528&amp;t=1551050618&amp;back=https%3A%2F%2Fstylecaster.com%2Foscars-mens-fashion-2019%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//www.anrdoezrs.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//scstylecaster.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Feed" href="https://stylecaster.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Comments Feed" href="https://stylecaster.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So Far Comments Feed" href="https://stylecaster.com/oscars-mens-fashion-2019/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1550249335h&ver=5.1-RC2-44763"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJylUM1uwyAMfqFRr1UX5TLtWcBxW6cYGIZWefuSRKumbcplF2R/f7aBezIYQ6FQQKpJvp45KNwTRjEq7Gn60e1Q9QX+tnm+ksJIJVm8mqV7yjmgr0OjGwADawHn46Jy2eYJtEyedsJhawDGTA2XZMusEBrYkidpsi2bpO7LNZeXtt3mHevBzqVMqqa9wlVMubRBv30rDDdOkASfGXN99tFZb041YOEY1tu/EfFGOfOwHapolr9Bq4WyObzuO0jVecYl7tQc//GPn5XyZEpsdJ5zPuR9/3bs+r4/dofxAaEayy4=?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJytkeFOwzAMhF+I1C1bmfYD8SxulqUGNy61w7S3X9ZqmiZEhQT/fNH5y+UCp9F5SRaSgfVhCApfNIJ6p3bm4FEtTO65bl5gzB2TB68KI8ZiVEqRQ1UOnuDPGIf+M5OSkaT/Qm5qd8CzfsMN2Y2cIyWFEx1isLIhnpAdFcujWMtygygSWz9lt6maOcVCrdRLtgVAkMQW+m1YixWDOBaP1zYehDsy0rS2OoWOJZYxzlHu8jcvOaIPncgHqJXrlkrnuquBfvyWfguRpUO+Gt6G16bd1vt92+527xdLneB4?cssminify=yes' type='text/css' media='all' />
<script type="text/javascript" src="https://s1.wp.com/wp-content/themes/vip/pmc-plugins/pmc-global-functions/js/pmc-utils.js?m=1543349140h"></script>			<script type="text/javascript">
			var pmc_do_analytics_pagecount = true;		//flag to allow analytics code to count a page view
			var pmc_common_urls = {
				parent_theme_uri: 'https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/',
				current_theme_uri: 'https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/',
				fb_channel_uri: 'https://s1.wp.com/wp-content/themes/vip/pmc-plugins/partner/facebook/channel.html'
			};
			</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sc_ajax_script = {"ajaxurl":"\/wp-admin\/admin-ajax.php","siteurl":"https:\/\/stylecaster.com"};
var scMainData = {"isPreview":"false"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var scAdvertisingConfig = {"vertical":"fashion\/celebrity-looks","globalTargeting":{"liveinsite":"segments","url":["https:\/\/stylecaster.com\/oscars-mens-fashion-2019\/"],"dm_content":"false","tag":["celebrity looks","Grammys 2019","men's fashion","red carpet"],"Article_Category":["Celebrity Looks","Fashion"],"ct":["vertical_slideshow"],"ci":"987967"},"pageType":"single","isSponsored":"false"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sc_newsletter_wp_vars = {"nonce":"71dec8d924"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytkd1OwzAMRl+ILPuhk7hA3KBd8wpp6nbuEifETqvy9MumTYCo4IJKkRLZR8efFT1GhWRdboB1X857hjTdrlXPD/o3QHnskhFYeaQ7bAMJkFzYGFg8MJsOZro+1OhAZYZUAJIypg0z3PdISAPC+CfWg0RjTyoB48eP6XKEkksPGHX0VkWXOyS+vjsXauNUm8kKBrru/FmfW/SLjK1imRxYwwJJbdebvY65dmgvmhaM5BJIxwQumAbSMjpvkNQRTLOMzjRqTCbGpeKxfT28/Us1ADUh3b+4kGhPk7KZJfiFMmJHOd5cL/55U1Xr7ePTblf1Z5Y3KHM='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scstylecaster.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://stylecaster.com/oscars-mens-fashion-2019/" />
<link rel='shortlink' href='https://wp.me/p2mU64-490X' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fstylecaster.com%2Foscars-mens-fashion-2019%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fstylecaster.com%2Foscars-mens-fashion-2019%2F&amp;for=wpcom-auto-discovery" /><link rel='openid.server' href='https://scstylecaster.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://scstylecaster.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://stylecaster.com/osd.xml" title="StyleCaster" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="author" content="Maggie Griswold">        <meta id="ad_wrapper_script" data-unit-name="fashion/celebrity-looks" />
                <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
        		<script class="gtm-script-container" type="text/javascript">
			;(function(){
				// save url from which user came to the site to cookies.
				// We set cookie with help js because wordpress vip prohibits the cookies on the server side
				if (document.referrer && document.referrer.split('/')[2] != document.domain) {
					setCookie('sc_gtm_original_url', document.referrer, null);
				}

				_gtmq = [{
					'page_version': isLayout.get(),
					'full_URL': "https:\/\/stylecaster.com\/oscars-mens-fashion-2019\/",
					'base_URL': "https:\/\/stylecaster.com\/oscars-mens-fashion-2019\/",
					'query_Parameters': "",
					// --- DEPRECATED START ---
					// let's leave it in the comments to keep the store
					// 'is_Parallax': ,
					// 'is_OriginalVideo': ,
					// 'is_OriginalPhoto': ,
					// 'is_Slideshow': ,
					// 'is_ContentCreator': ,
					// 'is_Shoppable': ,
					// --- DEPRECATED END ---


										'site_section': "stylecaster",
					
					'source_site_of_post' : "stylecaster",

					'dm2sc': "0",

					// post params
											'post_author': "Maggie Griswold",
						'post_published': "02 2019",
						'post_published_full': "02-24-2019 18:17",
						'post_published_date': "2019-02-24",
						'post_url': "https://stylecaster.com/oscars-mens-fashion-2019/",
						'post_title': "Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So Far",
						'histurl': null,
						// add type to characterize same events on different slideshows
																			'post_tags': "|1391597||374270012||85024||35588414|",
																			'post_categories': "Celebrity Looks|Fashion",
																			'main_categories': "Fashion",
																			'sub_categories': "Celebrity Looks",
													'article_id': "987967",
												'slide_num': null,
												'virtual_page_url': "\/oscars-mens-fashion-2019\/",
						'post_position_in_page': '1',
					
					// tag page params
					
					// result search page params
					
					// category page params
					
					// author page params
					
					// archive page params
					
					// meta data
					'meta_title': jQuery("title").text(),

					// page params
					'page_type': "single-vertical_slideshow",
					'referrer_original': getCookie('sc_gtm_original_url') ? getCookie('sc_gtm_original_url') : '',

										// Original WP post data
					'wp_post_type' : "post",
					
					'user_ip': "",
					'user_agent': navigator.userAgent
				}];

				// add utm params to _gtmq
				var temp;
				if (temp = getUrlParam(window.location.href, 'utm_source')) {
					_gtmq[0].utm_source = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_medium')) {
					_gtmq[0].utm_medium = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_campaign')) {
					_gtmq[0].utm_campaign = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_term')) {
					_gtmq[0].utm_term = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_content')) {
					_gtmq[0].utm_content = temp;
				}
			})();
		</script>
				<script>
			(function(w){
				w.dataLayer_SKM = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Celebrity Looks","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":987967,"contentArticleTitle":"Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So Far","contentPublishedDate":"2019-02-24","contentPublishedMonthYear":"2019-02","contentPublishedTimestamp":"2019-02-24-18-17-25","contentOriginalPublishedTimestamp":"2019-02-24-18-17-25","cmsAuthorId":"955030","momentumAuthorId":"_na_","contentAuthorName":"Maggie Griswold","articleCategories":"Celebrity Looks|Fashion","contentTags":"celebrity looks|Grammys 2019|men's fashion|red carpet","geoTarget":"US","pageFormat":"Article","editorialCategories":"Trending News","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_","scrollable":true,"infiniteScrollPageNum":1},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
				w.dataLayer_NA = "_na_";
				w.dataLayer_INTRO_SLIDE = "Intro";
			})(window);
		</script>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="StyleCaster" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Style News and Trends" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://stylecaster.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/f95e80beb275448b98a924f84cc3473a?s=16" /><script type="text/javascript">
/* <![CDATA[ */
var pmc_site_config = {"rot13_hostname":"fglyrpnfgre.pbz","hostname":"stylecaster.com","is_proxied":null};

/* ]]> */
</script>
		<script type='text/javascript'>
			var pmc_tracking_url = "https://s3.amazonaws.com/heartbeat.pmc.com/track?host=stylecaster.com&path=%2Foscars-mens-fashion-2019%2F&ct=article&lob=&loc=us&env=desktop&post_id=987967";
			var pmc_tracking_image = new Image();
			if ( 'undefined' !== typeof pmc_meta && 'string' === typeof pmc_meta.omni_visit_id ) {
				pmc_tracking_url = pmc_tracking_url + '&omni_visit_id=' + pmc_meta.omni_visit_id;
			}
			if ( 'string' === typeof window.location.hash && window.location.hash.length ) {
				pmc_tracking_url = pmc_tracking_url + "&h=" + encodeURIComponent( window.location.hash );
			}
			pmc_tracking_image.src = pmc_tracking_url + "&ts=" + Date.now();
		</script>
		<meta property="og:site_name" content="StyleCaster" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="134683123322801" />
<meta property="og:url" content="https://stylecaster.com/oscars-mens-fashion-2019/" />
<meta property="og:title" content="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So Far" />
<meta property="og:description" content="And the 2019 Oscars are no different." />
<meta property="article:published_time" content="2019-02-24T23:17:25+00:00" />
<meta property="article:modified_time" content="2019-02-24T23:17:25+00:00" />
<meta property="article:author" content="Maggie Griswold" />
<meta property="article:section" content="Celebrity Looks" />
<meta property="article:tag" content="Fashion" />
<meta property="article:tag" content="celebrity looks" />
<meta property="article:tag" content="Grammys 2019" />
<meta property="article:tag" content="men&#039;s fashion" />
<meta property="article:tag" content="red carpet" />
<meta property="og:image" content="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" />
<meta property="og:image:width" content="868" />
<meta property="og:image:height" content="490" />
<script type="text/javascript">
/* <![CDATA[ */
var pmc_krux = {"lob":"","page-type":"article","env":"desktop","primary-category":"Celebrity Looks","primary-vertical":"","vertical":"","category":["Celebrity Looks","Fashion"],"tag":["celebrity looks","Grammys 2019","men's fashion","red carpet"],"author":["Maggie Griswold"],"logged-in":"","subscriber-type":""};

/* ]]> */
</script>
<style type="text/css" id="syntaxhighlighteranchor"></style>
                <script type="text/javascript" src="https://ads.blogherads.com/bh/1/1/1/2208790/header.js" async="async"
                    data-cfasync="false"></script>
            <script type="text/javascript" src="https://ads.blogherads.com/static/blogherads.js" async="async"
                    data-cfasync="false"></script>
            
	<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@stylecaster" /><meta name="twitter:creator" content="@stylecaster" /><meta name="twitter:title" content="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far"/><meta name="twitter:description" content="And the 2019 Oscars are no different."/><meta name="twitter:image" content="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg"/><meta property="twitter:account_id" content="55678606" />        <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
        <!--[if lt IE 9]>
        <script src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/html5shiv.min.js"></script>
        <script src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/respond.min.js"></script>
        <![endif]-->
                <meta property="fb:pages" content="48566051011" />
        <meta property="fb:article_style" content="scdefault">
        </head>
<body class="post-template-default single single-post postid-987967 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light pmc-desktop pmc-no-tablet pmc-no-mobile geo-us" data-paged="1" data-siteurl="https://stylecaster.com">

<div class="wrapper">
    
        <header class="header hide-when-active-popup" id="siteheader" data-gtm-link-location="Header"  >
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </header>
    
        <div class="siteheadersticky header" id="siteheadersticky" data-gtm-link-location="Header">
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="https://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="https://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </div>
        
            <div class="header" id="singleheader"  data-gtm-nav-show="0" data-gtm-link-location="PostNavBar">
        <div class="container shadow">
            
<div class="main">
    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    <div class="logo_delimiter"></div>
    <div class="logo hidden-phone">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>
    <div class="post_header_title">
                    <span>Share</span>
                <div class="social_menu square">
            <ul id="single-header-social-menu" class="social-menu-container" data-gtm-button-location="PostNavBar">
                <li class="sc-icon-facebook menu-item">
                    <a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Facebook</a>
                </li>
                <li class="sc-icon-pinterest menu-item">
                    <a class="pretty_social" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" data-type="pinterest" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Pinterest</a>
                </li>
                <li class="sc-icon-twitter menu-item">
                    <a class="pretty_social" data-type="twitter" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster">Twitter</a>
                </li>
                <li class="sc-icon-tumblr menu-item">
                    <a class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster">Tumblr</a>
                </li>
            </ul>
        </div>
        <h2 itemprop="name">Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far</h2>

    </div>
</div>


<div class="main_menu">
    <div class="hot-block">
        <i class="icon-fire"></i>
        <span>What's hot</span>        
    </div>
    <div class="post_prev_next_vav">
        <span class="trigger next">
            <i class="sc-icon-arrow-right"></i>
        </span>
        <span class="trigger back inactive">
            <i class="sc-icon-arrow-left"></i>
        </span>
    </div>
    <div id="sliderNexPrev" class="iner">
        <div class="post_prev_next next hidden-phone hidden-tablet-portrait scpin-no">
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/plus-size-party-dresses/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/02/plus-size-dresses.jpg?w=120&#038;h=120&#038;crop=1" alt="Your Everything Guide to Plus-Size Party Dresses" />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Your Everything Guide to Plus-Size Party Dresses								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/kendall-jenner-ivory-dress/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2018/09/kendall-jenner.jpg?w=120&#038;h=120&#038;crop=1" alt="Just When We Thought Kendall Jenner Couldn&#039;t Surprise..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Just When We Thought Kendall Jenner Couldn&#039;t Surprise...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/spring-cardigans/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/02/cardigan.jpg?w=120&#038;h=120&#038;crop=1" alt="It&#039;s Never Too Early to Find Your Go-To Spring Cardigan..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									It&#039;s Never Too Early to Find Your Go-To Spring Cardigan...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/essence-black-women-in-hollywood-photos/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/02/shutterstock_10114685l-e1550857042427.jpg?w=120&#038;h=120&#038;crop=1" alt="The Essence Black Women In Hollywood Awards Luncheon..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									The Essence Black Women In Hollywood Awards Luncheon...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/nyfw-2019-fashion-trends/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2019/02/fall-fashion-fi.jpg?w=120&#038;h=120&#038;crop=1" alt="7 Can&#039;t-Miss Trends from New York Fashion Week Fall..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									7 Can&#039;t-Miss Trends from New York Fashion Week Fall...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
			        </div>
    </div>
</div>        </div>
    </div>
    
    <div class="wrapper-header-ad-slot hidden-phone">
	<div class="header-ad-slot">
		<div class="header slideshow-header sc-top-ad">
			<div class="container">
				<div class="mobile_menu_trigger">
					<div class="border-menu"></div>
				</div>
				<div class="logo_delimiter"></div>
				<div class="logo-small visible-desktop visible-tablet">
					<a href="https://stylecaster.com">StyleCaster</a>
				</div>
								<div class="slideshow-ad-top-block">
					<div id="oas_Top2" class="sc-ad-init" data-position="Top2" data-internal-section="SlideShow"></div>
				</div>
			</div>
		</div>
	</div>
</div>
    <!--Use list element of the schema org for pages there list is present-->
    
            <div class="page_content_container ">
        <div id="skin">
            <div class="isa_post_container" data-viglink-disable="false" data-is-sponsored="false" data-post-id="987967" data-post-type="vertical_slideshow" data-post-authors="Maggie Griswold" data-categories-slug="celebrity-looks,fashion" data-categories="Celebrity Looks,Fashion" data-tags="celebrity looks,Grammys 2019,men&#039;s fashion,red carpet" data-page-title="Must-See Oscars 2019 Men&#8217;s Fashion &laquo;  StyleCaster" data-gtm-article-type="vertical_slideshow" data-facebook-page-type="page-vertical_slideshow" data-page-title-gtm="Must-See Oscars 2019 Men&#8217;s Fashion | StyleCaster" href="https://stylecaster.com/oscars-mens-fashion-2019/" data-page-format="Article">
    		<script>
			if( 'undefined' == typeof scGtmPremiumData ) {
				window.scGtmPremiumData = {};
			}
			window.scGtmPremiumData[987967] = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Celebrity Looks","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":987967,"contentArticleTitle":"Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far","contentPublishedDate":"2019-02-24","contentPublishedMonthYear":"2019-02","contentPublishedTimestamp":"2019-02-24-18-17-25","contentOriginalPublishedTimestamp":"2019-02-24-18-17-25","cmsAuthorId":"955030","momentumAuthorId":"_na_","contentAuthorName":"Maggie Griswold","articleCategories":"Celebrity Looks|Fashion","contentTags":"celebrity looks|Grammys 2019|men's fashion|red carpet","geoTarget":"US","pageFormat":"Article","editorialCategories":"Trending News","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_"},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
		</script>
		        <div class="container">
        <div class="content-split sc-section_single sc-section-can-stiky">
            <aside class="sc-sidebar sc-sidebar-single visible-desktop">
              <div class="sc-adv-wrap">
                  <div class="sc-adv-wrap-help">
                      <div id="sc_adwrapperunit-4" class="widget widget_sc_adwrapperunit">
        <div class="sc-ad-init" id="oas_Middle3" data-position="Middle3"></div>
        
        </div>
                  </div>
              </div>
            </aside>
            <article class="main_content_area sc-main_content  vertical-slideshow" itemscope itemtype="https://schema.org/Article">
                <meta itemprop="mainEntityOfPage" content="https://stylecaster.com/oscars-mens-fashion-2019/" />
                <meta itemprop="name" content="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" />
               <div class="sc-single-column">
                   <div class="article " data-current-url="https://stylecaster.com/oscars-mens-fashion-2019/"   data-next-url="https://stylecaster.com/elsie-fisher-oscars-2019-look/" >
                       <header>
                           
                           
                           
                                                                                     <h1 itemprop="headline">Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far</h1>
                           
                           <div class="post_detail">
                               <div class="post_head_detials" data-gtm-button-location="Post Shared Count">
                                   <div class="sc-column">
                                               <ul class="sharecount-social-btns social_menu colored ">
            <li class="menu-item sc-icon-facebook"><a href="javascript:void(0);" class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Facebook</a></li>
            <li class="menu-item sc-icon-pinterest"><a href="javascript:void(0);" class="pretty_social" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" data-type="pinterest" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Pinterest</a></li>
            <li class="menu-item sc-icon-twitter"><a href="javascript:void(0);" class="pretty_social icon-twitter" data-type="twitter" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster">Twitter</a></li>
            <li class="menu-item sc-icon-tumblr"><a href="javascript:void(0);" class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Tumblr</a></li>
                            <li class="menu-item sc-icon-comment"><span class="sc-comments-count spot-im-replies-count" data-post-id="987967">0</span></li>
                    </ul>
                                           </div>
                                   
                                   <div class="sc-column">

                                       <div class="sc-post-avatar"><img alt='Maggie Griswold' src='https://0.gravatar.com/avatar/c4d21c8b748f861c07fd8fc4b3005385?s=96&#038;d=identicon&#038;r=G' class='sc-desaturate-image scpin-no avatar avatar-96' height='0' width='0' /></div>                                       
                                                                              <span class="sc-post-author">by<span itemprop="author"><a href="https://stylecaster.com/author/maggiegriswold93/" title="Posts by Maggie Griswold" class="author url fn" rel="author">Maggie Griswold</a></span></span>

                                                                              
                                                                              <span itemprop="datePublished" content="2019-02-24T18:17:25-05:00" class="sc-post-date hidden-phone">6 mins ago</span>
                                       <meta itemprop="dateModified" content="2019-02-24T18:17:25+00:00" />
                                               <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
            <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                <meta itemprop="url" content="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/base64/Stylecaster-logo.png">
                <meta itemprop="width" content="600">
                <meta itemprop="height" content="60">
            </div>
            <meta itemprop="name" content="StyleCaster">
        </div>

                                           </div>
                               </div>
                           </div>
                           
                           
                <div class="sc_feature_image_container " itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <img src="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" title="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" alt="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" />
            <meta itemprop="url" content="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" />
            <meta itemprop="width" content="712" />
            <meta itemprop="height" content="400" />
                    </div>

                            <div class="photo-detail">Photo:
                                    <span class="source">Dimitrios Kambouris/Getty Images for Turner.</span>
                            </div>
        
                                           
                                                      
                                                      
                       </header>
                       <div class="post_content format clearfix" data-gtm-pin-location="PostContent" itemprop="articleBody">
                                                          <p class="scroll-to-see-more d-none">Scroll To See More Images</p>
                                                      <?xml encoding="utf-8" ?><p class="big_first_letter">Let’s hear it for the boys this year. While most of award show fashion highlights the ladies of the entertainment industry, let’s not forget some of the most iconic looks have come from the men. Leading up to—and including—the <a href="https://www.hollywoodreporter.com/news/men-oscar-red-carpet-a-brief-history-male-peacocking-1187974" target="_blank" rel="noopener noreferrer" target="_blank">2019 Oscars, men’s fashion</a> has been one of the unexpected highlights of awards season thus far. We’re talking Timothee Chalamet, Michael B Jordan, John Legend, Darren Criss and countless others gracing us with some truly amazing red carpet looks. The most recent Academy Awards <a href="https://www.esquire.com/style/mens-fashion/g26379698/oscars-best-dressed-men-academy-awards/" target="_blank" rel="noopener noreferrer" target="_blank">looks from Billy Porter, Stephen James, Adam Lambert</a> and myriad others continue to remind us that the boys are here to slay.</p>
<p>Each of these celebs brought their unique style to the red carpet, and we can’t look away. We don’t know who allowed these gents to look so handsome, but we’re certainly not mad about it. We rounded up the <a href="https://www.post-gazette.com/ae/movies/2019/02/24/PittsburghBilly-Porter-Oscars-red-carpet-ABC-style-fashion-awards-ceremony/stories/201902240191" target="_blank" rel="noopener noreferrer" target="_blank">hottest of this year’s Oscars men’s fashion</a>, and we have to say, there is some <em>serious </em>eye candy.</p>
<div id="attachment_991754" style="width: 722px" class="wp-caption aligncenter">
<noscript><img src="https://scstylecaster.files.wordpress.com/2019/02/10112734j.jpg?w=712&amp;h=762"></noscript>
<img aria-describedby="caption-attachment-991754" data-attachment-id="991754" data-permalink="https://stylecaster.com/oscars-mens-fashion-2019/91st-annual-academy-awards-arrivals-los-angeles-usa-24-feb-2019-8/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/02/10112734j.jpg?w=712&amp;h=762" data-orig-size="3388,3626" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"David Fisher\/REX\/Shutterstock","camera":"","caption":"Mandatory Credit: Photo by David Fisher\/REX\/Shutterstock (10112734j)\r\nBilly Porter\r\n91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","created_timestamp":"0","copyright":"Copyright (c) 2019 Shutterstock. No use without permission.","focal_length":"0","iso":"0","shutter_speed":"0","title":"91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","orientation":"0"}' data-image-title="91st Annual Academy Awards, Arrivals, Los Angeles, USA – 24 Feb 2019" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/02/10112734j.jpg?w=712&amp;h=762?w=626" data-large-file="https://scstylecaster.files.wordpress.com/2019/02/10112734j.jpg?w=712&amp;h=762?w=957" class="wp-image-991754" alt="10112734j Mens Fashion Has Been the Unexpected Highlight of Awards Season So Far" width="712" height="762" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/02/10112734j.jpg?w=712&amp;h=762" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-991754" class="wp-caption-text">David Fisher/REX/Shutterstock.</p>
</div>
<p>Billy Porter stepped out on the red carpet wearing a tuxedo dress with ruffled sleeves, and it was instantly iconic.</p>
<div id="attachment_991755" style="width: 1034px" class="wp-caption aligncenter">
<noscript><img src="https://scstylecaster.files.wordpress.com/2019/02/10112734t.jpg?w=1024&amp;h=1536"></noscript>
<img aria-describedby="caption-attachment-991755" data-attachment-id="991755" data-permalink="https://stylecaster.com/oscars-mens-fashion-2019/91st-annual-academy-awards-arrivals-los-angeles-usa-24-feb-2019-9/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/02/10112734t.jpg?w=1024&amp;h=1536" data-orig-size="3241,4862" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"David Fisher\/REX\/Shutterstock","camera":"","caption":"Mandatory Credit: Photo by David Fisher\/REX\/Shutterstock (10112734t)\r\nRyan Seacrest\r\n91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","created_timestamp":"0","copyright":"Copyright (c) 2019 Shutterstock. No use without permission.","focal_length":"0","iso":"0","shutter_speed":"0","title":"91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","orientation":"0"}' data-image-title="91st Annual Academy Awards, Arrivals, Los Angeles, USA – 24 Feb 2019" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/02/10112734t.jpg?w=1024&amp;h=1536?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/02/10112734t.jpg?w=1024&amp;h=1536?w=683" class="size-full wp-image-991755" alt="10112734t Mens Fashion Has Been the Unexpected Highlight of Awards Season So Far" width="1024" height="1536" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/02/10112734t.jpg?w=1024&amp;h=1536" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-991755" class="wp-caption-text">David Fisher/REX/Shutterstock.</p>
</div>
<p>Ryan Seacrest, who always looks super chic, stunned again in a red and black tuxedo.</p>
<div id="attachment_991756" style="width: 722px" class="wp-caption aligncenter">
<noscript><img src="https://scstylecaster.files.wordpress.com/2019/02/10113255bh.jpg?w=712&amp;h=1033"></noscript>
<img aria-describedby="caption-attachment-991756" data-attachment-id="991756" data-permalink="https://stylecaster.com/oscars-mens-fashion-2019/91st-annual-academy-awards-arrivals-los-angeles-usa-24-feb-2019-10/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bh.jpg?w=712&amp;h=1033" data-orig-size="3537,5134" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"Christopher Polk\/REX\/Shutterstock","camera":"","caption":"Mandatory Credit: Photo by Christopher Polk\/REX\/Shutterstock (10113255bh)\r\nSpike Lee\r\n91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","created_timestamp":"0","copyright":"Copyright (c) 2019 Shutterstock. No use without permission.","focal_length":"0","iso":"0","shutter_speed":"0","title":"91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","orientation":"0"}' data-image-title="91st Annual Academy Awards, Arrivals, Los Angeles, USA – 24 Feb 2019" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bh.jpg?w=712&amp;h=1033?w=462" data-large-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bh.jpg?w=712&amp;h=1033?w=705" class="wp-image-991756" alt="10113255bh Mens Fashion Has Been the Unexpected Highlight of Awards Season So Far" width="712" height="1033" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/02/10113255bh.jpg?w=712&amp;h=1033" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-991756" class="wp-caption-text">Christopher Polk/REX/Shutterstock.</p>
</div>
<p>Spike Lee in a purple suit with matching purple hat, gold sneakers <em>and </em>rings that say “HATE” and “LOVE” might be the new gold standard for men’s red carpet looks.</p>
<div id="attachment_991761" style="width: 722px" class="wp-caption aligncenter">
<noscript><img src="https://scstylecaster.files.wordpress.com/2019/02/10113255bp.jpg?w=712&amp;h=1068"></noscript>
<img aria-describedby="caption-attachment-991761" data-attachment-id="991761" data-permalink="https://stylecaster.com/oscars-mens-fashion-2019/91st-annual-academy-awards-arrivals-los-angeles-usa-24-feb-2019-11/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bp.jpg?w=712&amp;h=1068" data-orig-size="3648,5472" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"Christopher Polk\/REX\/Shutterstock","camera":"","caption":"Mandatory Credit: Photo by Christopher Polk\/REX\/Shutterstock (10113255bp)\r\nStephan James\r\n91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","created_timestamp":"0","copyright":"Copyright (c) 2019 Shutterstock. No use without permission.","focal_length":"0","iso":"0","shutter_speed":"0","title":"91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","orientation":"0"}' data-image-title="91st Annual Academy Awards, Arrivals, Los Angeles, USA – 24 Feb 2019" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bp.jpg?w=712&amp;h=1068?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/02/10113255bp.jpg?w=712&amp;h=1068?w=683" class="wp-image-991761" alt="10113255bp Mens Fashion Has Been the Unexpected Highlight of Awards Season So Far" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/02/10113255bp.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-991761" class="wp-caption-text">Christopher Polk/REX/Shutterstock.</p>
</div>
<p>Stephen James wore a red velvet tuxedo—basically camouflage on the red carpet—to the 2019 Oscars, and we’re in love.</p>
<div id="attachment_991762" style="width: 722px" class="wp-caption aligncenter">
<noscript><img src="https://scstylecaster.files.wordpress.com/2019/02/10113255ce.jpg?w=712&amp;h=1068"></noscript>
<img aria-describedby="caption-attachment-991762" data-attachment-id="991762" data-permalink="https://stylecaster.com/oscars-mens-fashion-2019/91st-annual-academy-awards-arrivals-los-angeles-usa-24-feb-2019-12/" data-orig-file="https://scstylecaster.files.wordpress.com/2019/02/10113255ce.jpg?w=712&amp;h=1068" data-orig-size="3648,5472" data-comments-opened="1" data-image-meta='{"aperture":"0","credit":"Christopher Polk\/REX\/Shutterstock","camera":"","caption":"Mandatory Credit: Photo by Christopher Polk\/REX\/Shutterstock (10113255ce)\r\nAdam Lambert\r\n91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","created_timestamp":"0","copyright":"Copyright (c) 2019 Shutterstock. No use without permission.","focal_length":"0","iso":"0","shutter_speed":"0","title":"91st Annual Academy Awards, Arrivals, Los Angeles, USA - 24 Feb 2019","orientation":"0"}' data-image-title="91st Annual Academy Awards, Arrivals, Los Angeles, USA – 24 Feb 2019" data-image-description="" data-medium-file="https://scstylecaster.files.wordpress.com/2019/02/10113255ce.jpg?w=712&amp;h=1068?w=447" data-large-file="https://scstylecaster.files.wordpress.com/2019/02/10113255ce.jpg?w=712&amp;h=1068?w=683" class="wp-image-991762" alt="10113255ce Mens Fashion Has Been the Unexpected Highlight of Awards Season So Far" width="712" height="1068" data-lazy-src="https://scstylecaster.files.wordpress.com/2019/02/10113255ce.jpg?w=712&amp;h=1068" src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-991762" class="wp-caption-text">Christopher Polk/REX/Shutterstock/</p>
</div>
<p>Of course, Adam Levine effortlessly rocked an Alexander McQueen suit and sparkly ear cuff on the red carpet.</p>                                                                                                                                   </div>
                       <script>
                           // wrapper for adding responsive styles, and fix embed overlapping sidebar
                           jQuery('.post_content .wpcom-protected-iframe').wrap('<p class="embed-video-wrapper"></p>')
                       </script>
                               <div class="post_share  comments-visible  pretty_socials clearfix" data-gtm-button-location="Post Share" data-gtm-pin-location="Post Share">
            <ul>
                <li class="facebook">
                    <div>
                        <a href="#" class="pretty_social sc-icon-facebook" data-type="facebook" data-url="https://stylecaster.com/oscars-mens-fashion-2019/"><span>share</span></a>
                    </div>
                </li><!--
                --><li class="pinterest">
                    <div>
                        <a href="#" class="pretty_social sc-icon-pinterest" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" data-type="pinterest" data-url="https://stylecaster.com/oscars-mens-fashion-2019/"><span>pin</span></a>
                    </div>
                </li><!--
                --><li class="twitter">
                    <div>
                        <a href="#" class="pretty_social sc-icon-twitter" data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far" data-type="twitter" data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster"><span>tweet</span></a>
                    </div>
                </li><!---
                --><li class="tumblr">
                    <div>
                        <a href="#" class="pretty_social sc-icon-tumblr" data-type="tumblr" data-url="https://stylecaster.com/oscars-mens-fashion-2019/"><span>tumblr</span></a>
                    </div>
                </li>
                                    <li class="comments">
                        <div>
                            <a href="javascript:void(0);" class="pretty_social sc-icon-comment" data-type="comments"><span class="sc-comments-count spot-im-replies-count" data-post-id="987967">0</span><span>comments</span></a>
                        </div>
                    </li>
                            </ul>
        </div>
                                       <section class="post_tags modal clearfix">
            <div class="post_tags_category">
                    <span class="more_tag">Tags:</span>
                    <ul>
                                                                                <li><a href="https://stylecaster.com/tag/celebrity-looks/" class="tag-item small">celebrity looks</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/grammys-2019/" class="tag-item small">Grammys 2019</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/mens-fashion/" class="tag-item small">men&#039;s fashion</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/red-carpet-2/" class="tag-item small">red carpet</a></li>
                                            </ul>
            </div>
        </section>
                           </div>
                   <div class="sidebar_after_post_content">
                                          </div>

                   <div class="zergnet-container d-none">
                       <p class="zergnet-header">Promoted Stories</p>
                   </div>

                   
        <div data-spotim-module="recirculation" data-spot-id="sp_YAI3K1BD"></div>
        <script async src="https://recirculation.spot.im/spot/sp_YAI3K1BD"></script>
        <script async src="https://launcher.spot.im/spot/sp_YAI3K1BD"
                data-spotim-module="spotim-launcher"
                data-post-url="https://stylecaster.com/oscars-mens-fashion-2019/"
                data-post-id="987967">
        </script>
        
                                  </div>
           </article>
        </div>
    </div>
    
    <div class="post-splitter"></div>
</div>
        </div>
    </div>

    
    <!--Use list element of the schema org for pages there list is present-->
    
    
    <footer class="footer" data-gtm-link-location="Footer">
        <div class="footer-wraper">
            <div class="stretch-clns">

  <div class="hp-column main-logo">
    <a href="https://stylecaster.com"><div class="logo"></div></a>
  </div>

  <div class="hp-column">
    <div class="footer_menu">
      <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://corporate.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank">Press</a></li>
</ul></div>    </div>
  </div>

  <div class="hp-column">
    <div class="social_menu" data-gtm-button-location="Footer">
      <div class="menu-global-social-profiles-container"><ul id="menu-global-social-profiles" class="menu"><li id="menu-item-593286" class="sc-icon-mail menu-item menu-item-type-post_type menu-item-object-page menu-item-593286"><a target="_blank" href="https://stylecaster.com/signup/">Signup</a></li>
<li id="menu-item-218288" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-218288"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-218287" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-218287"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-593287" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-593287"><a target="_blank" rel="me" href="https://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-218289" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-218289"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-218291" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-218291"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>    </div>
  </div>

</div>

<div class="copy stretch-clns">
    <div class="hp-column sheknows-wrapper">
        <a class="sheknows-copy" href="http://www.sheknows.com/beauty-and-style" target="_blank"><span>Sheknows Media</span><i>Beauty and Style</i></a>
    </div>
    <div class="hp-column">
        <p class="copyright">
            copyright 2019 &copy; all rights reserved by stylecaster        </p>
        <div class="menu-copyright-menu-container"><ul id="menu-copyright-menu" class="menu"><li id="menu-item-341577" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341577"><a target="_blank" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735575" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735575"><a>Privacy Preference</a></li>
<li id="menu-item-341579" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341579"><a target="_blank" href="https://pmc.com/terms-of-use/">Terms Of Use Agreement</a></li>
<li id="menu-item-218296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218296"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694233"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>    </div>
</div>
<div class="footer-right-bottom-block">
	<div class="footer-copy-right">
		<p class="powered-by">Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=stylecaster.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>
	</div>
</div>        </div>
    </footer>

    </div>
<div class="mobile_splash" id="sc-mobile-splash"></div>
<div class="mobile_menu">
    <div class="logo"><a href="https://stylecaster.com">StyleCaster</a></div>
    <div class="close_btn sc-icon-close"></div>
    <div class="mobile_menu_inner">
        <div class="mobile_menu_swipe">
            <div class="menu-new-main-navigation-container"><ul id="menu-new-main-navigation" class="menu"><li id="menu-item-218309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218309"><a href="https://stylecaster.com/fashion/">Fashion</a>
<ul class="sub-menu">
	<li id="menu-item-218313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218313"><a href="https://stylecaster.com/fashion-news/">Fashion News</a></li>
	<li id="menu-item-218314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218314"><a href="https://stylecaster.com/street-style/">Street Style</a></li>
	<li id="menu-item-476084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476084"><a href="https://stylecaster.com/tips-trends/">Tips + Trends</a></li>
	<li id="menu-item-218335" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218335"><a href="https://stylecaster.com/shopping/">Shopping</a></li>
	<li id="menu-item-476085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476085"><a href="https://stylecaster.com/celebrity-looks/">Celebrity Looks</a></li>
</ul>
</li>
<li id="menu-item-218321" class="beautyhigh-submenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218321"><a href="https://stylecaster.com/beauty/">Beauty</a>
<ul class="sub-menu">
	<li id="menu-item-441672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441672"><a href="https://stylecaster.com/beauty/makeup/">Makeup</a></li>
	<li id="menu-item-476090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476090"><a href="https://stylecaster.com/beauty/hair-nails/">Hair + Nails</a></li>
	<li id="menu-item-441674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441674"><a href="https://stylecaster.com/beauty/skin-care/">Skin Care</a></li>
	<li id="menu-item-503638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-503638"><a href="https://stylecaster.com/beauty/health-fitness/">Health + Fitness</a></li>
</ul>
</li>
<li id="menu-item-218316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218316"><a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-476086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476086"><a href="https://stylecaster.com/home/">Home</a></li>
	<li id="menu-item-476290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476290"><a href="https://stylecaster.com/travel/">Travel</a></li>
	<li id="menu-item-319491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319491"><a href="https://stylecaster.com/food-and-drink/">Food + Drink</a></li>
	<li id="menu-item-476088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476088"><a href="https://stylecaster.com/love-sex/">Love + Sex</a></li>
</ul>
</li>
<li id="menu-item-218842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218842"><a href="https://stylecaster.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-218330" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218330"><a href="https://stylecaster.com/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-218332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218332"><a href="https://stylecaster.com/tv-movies/">TV + Movies</a></li>
	<li id="menu-item-218331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218331"><a href="https://stylecaster.com/music/">Music</a></li>
	<li id="menu-item-476292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476292"><a href="https://stylecaster.com/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-513736" class="menu-item-sctv menu-item menu-item-type-taxonomy menu-item-object-category menu-item-513736"><a href="https://stylecaster.com/sctv/">SCTV</a></li>
</ul></div>
            <!-- <div class="newsletter_signup signup-form">
	<h5 class="subscribed-status">WANT <span>MORE?</span></h5>
	<h6 class="subscribed-message">Get STYLECASTER in your inbox</h6>
		<form method="post" class="sc-newsletter-form" autocomplete="off" data-location="expanded-menu" data-source="SignUp-Hamburger">
		<div id="email-validation"></div>
		<input name="additional_information" class="additional_information" type="text" placeholder="Enter Your Email Address" />
		<input name="email" class="email-field" type="text" placeholder="Enter Your Email Address">
		<div class="newsletter-item">
			<input type="checkbox" checked name="daily" class="daily_newsletter" id="daily_checkbox2" value="1" data-newsletter="daily" />
			<label for="daily_checkbox2"><span></span><p>STYLECASTER Daily</p></label>
		</div>
		<div class="newsletter-item">
			<input type="checkbox" checked name="beauty" class="beauty_newsletter" id="beauty_checkbox2" value="1" data-newsletter="beauty" />
			<label for="beauty_checkbox2"><span></span><p>STYLECASTER Beauty</p></label>
		</div>
		<input type="submit" class="subscribe-button" value="Submit" />
		<input type="hidden" name="source" value="SC_Menu" />
	</form>
</div> SPT-68: temporary disabled -->

            <div class="social_menu">
                <div class="menu-expanded-menu-social-container"><ul id="menu-expanded-menu-social" class="menu"><li id="menu-item-609237" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-609237"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-609238" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-609238"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-609239" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-609239"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-609240" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-609240"><a target="_blank" rel="me" href="https://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-609241" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-609241"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>            </div>
            <div class="mobile_footer_menu">
                <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://corporate.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank">Press</a></li>
</ul></div>            </div>
            <div class="mobile_copyright_menu">
                <div class="menu-expanded-menu-copyright-container"><ul id="menu-expanded-menu-copyright" class="menu"><li id="menu-item-646562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-646562"><a target="_blank" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735578" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735578"><a>Privacy Preference</a></li>
<li id="menu-item-646563" class="sc-new-line menu-item menu-item-type-custom menu-item-object-custom menu-item-646563"><a target="_blank" href="https://pmc.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-646564" class="no-delimiter menu-item menu-item-type-custom menu-item-object-custom menu-item-646564"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694234"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>            </div>
        </div>
    </div>
</div>
<script>
window.twttr = (function (d,s,id) {
    var t, js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.async=true;
    js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
    return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
}(document, "script", "twitter-wjs"));
</script>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>        <div id="oas_Bottom" class="blogher-ad" data-position="Bottom"></div>
        
<!-- wpcom_wp_footer -->
	<script>
		window.dataLayer_SKM = window.dataLayer_SKM || [];
		</script>
			<div id="amzn-assoc-ad-46b2a569-85af-49b7-bb16-f343ea35b2cc"></div>
		<script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=46b2a569-85af-49b7-bb16-f343ea35b2cc"></script>
		        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","name":"StyleCaster","url":"https:\/\/stylecaster.com"}</script>
                <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Organization","brand":"StyleCaster","name":"StyleCaster","telephone":"(646) 300-8372","foundingDate":2007,"pinterest":"https:\/\/www.pinterest.com\/stylecaster\/","facebook":"https:\/\/www.facebook.com\/stylecaster","twitter":"https:\/\/twitter.com\/StyleCaster","instagram":"https:\/\/www.instagram.com\/stylecaster\/","linkedin":"https:\/\/www.linkedin.com\/company\/stylecaster\/","logo":"https:\/\/s2.wp.com\/wp-content\/themes\/vip\/sc-stylecaster-2016\/public\/assets\/images\/stylecaster-logo.svg","parentOrganization":"Penske Media Corporation","address":"475 Fifth Avenue, New York, NY 10017"}</script>
        <div class="inline-slideshow-zoom-popup">
	<div class="slide-content"></div>
	<i class="sc-close-icon"></i>
</div>
		<div id="single-social-header" class="visible-phone">
			<span class="social-header-text">share</span>
			<ul data-gtm-button-location="Post Sticky Header" data-gtm-link-location="Post Sticky Header">
				<li class="sc-icon-facebook">
					<a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Facebook</a>
				</li>
				<li class="sc-icon-pinterest">
					<a class="pretty_social"
					   data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far | StyleCaster"
					   data-media="https://scstylecaster.files.wordpress.com/2019/02/gettyimages-1090545962-e1549484803293.jpg" data-type="pinterest"
					   data-url="https://stylecaster.com/oscars-mens-fashion-2019/">Pinterest</a>
				</li>
				<li class="sc-icon-twitter">
					<a class="pretty_social" data-type="twitter"
					   data-description="Men&#8217;s Fashion Has Been the Unexpected Highlight of Awards Season So&nbsp;Far"
					   data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster">Twitter</a>
				</li>
				<li class="sc-icon-tumblr">
					<a class="pretty_social" data-type="tumblr"
					   data-url="https://stylecaster.com/oscars-mens-fashion-2019/" data-via="StyleCaster">Tumblr</a>
				</li>
			</ul>
		</div>
		<div class="mobile-vertical-slideshow">
	<div class="close-mobile-slideshow-container">
		<a href="javascript:void(0);" class="close-mobile-slideshow"></a>
	</div>
	<div class="slideshow-scroll-container">
		<div class="sc-mobile-slideshow">
			<div class='main-gallery'>
				<div class="scroll-to-see">
					<span></span>
				</div>
				<div class="main-post-title"></div>
				<div class="social_menu">
					<ul id="mobile-slideshow-social-menu"  data-gtm-button-location="mobile slideshow header" class="social-menu-container">
						<li class="sc-icon-facebook menu-item">
							<a class="pretty_social" data-type="facebook" data-url="">Facebook</a>
						</li>
						<li class="sc-icon-pinterest menu-item">
							<a class="pretty_social" data-type="pinterest" data-description="" data-media="" data-url="">Pinterest</a>
						</li>
						<li class="sc-icon-twitter menu-item">
							<a class="pretty_social" data-type="twitter" data-description="" data-url="" data-via="StyleCaster">Twitter</a>
						</li>
					</ul>
				</div>
				<ul class="slides-list slide-images"></ul>
			</div>
			<div class="more-slideshows"></div>
			<ul></ul>
		</div>
	</div>
</div>

<script type="text/template" id="slide-view-template">
	<div class="mobile-slide" data-num="<%- slide.slideNumber %>" data-id="<%- slide.galleryId %>-<%- slide.slideNumber %>" data-name="<%- slide.title %>">
		<div class="slide-number"><%- slide.slideNumber %> <span>of</span> <%- countSlides %></div>
		<% if ( slide.type == "instagram") { %>
		<div class="embedded-instagram-container">
			<div class="embedded-instagram">
				<%= slide.instagram %>
			</div>
		</div>
		<% } else if( slide.type == "tumblr" ) { %>
		<div class="embedded-tumblr-container">
			<%= slide.tumblr %>
		</div>
		<% } else { %>
		<div class="slide-img">
			<img src="https://s2.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-original="<%- slide.mobileUrl %>" height="<%- slide.sizes.height %>" width="<%- slide.sizes.width %>" <% if ( slide.slide_alt) { %>alt="<%= slide.slide_alt %>"<% } %> />
			<noscript><img src="<%- slide.mobileUrl %>" alt="<%- slide.caption %>" /></noscript>
		</div>
		<% } %>
		<% if ( slide.caption || slide.author || slide.title || slide.is_sponsored ) { %>
		<div class="slide-description format">
			<% if ( slide.author ) { %>
				<p class="author ">
				<% if ( slide.creditLabel) { %>
					<%= slide.creditLabel %>:
									 <% } else { %>
					Photo:
				<% } %>
				<span><%= slide.author %></span></p>
			<% } %>
			<% if ( slide.is_sponsored ) { %>
				<p class="slide-sponsored">sponsored</p>
			<% } %>
			<% if ( slide.caption || slide.title ) { %>
				<div class="caption ">
					<% if ( slide.title ) { %>
						<p class="image-title"><strong><%= slide.title %></strong></p>
					<% } %>
					<%= slide.caption %>
				</div>
			 <% } %>
		</div>
		<% } %>
	</div>
</script>

<script type="text/template" id="more_slideshows-view-template">
	<div class="more-slideshow-background-image">
		<img src="<%- slideshow.thumbnail %>" alt="<%- slideshow.title %>"/>
	</div>
	<div class="more-slideshow-background"></div>
	<div class="more-slideshow-content">
		<span><%- slideshow.slideshowTitle %></span>
		<h2 class="slideshow-title" ><%= slideshow.title %></h2>
		<div class="social_menu">
			<ul class="social-menu-container">
				<li class="sc-icon-facebook menu-item">
					<a class="pretty_social" data-type="facebook" data-url="<%- slideshow.permalink %>">Facebook</a>
				</li>
				<li class="sc-icon-pinterest menu-item">
					<a class="pretty_social" data-description="<%= slideshow.pinterestShareCaption %>" data-media="<%= slideshow.pinterestShareImage %>" data-type="pinterest" data-url="<%- slideshow.permalink %>">Pinterest</a>
				</li>
				<li class="sc-icon-twitter menu-item">
					<a class="pretty_social" data-type="twitter" data-description="<%= slideshow.title %>" data-url="<%- slideshow.permalink %>" data-via="StyleCaster">Twitter</a>
				</li>
			</ul>
		</div>
		<a href="<%- slideshow.permalink %>#autoplay" class="start-slideshow" title="<%= slideshow.title %>">
			<%- slideshow.btnTitle %>
		</a>
	</div>
</script>

<script>
	// start slideshow immediately
	if ( location.hash == '#autoplay' && scGetDocumentWidth() < 768) {
		var elem = document.getElementsByClassName("mobile-vertical-slideshow");
		if (typeof elem[0] != 'undefined') {
			elem[0].style.display = 'block';
			document.getElementsByTagName('html')[0].className+='active-popup'
		}
	}
</script>
        <script type='text/javascript'>
            var _sf_async_config = _sf_async_config || {};
            /** CONFIGURATION START **/
            _sf_async_config.uid = 7673; // hardcoded Chartbeat ID
            _sf_async_config.domain = 'stylecaster.com';
            /** Doesn't track custom canonical path **/
                            _sf_async_config.useCanonical = true;
             
                        _sf_async_config.authors = "Maggie Griswold";
            
                        _sf_async_config.sections = "celebrity-looks,fashion";
                        /** CONFIGURATION END **/

                (function() {
                    function loadChartbeat() {
                        window._sf_endpt = (new Date()).getTime();
                        var e = document.createElement('script');
                        e.setAttribute('language', 'javascript');
                        e.setAttribute('type', 'text/javascript');
                                                    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
                                                document.body.appendChild(e);
                    }
                    var oldonload = window.onload;
                    window.onload = (typeof window.onload != 'function') ?
                        loadChartbeat : function() {
                        oldonload();
                        loadChartbeat();
                    };
                })();
        </script>
    <script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201908y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-c4d21c8b748f861c07fd8fc4b3005385">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/scstylecaster.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/scstylecaster.wordpress.com\/wp-login.php?action=logout&_wpnonce=560e4ba56b","homeURL":"https:\/\/stylecaster.com\/","postID":"987967","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1550785955j'></script>
<noscript><img src="https://s3.amazonaws.com/heartbeat.pmc.com/track?host=stylecaster.com&#038;path=%2Foscars-mens-fashion-2019%2F&#038;ct=article&#038;lob=&#038;loc=us&#038;env=desktop&#038;post_id=987967" border="0" width="0" height="0" style="z-index: 0; bottom: -1px; left: -1px; display: inline; position: fixed;" /></noscript>
	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="35011528" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://stylecaster.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="StyleCaster" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="eb84c53750" /><input type="hidden" name="_wp_http_referer" value="/oscars-mens-fashion-2019/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytlMtywjAMRX+oxtBSpl10+hF031EcJRH4hS1D8/cVDNMyXXSDdrYjn1w9ru0pG5ciY2S7q7bHIznMX4tdfbA3n0Iz2beRYrWe9ljtoWHDCWLvsfwN5gmDhBwp2xzcz8XzevSpA2+GFh1TkkP55wnmnChy/YdTnak8e3RQGYt5XK42NrfOkzsTjhj7VAQmqspsGPIiUFTDpeam7YkyalJR9nwXcEDgViS0TlCg82gowIhVUyUNBQJyAbeXPquoHeHzkruqzsokCoNxrXIKmuRGBocBna5eThKlVNBKjGZC6LU6VF1J3n8kJRpCcZPpQE3dxYtKtJA6EucEjE2zeNjrduQ83jLl1KNaHa+ZQ3/fYN/42uSCgdp99vvlYZKXvIyo9EoGEIqihSVZ5nmbHIG/ct/D2+p5/fq0Wm9elrtvFwa3QQ=='></script>
<script type='text/javascript' async="async" src='//www.anrdoezrs.net/am/8725733/include/joined/generate/onLoad/impressions/page/am.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/mu-plugins/2-vip/js/vip-analytics.js?m=1411795912h'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"channelUrl":"https:\/\/scstylecaster.wordpress.com\/wp-content\/themes\/vip\/plugins\/facebook\/channel.php","xfbml":true,"appId":"134683123322801"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<div id="fb-root"></div><script type="text/javascript">(function(d){var id="facebook-jssdk";if(!d.getElementById(id)){var js=d.createElement("script"),ref=d.getElementsByTagName("script")[0];js.id=id,js.async=true,js.src="https:\/\/connect.facebook.net\/en_US\/all.js",ref.parentNode.insertBefore(js,ref)}})(document)</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJy1ks1OQjEQhV/IUn6ExIVxZ+KClU8wtx0uc+kfMy2Et7eXIBoSEyN11zSnX8+cOfqYlIkhY8jaF5Vc6SmIBuspqA5Ye5CMXE8qHpCZLMrX3WSQB/17QmYwO7l9lLfoK/RASYtRkk8OzfmJmk9nK51K58jooSow2Miih31BPikDHMsro31Hp1aT+t2fyRuEXLhKEzKJiQnvwn0aFcPRuXUMlCM3Mgg9qpIsVNF3IgXjyribKi7BItcpGH9SdHUPXQz3TXn15GNHDlWtRyYDTokbW7KNxyYhXra9Jakhnto4rvZ2OY6ZOArYyPCVfsUpBx26lilIDHBfk26B54p66Mn8E1ZZ7ErfJtn/rRgf7Vu1jGtI0sYvjTjlISUKjSIAsy8klCmGkbLBnOlCfvHPs+VyOn98WiyWwwdmaise'></script>
<script type='text/javascript' src='https://platform.instagram.com/en_US/embeds.js?ver=5.1-RC2-44763'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/stylecaster.com\/wp-admin\/admin-ajax.php","nonce":"6ee46b5576","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/scstylecaster.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fstylecaster.com%2Foscars-mens-fashion-2019%2F","blog_id":"35011528","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=35011528&v=wpcom&tz=-5&user_id=0&subd=scstylecaster","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyt09tuwyAMBuAXGmE9LNrNtGehxEmhGHsYUrVPP6Z0US92tSAhIaGfT5Zs6ysrSzFDzDqfAUH07FiLVZJvAayRDEntX3e95nIKzmovegSTS6rRO6QpQu7Qxc7Li/4PNkMcKIn2XwXSTXlrEhWBsAldK5QzMbs4KaShBGiE2kQhqEz1cBvSEmL9KWqx26DZsIJxBLutQ6uH5gI01wA3K9GhmUAqgGxSo/YgnVwAdSdCtfibXP4RtNQhajU/Lo4uugyPZlf52XXRhjLUWP0i/Pf7siyPq3tO/VaFRXEok4t1th4bpT1kNvai1hXz8okfu7fj++Fw7Pe9/wb43n61'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?59" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'35011528','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'35011528','v':'wpcom','tz':'-5','user_id':'0','post':'987967','subd':'scstylecaster'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=35011528&v=wpcomvt&tz=-5&user_id=0&post=987967&subd=scstylecaster&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcweC5+TS4lUFRfaG98WnVnRmpSQyxOLitPcGlZM3Y1YnQ0UXd+M1NddTE4eXVIPzVfY2kmb0Z+eFtOLWY9XXNmSHp8Vzh8ZVtRM2pOVDdILC9senxNWHBndVhUOGRJSFE9UGJ1SWNVVD1teEQ/P19uNmVrflVTeWVVVG93ZzV4fjQ5X1IwWWhaaz1leThrX3olLzZKUmFIZEdraU4yXXZ5QmxwTUc9OU00X3dTbFJkbFRqRysyWCwwYUxjd0QzeV1xdi0='}]);
_stq.push([ 'clickTrackerInit', '35011528', '987967' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated 25 seconds ago
	generated in 0.157 seconds
	served from batcache in 0.002 seconds
	expires in 275 seconds
-->
