<!doctype html>
<!--[if lt IE 7]>      <html class="ie6" lang="en-US"> <![endif]-->
<!--[if IE 7]>         <html class="ie7" lang="en-US"> <![endif]-->
<!--[if IE 8]>         <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>         <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US">         <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<title>I Found The Best Affordable Cocktail Dress For $20 At Amazon | StyleCaster</title>

    <link rel="apple-touch-icon" sizes="192x192" href="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/apple-touch-icon-192x192.png" />
    <link rel="shortcut icon"  href="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/favicon-32x32.ico" />

    <link rel="icon" sizes="32x32" type="image/png"  href="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/favicon-32x32.png" />
    <link rel="icon" sizes="192x192" type="image/png" href="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/favicon-192x192.png" />

	        <script type='text/javascript'>
            /**
             * Restoring jQuery object if 3rd party plugins is removed/override jQuery
             */
            (function (w) {
                // Latest jQuery value
                var latestValue = undefined;

                // First jQuery value
                var firstValue = undefined;

                // Add getter and setter for jQuery
                Object.defineProperty(w, 'jQuery', {

                    // jQuery getter
                    get: function () {
                        // if latest version jQuery is a function then return latest jQuery version
                        // if latest version jQuery is not a function then return first jQuery version
                        return ( 'function' === typeof latestValue ) ? latestValue : firstValue;
                    },

                    // jQuery setter
                    set: function (value) {
                        // override latesr jQuery version
                        latestValue = value;
                        // set up first jQuery version
                        if ('undefined' === typeof firstValue && 'function' === typeof value) {
                            firstValue = value;
                        }
                    }
                });

            })(window);
        </script>
        
	
<!--
		 _     _ _           ____          _          _____ _    ___
		| |   (_) | _____   / ___|___   __| | ___    | ____| |__|__ \
		| |   | | |/ / _ \ | |   / _ \ / _` |/ _ \   |  _| | '_ \ / /
		| |___| |   <  __/ | |__| (_) | (_| |  __/_  | |___| | | |_|
		|_____|_|_|\_\___|  \____\___/ \__,_|\___( ) |_____|_| |_(_)
												  |/

		 Work on StyleCaster and other iconic brands!

		 Visit our careers page at https://pmc.com/careers/

-->

<meta name="description" content="I&#039;m a shopping editor who browses retailers every day, and I found the best affordable cocktail dress at Amazon. The $20 design is so chic." />
<meta name="msvalidate.01" content="7A34A1C1904BAFB83691E8B3718CA9A2" />
<meta property="article:publisher" content="https://www.facebook.com/stylecaster" />
<meta name="google-site-verification" content="yB_5UwT5pPNnn93Mba5HIaFkNtbrafDQWP_Rj34Iw08" />
<meta name="keywords" content="" />
<meta name="news_keywords" content="amazon, dresses, shop" />

<script type="text/javascript">dataLayer = window.dataLayer || []; /* Google Tag Manager */</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_meta = {"lob":"","page-type":"article","env":"desktop","primary-category":"Fashion","primary-vertical":"","vertical":"","category":["Fashion","Shopping"],"tag":["amazon","dresses","shop"],"author":["Summer Cartwright"],"logged-in":"","subscriber-type":"","country":"us","is_eu":false,"post-options":""};

/* ]]> */
</script>
		<script type="text/javascript" class="optanon-category-C0002">
			(function(d,w){
				var i, parts, name, c, rdecode = /(%[0-9A-Z]{2})+/g, rspace = /\+/g, ac = (d ? d.split('; ') : []);
				for(w.pmc_cookies = {}, i = 0; i < ac.length; i++) {
					parts = ac[i].split('='), name = parts[0].replace(rdecode, decodeURIComponent), c = parts.slice(1).join('=');
					if(c.charAt(0) === '"') { c = c.slice(1, -1); } c = c.replace(rdecode, decodeURIComponent).replace(rspace, ' '); w['pmc_cookies'][name] = c;
				}
			})(document.cookie, window);

			pmc_meta=pmc_meta || {}, pmc_meta.omni_visit_id = window.pmc_cookies.omni_visit_id || "pmc." + new Date().getTime() + '.' + (function(l,b,a,c,i,d){for(i=0;i<256;i++){l[i]=(i<16?'0':'')+(i).toString(16);}if(c&&c.getRandomValues){try{d=new Uint32Array(4),c.getRandomValues(d);}catch(e){d=0;}}d=d||[b()*a>>>0,b()*a>>>0,b()*a>>>0,b()*a>>>0];a=d[0],b=d[1],c=d[2],d=d[3];return l[a&0xff]+l[a>>8&0xff]+l[a>>16&0xff]+l[a>>24&0xff]+'-'+l[b&0xff]+l[b>>8&0xff]+'-'+l[b>>16&0x0f|0x40]+l[b>>24&0xff]+'-'+l[c&0x3f|0x80]+l[c>>8&0xff]+'-'+l[c>>16&0xff]+l[c>>24&0xff]+l[d&0xff]+l[d>>8&0xff]+l[d>>16&0xff]+l[d>>24&0xff];})([],Math.random,0x100000000,window.crypto||window.msCrypto);
			var d = new Date(); d.setTime(d.getTime() + ( 60 * 60 * 1000 )); var expires = d.toGMTString(); var path = "/"; var domain = window.location.hostname;
			document.cookie = 'omni_visit_id=' + encodeURIComponent(pmc_meta.omni_visit_id) + ( expires ? '; expires=' + expires : '' ) + ( path ? '; path=' + path : '' ) + ( domain ? '; domain=' + domain : '' );
		</script>
				<script type="text/javascript">
		if( window.hasOwnProperty( 'pmc_meta' ) ) {
			if( !window.hasOwnProperty( 'dataLayer' ) || !window.dataLayer.hasOwnProperty('push') ) {
				window.dataLayer = [];
			}
			window.dataLayer.push( pmc_meta );
		}
		</script>

		           <meta id="ad_wrapper_script" data-unit-name="fashion/shopping"/>
           <meta name='robots' content='max-image-preview:large' />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />            <script type="text/javascript" src="//content.jwplatform.com/libraries/ZNyazssg.js"></script>
                <!-- Facebook Pixel Code -->
        <script type="text/javascript" class="optanon-category-C0004">
            !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
                n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
                n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
                t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
                document,'script','//connect.facebook.net/en_US/fbevents.js');
            // Insert Your Facebook Pixel ID below.
            fbq('init', '1130306277008218');
            fbq('track', 'PageView');
        </script>
        <noscript>
            <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1130306277008218&amp;ev=PageView&amp;noscript=1" />
        </noscript>
        <!-- End Facebook Pixel Code -->

        <!--Additional template-specific events for Facebook Pixel-->
                            <script id="facebook-page-type" data-facebook-page-type="page-vertical_slideshow" type="text/javascript" class="optanon-category-C0004">
                if ( typeof fbq != 'undefined' ) {
                    fbq('track', "page-vertical_slideshow");
                }
            </script>
        
                <script type="text/javascript" class="optanon-category-C0004">
            (function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//comfortablecheese.com/0d54dab07da3e2c70e4c904001da3e0bcca526db5e6852893a5d2314eea316b18afeeb8af05e9b4e159a27858787b043438981d6a081e3ab397073de7b62');
        </script>
        <link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//www.anrdoezrs.net' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Feed" href="https://stylecaster.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Comments Feed" href="https://stylecaster.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20 Comments Feed" href="https://stylecaster.com/affordable-cocktail-dress/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/stylecaster.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://stylecaster.com/_static/??-eJydUMtOAzEM/CFSs6Uq4oD4lqzX3aY4D2wHlL8n3VWlreCAuNkez3jG8FVcSMh1IgVUhSmowcgZ3x2HUbw0UGtMuxjSri88wJZxUYg0BU9MkZLdNYV9I3FMs8f2N3rHtv0dCXOy5UR1hesckoKSFzwDsVcLWIRu/q9BpI+NJleymro10ZJEf5W9aZaIblvPnEfP7lQTWshpfdIGyJ8kEnqYH4p27iG6SVzPYjfZ37F/HI5Q6sgBF6lT3/4v9/JRSZqz3GG5arzF1+H4dNgfXobh+Rtv/bFi' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://stylecaster.com/_static/??-eJytj0ESgjAMRS9kCQVHx4XjWUqIEC1tJekw3F5FXbFydPsn7+V/mJLBGJSCgvY0kICgEZ09oROl0VSl3UHKjWcEFIHkuucRh85T8Qg28JPCOLxlFlaO4R+6ujStm+UblecGks8dBxDHXvsxL96J2460EIxZV74XIHB2SE2MVxB1+i60fCgGXg8asvmAF9Lk8GpsWVQL9Q6ezGk42l29rbYHa/d3gp+YeQ==' type='text/css' media='all' />
<script type="text/javascript" src="https://stylecaster.com/wp-content/plugins/pmc-plugins/pmc-global-functions/js/pmc-utils.js"></script>			<script type="text/javascript">
			var pmc_do_analytics_pagecount = true;		//flag to allow analytics code to count a page view
			var pmc_common_urls = {
				parent_theme_uri: 'https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/',
				current_theme_uri: 'https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/',
				fb_channel_uri: 'https://stylecaster.com/wp-content/plugins/pmc-plugins/partner/facebook/channel.html',
				pmc_larva_uri: 'https://stylecaster.com/wp-content/plugins/pmc-plugins/pmc-larva/_core'
			};
			</script>
<script id='pmc-comscore-js-extra'>
var pmc_comscore_options = {"pageview_candidate_url":"\/\/stylecaster.com\/wp-content\/plugins\/pmc-plugins\/pmc-comscore\/xml\/comscore-pageview-candidate.xml"};
</script>
<script id='sc_main_head-js-extra'>
var sc_ajax_script = {"ajaxurl":"\/wp-admin\/admin-ajax.php","siteurl":"https:\/\/stylecaster.com"};
var scMainData = {"isPreview":"false"};
</script>
<script id='StyleCaster_Advertising-js-extra'>
var scAdvertisingConfig = {"vertical":"fashion\/shopping","globalTargeting":{"liveinsite":"segments","url":["https:\/\/stylecaster.com\/affordable-cocktail-dress\/"],"dm_content":"false","tag":["amazon","dresses","shop"],"Article_Category":["Fashion","Shopping"],"ct":["vertical_slideshow"],"ci":"1232236"},"pageType":"single","isSponsored":"false"};
</script>
<script id='pmc-jwplayer-js-extra'>
var pmc_jwplayer_options = {"pid":"ALJ3XQCI","cgid":""};
</script>
<script type='text/javascript' src='https://stylecaster.com/_static/??-eJytktFOwzAMRX+ILHRMQzwgXtCe+YXM8dp0iR3iZFX/nkxbYUK8lE6KlFzLObq2rh6icgS+WBTd1/NZMI3XaxUcrXp50LUJmDJS1tGX1pHoGEDdvlvPe+PVoRBkx3QDU8G1yWRcSvupzyEBBwFOOBEmvdRJx3yU35DcYah7FFCSR49gJGNS68dmq2PZewfn3wc0uaTaFhN6NhbTX/PMQwXjSHVo7HKUsWpIJsZ72BJ43338G3NCspy+YyTZwXFUUCRzuIM311KJc6J0cha5VsyIaYpBP1z0lfMWXpvt02a9eWma5/4Lux4/HQ=='></script>
<script type="text/javascript" src="https://iabusprivacy.pmc.com/geo-info.js"></script>
<script defer='defer' src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-ignore-ga="true" data-domain-script="a320f940-9df1-44a7-9834-d5b5b87fd281"></script>
<script defer='defer' src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0002,C0004,SPD_BG" ccpa-opt-out-geo="ca" ccpa-opt-out-lspa="true"></script>
		
<script type="text/javascript">
	// Override the OneTrust geo location data with our own
	if ( 'object' === typeof pmc_fastly_geo_data && 'string' === typeof pmc_fastly_geo_data.region && 'string' === typeof pmc_fastly_geo_data.country) {
		var OneTrust = {
			geolocationResponse: {
				stateCode: pmc_fastly_geo_data.region,
				countryCode: pmc_fastly_geo_data.country,
			}
		}
	}

	function OptanonWrapper() {
		//Temp fix to solve cache issue
		if (
			'' === location.search &&
			'function' === typeof window.loadGA &&
			pmc_fastly_geo_data &&
			pmc_fastly_geo_data.continent &&
			'EU' !== pmc_fastly_geo_data.continent
		) {
			window.loadGA( true );
			var consent_data = {
				'returnValue': '',
				'success': true
			};
			pmc.hooks.do_action( 'pmc_adm_consent_data_ready', consent_data );
		}

		if ( 'object' === typeof pmc_onetrust ) {
			pmc_onetrust.init();
		}
	}
</script>
<link rel="https://api.w.org/" href="https://stylecaster.com/wp-json/" /><link rel="alternate" type="application/json" href="https://stylecaster.com/wp-json/wp/v2/posts/1232236" /><meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://wp.me/pc8pLe-5ayM' />
<link rel="alternate" type="application/json+oembed" href="https://stylecaster.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stylecaster.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F&#038;format=xml" />
<meta name="author" content="Summer Cartwright">		<link rel="manifest" href="https://stylecaster.com/wp-json/wp/v2/web-app-manifest">
		<meta name="theme-color" content="#fff">
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-touch-fullscreen" content="YES">
							<link rel="apple-touch-startup-image" href="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/favicon-32x32.png">
		
				<meta name="apple-mobile-web-app-title" content="StyleCaster">
		<meta name="application-name" content="StyleCaster">
				<script type="text/javascript">
			window.addEventListener('beforeinstallprompt', (e) => {
				e.preventDefault();
			});
		</script>
		
<style type="text/css">
.vvqbox {
	visibility: visible !important;
	display: block;
	clear: both;
	width: 100%;
}
.vvqbox div {
	margin: 10px auto;
}
.vvqbox img {
	max-width: 100%;
	height: 100%;
}
.vvqbox object {
	max-width: 100%;
}
</style>
<link rel="canonical" href="https://stylecaster.com/affordable-cocktail-dress/" />
<meta name="robots" content="max-image-preview:large">		<script>
			try {
				// Don't rely on jQuery being loaded yet.
				document.addEventListener( 'DOMContentLoaded', function() {
					// Record in GA event if ads are blocked.
					if ( true === window.pmc_is_adblocked ) {
						ga( 'send', 'event', 'ad_blocker', 'blocked', 'ads_blocked', {
							nonInteraction: true
						});
					}
				});
			} catch( err ) {
				// Do nothing...
			}
		</script>
		<style type='text/css'>img#wpstats{display:none}</style>
		        <meta id="ad_wrapper_script" data-unit-name="fashion/shopping" />
                <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
        		<script class="gtm-script-container" type="text/javascript">
			;(function(){
				// save url from which user came to the site to cookies.
				// We set cookie with help js because wordpress vip prohibits the cookies on the server side
				if (document.referrer && document.referrer.split('/')[2] != document.domain) {
					setCookie('sc_gtm_original_url', document.referrer, null);
				}

				_gtmq = [{
					'page_version': isLayout.get(),
					'full_URL': "https:\/\/stylecaster.com\/affordable-cocktail-dress\/",
					'base_URL': "https:\/\/stylecaster.com\/affordable-cocktail-dress\/",
					'query_Parameters': "",
					// --- DEPRECATED START ---
					// let's leave it in the comments to keep the store
					// 'is_Parallax': ,
					// 'is_OriginalVideo': ,
					// 'is_OriginalPhoto': ,
					// 'is_Slideshow': ,
					// 'is_ContentCreator': ,
					// 'is_Shoppable': ,
					// --- DEPRECATED END ---


										'site_section': "stylecaster",
					
					'source_site_of_post' : "stylecaster",

					'dm2sc': "0",

					// post params
											'post_author': "Summer Cartwright",
						'post_published': "10 2021",
						'post_published_full': "10-15-2021 17:08",
						'post_published_date': "2021-10-15",
						'post_url': "https://stylecaster.com/affordable-cocktail-dress/",
						'post_title': "I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20",
						'histurl': null,
						// add type to characterize same events on different slideshows
																			'post_tags': "|6602||45939||32240|",
																			'post_categories': "Fashion|Shopping",
																			'main_categories': "Fashion",
																			'sub_categories': "Shopping",
													'article_id': "1232236",
												'slide_num': null,
												'virtual_page_url': "\/affordable-cocktail-dress\/",
						'post_position_in_page': '1',
					
					// tag page params
					
					// result search page params
					
					// category page params
					
					// author page params
					
					// archive page params
					
					// meta data
					'meta_title': jQuery("title").text(),

					// page params
					'page_type': "single-vertical_slideshow",
					'referrer_original': getCookie('sc_gtm_original_url') ? getCookie('sc_gtm_original_url') : '',

										// Original WP post data
					'wp_post_type' : "post",
					
					'user_ip': "",
					'user_agent': navigator.userAgent
				}];

				// add utm params to _gtmq
				var temp;
				if (temp = getUrlParam(window.location.href, 'utm_source')) {
					_gtmq[0].utm_source = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_medium')) {
					_gtmq[0].utm_medium = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_campaign')) {
					_gtmq[0].utm_campaign = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_term')) {
					_gtmq[0].utm_term = temp;
				}
				if (temp = getUrlParam(window.location.href, 'utm_content')) {
					_gtmq[0].utm_content = temp;
				}
			})();
		</script>
				<script>
			(function(w){
				w.dataLayer = w.dataLayer || [];
				w.dataLayer.push( {"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Shopping","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":1232236,"contentArticleTitle":"I Found The Most Versatile Slip Dress Ever, & It&#8217;s Just $20","contentPublishedDate":"2021-10-15","contentPublishedMonthYear":"2021-10","contentPublishedTimestamp":"2021-10-15-17-08-26","contentOriginalPublishedTimestamp":"2021-10-15-17-05-46","cmsAuthorId":"191609805","momentumAuthorId":"_na_","contentAuthorName":"Summer Cartwright","articleCategories":"Fashion|Shopping","contentTags":"amazon|dresses|shop","geoTarget":"US","pageFormat":"Vertical Slideshow","editorialCategories":"Shopping","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_","scrollable":true,"infiniteScrollPageNum":1},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}} );
				w.dataLayer_NA = "_na_";
				w.dataLayer_INTRO_SLIDE = "Intro";
			})(window);
		</script>
		<script type="application/javascript">
var blogherads = blogherads || {};
blogherads.adq = blogherads.adq || [];
blogherads.adq.push(function() {
	blogherads.setConf( 'narrativ_enable_monetization', true );
});
</script>
<script type="text/javascript">
/* <![CDATA[ */
var pmc_site_config = {"rot13_hostname":"fglyrpnfgre.pbz","hostname":"stylecaster.com","is_proxied":null};

/* ]]> */
</script>
<script type="application/ld+json">
[
    {
        "@context": "http://schema.org",
        "@type": "Article",
        "name": "StyleCaster",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://stylecaster.com/affordable-cocktail-dress/"
        },
        "headline": "I Found The Best Affordable Cocktail Dress For $20 At Amazon",
        "datePublished": "2021-10-15T21:08:26+00:00",
        "dateModified": "2021-10-15T17:08:26+00:00",
        "description": "Catch me wearing it to weddings, work events, and brunches.",
        "author": {
            "@type": "Person",
            "name": "Summer Cartwright"
        },
        "publisher": {
            "@type": "Organization",
            "brand": "StyleCaster",
            "name": "StyleCaster",
            "telephone": "(646) 300-8372",
            "foundingDate": 2007,
            "sameAs": [
                "https://www.pinterest.com/stylecaster/",
                "https://www.facebook.com/stylecaster",
                "https://twitter.com/StyleCaster",
                "https://www.instagram.com/stylecaster/",
                "https://www.linkedin.com/company/stylecaster/"
            ],
            "logo": "https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/stylecaster-logo.svg",
            "parentOrganization": "Penske Media Corporation",
            "address": "475 Fifth Avenue, New York, NY 10017",
            "url": "https://stylecaster.com"
        },
        "isAccessibleForFree": "True",
        "image": {
            "@type": "ImageObject",
            "url": "https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg"
        }
    },
    {
        "@context": "https://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@id": "https://stylecaster.com",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                "item": {
                    "@id": "https://stylecaster.com/fashion/",
                    "name": "Fashion"
                }
            },
            {
                "@type": "ListItem",
                "position": 3,
                "item": {
                    "@id": "https://stylecaster.com/shopping/",
                    "name": "Shopping"
                }
            }
        ]
    }
]</script>
<meta name="onesignal" content="wordpress-plugin"/><meta property="og:site_name" content="StyleCaster" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="134683123322801" />
<meta property="og:url" content="https://stylecaster.com/affordable-cocktail-dress/" />
<meta property="og:title" content="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" />
<meta property="og:description" content="Catch me wearing it to weddings, work events, and brunches." />
<meta property="article:published_time" content="2021-10-15T21:08:26+00:00" />
<meta property="article:modified_time" content="2021-10-15T21:08:26+00:00" />
<meta property="article:author" content="Summer Cartwright" />
<meta property="article:section" content="Fashion" />
<meta property="article:tag" content="Shopping" />
<meta property="article:tag" content="amazon" />
<meta property="article:tag" content="dresses" />
<meta property="article:tag" content="shop" />
<meta property="og:image" content="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="540" />
<script type="text/javascript">
/* <![CDATA[ */
var pmc_krux = {"lob":"","page-type":"article","env":"desktop","primary-category":"Fashion","primary-vertical":"","vertical":"","category":["Fashion","Shopping"],"tag":["amazon","dresses","shop"],"author":["Summer Cartwright"],"logged-in":"","subscriber-type":""};

/* ]]> */
</script>

<script type="text/javascript">
	!function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	}(document.createElement('script'),
	document.getElementsByTagName('script')[0],
	'//cdn.taboola.com/libtrc/shemedia-stylecaster/loader.js');
	window.taboolaDivCount   = 0;
	window.taboolaDivsLoaded = [];
</script>                <script type="text/javascript" src="https://ads.blogherads.com/bh/1/1/1/2208790/header.js" async="async"
                    data-cfasync="false"></script>
            <script type="text/javascript" src="https://ads.blogherads.com/static/blogherads.js" async="async"
                    data-cfasync="false"></script>
            
	<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@stylecaster" /><meta name="twitter:creator" content="@stylecaster" /><meta name="twitter:title" content="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20"/><meta name="twitter:description" content="Catch me wearing it to weddings, work events, and brunches."/><meta name="twitter:image" content="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg"/><meta property="twitter:account_id" content="55678606" />        <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
        <!--[if lt IE 9]>
        <script src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/js/vendors/html5shiv.min.js"></script>
        <script src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/js/vendors/respond.min.js"></script>
        <![endif]-->
                <meta property="fb:pages" content="48566051011" />
        <meta property="fb:article_style" content="scdefault">
        </head>
<body class="post-template-default single single-post postid-1232236 single-format-standard pmc-desktop pmc-no-tablet pmc-no-mobile geo-us" data-paged="1" data-siteurl="https://stylecaster.com">
	<!-- Google Tag Manager -->
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NWP7KQB"
					  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script type="text/javascript" class="optanon-category-C0004">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-NWP7KQB');</script>
	<!-- End Google Tag Manager -->

	<!-- pmc-tags-top Comscore -->	<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035310&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
	</noscript>

<!-- end pmc-tags-top Comscore -->
<div class="wrapper">
    
        <header class="header hide-when-active-popup" id="siteheader" data-gtm-link-location="Header"  >
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li>
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/digital-issues/">Digital Issues</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/tag/shop/">Shopping</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </header>

        <div class="siteheadersticky header" id="siteheadersticky" data-gtm-link-location="Header">
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="https://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li>
            	            		<a href="https://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/digital-issues/">Digital Issues</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/tag/shop/">Shopping</a>
            	            </li>
                    <li>
            	            		<a href="https://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>
    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="https://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="https://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li>
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </div>
    
            <div class="header" id="singleheader"  data-gtm-nav-show="0" data-gtm-link-location="PostNavBar">
        <div class="container shadow">
            
<div class="main">
    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    <div class="logo_delimiter"></div>
    <div class="logo hidden-phone">
        <a href="https://stylecaster.com">StyleCaster</a>
    </div>
    <div class="post_header_title">
                    <span>Share</span>
                <div class="social_menu square">
            <ul id="single-header-social-menu" class="social-menu-container" data-gtm-button-location="PostNavBar">
                <li class="sc-icon-facebook menu-item">
                    <a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/affordable-cocktail-dress/">Facebook</a>
                </li>
                <li class="sc-icon-pinterest menu-item">
                    <a class="pretty_social" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20 | StyleCaster" data-media="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" data-type="pinterest" data-url="https://stylecaster.com/affordable-cocktail-dress/">Pinterest</a>
                </li>
                <li class="sc-icon-twitter menu-item">
                    <a class="pretty_social" data-type="twitter" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster">Twitter</a>
                </li>
                <li class="sc-icon-tumblr menu-item">
                    <a class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster">Tumblr</a>
                </li>
            </ul>
        </div>
        <h2 itemprop="name">I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20</h2>

    </div>
</div>


<div class="main_menu">
    <div class="hot-block">
        <i class="icon-fire"></i>
        <span>What's hot</span>        
    </div>
    <div class="post_prev_next_vav">
        <span class="trigger next">
            <i class="sc-icon-arrow-right"></i>
        </span>
        <span class="trigger back inactive">
            <i class="sc-icon-arrow-left"></i>
        </span>
    </div>
    <div id="sliderNexPrev" class="iner">
        <div class="post_prev_next next hidden-phone hidden-tablet-portrait scpin-no">
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/halloween-costume-trends-women/" rel="next">
						<div class="prev_next_image">
														<img src="https://stylecaster.com/wp-content/uploads/2021/07/daphne.jpg?w=120&#038;h=120&#038;crop=1" alt="We Predict These Will Be The Biggest Halloween Costumes..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									We Predict These Will Be The Biggest Halloween Costumes...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/adele-cleavage-british-vogue/" rel="next">
						<div class="prev_next_image">
														<img src="https://stylecaster.com/wp-content/uploads/2021/10/adele-vogue.jpg?w=120&#038;h=120&#038;crop=1" alt="No One Has Ever Looked Hotter Than Adele On Her &#039;British..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									No One Has Ever Looked Hotter Than Adele On Her &#039;British...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/lizzo-sheer-dress/" rel="next">
						<div class="prev_next_image">
														<img src="https://stylecaster.com/wp-content/uploads/2021/10/lizzo-naked-dress.jpg?w=120&#038;h=120&#038;crop=1" alt="Lizzo Literally Showed Up Naked To Cardi B&#039;s Birthday..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Lizzo Literally Showed Up Naked To Cardi B&#039;s Birthday...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/amazon-fall-shirts/" rel="next">
						<div class="prev_next_image">
														<img src="https://stylecaster.com/wp-content/uploads/2021/10/amazon-shirts-for-fall.jpg?w=120&#038;h=120&#038;crop=1" alt="10 Perfect-For-Fall Shirts That Look More Expensive..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									10 Perfect-For-Fall Shirts That Look More Expensive...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="https://stylecaster.com/best-clothing-sales-right-now/" rel="next">
						<div class="prev_next_image">
														<img src="https://stylecaster.com/wp-content/uploads/2021/06/best-clothing-sales-to-shop-right-now.jpg?w=120&#038;h=120&#038;crop=1" alt="25 Can&rsquo;t-Miss Clothing Sales To Shop Right Now Only..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									25 Can&rsquo;t-Miss Clothing Sales To Shop Right Now Only...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
			        </div>
    </div>
</div>        </div>
    </div>
    
    <div class="wrapper-header-ad-slot hidden-phone">
	<div class="header-ad-slot">
		<div class="header slideshow-header sc-top-ad">
			<div class="container">
				<div class="mobile_menu_trigger">
					<div class="border-menu"></div>
				</div>
				<div class="logo_delimiter"></div>
				<div class="logo-small visible-desktop visible-tablet">
					<a href="https://stylecaster.com">StyleCaster</a>
				</div>
								<div class="slideshow-ad-top-block">
					<div id="oas_Top2" class="sc-ad-init" data-position="Top2" data-internal-section="SlideShow"></div>
				</div>
			</div>
		</div>
	</div>
</div>
    <!--Use list element of the schema org for pages there list is present-->
    
            <div class="page_content_container ">
        <div id="skin">
            <div class="isa_post_container" data-viglink-disable="false" data-is-sponsored="false" data-post-id="1232236" data-post-type="vertical_slideshow" data-post-authors="Summer Cartwright" data-categories-slug="fashion,shopping" data-categories="Fashion,Shopping" data-tags="amazon,dresses,shop" data-page-title="I Found The Best Affordable Cocktail Dress For $20 At Amazon &laquo;  StyleCaster" data-gtm-article-type="vertical_slideshow" data-facebook-page-type="page-vertical_slideshow" data-page-title-gtm="I Found The Best Affordable Cocktail Dress For $20 At Amazon | StyleCaster" href="https://stylecaster.com/affordable-cocktail-dress/" data-page-format="Vertical Slideshow">
    		<script>
			if( 'undefined' == typeof scGtmPremiumData ) {
				window.scGtmPremiumData = {};
			}
			window.scGtmPremiumData[1232236] = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Fashion","subchannel":"Shopping","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":1232236,"contentArticleTitle":"I Found The Most Versatile Slip Dress Ever, & It&#8217;s Just $20","contentPublishedDate":"2021-10-15","contentPublishedMonthYear":"2021-10","contentPublishedTimestamp":"2021-10-15-17-08-26","contentOriginalPublishedTimestamp":"2021-10-15-17-05-46","cmsAuthorId":"191609805","momentumAuthorId":"_na_","contentAuthorName":"Summer Cartwright","articleCategories":"Fashion|Shopping","contentTags":"amazon|dresses|shop","geoTarget":"US","pageFormat":"Vertical Slideshow","editorialCategories":"Shopping","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Sponsored","slideNumber":"_na_","slideId":"_na_","slideName":"_na_","slideshowLength":"_na_"},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
		</script>
		        <div class="container">
        <div class="content-split sc-section_single sc-section-can-stiky">
            <aside class="sc-sidebar sc-sidebar-single visible-desktop">
              <div class="sc-adv-wrap">
                  <div class="sc-adv-wrap-help">
                      <div id="sc_adwrapperunit-4" class="widget widget_sc_adwrapperunit">
        <div class="sc-ad-init" id="oas_Middle3" data-position="Middle3"></div>
        
        </div>
                  </div>
              </div>
            </aside>
            <article class="main_content_area sc-main_content  vertical-slideshow" itemscope itemtype="https://schema.org/Article">
                <meta itemprop="mainEntityOfPage" content="https://stylecaster.com/affordable-cocktail-dress/" />
                <meta itemprop="name" content="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" />
               <div class="sc-single-column">
                   <div class="article " data-current-url="https://stylecaster.com/affordable-cocktail-dress/"   data-next-url="https://stylecaster.com/last-minute-halloween-costumes/" >
                       <header>
                           
                           
                           
                                                                                     <h1 itemprop="headline">I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20</h1>
                           
                           <div class="post_detail">
                               <div class="post_head_detials" data-gtm-button-location="Post Shared Count">
                                   <div class="sc-column">
                                               <ul class="sharecount-social-btns social_menu colored ">
            <li class="menu-item sc-icon-facebook"><a href="javascript:void(0);" class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/affordable-cocktail-dress/">Facebook</a></li>
            <li class="menu-item sc-icon-pinterest"><a href="javascript:void(0);" class="pretty_social" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20 | StyleCaster" data-media="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" data-type="pinterest" data-url="https://stylecaster.com/affordable-cocktail-dress/">Pinterest</a></li>
            <li class="menu-item sc-icon-twitter"><a href="javascript:void(0);" class="pretty_social icon-twitter" data-type="twitter" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster">Twitter</a></li>
            <li class="menu-item sc-icon-tumblr"><a href="javascript:void(0);" class="pretty_social" data-type="tumblr" data-url="https://stylecaster.com/affordable-cocktail-dress/">Tumblr</a></li>
                            <li class="menu-item sc-icon-comment"><span class="sc-comments-count spot-im-replies-count" data-post-id="1232236">0</span></li>
                    </ul>
                                           </div>

                                   <div class="sc-column">

                                       <div class="sc-post-avatar"><img alt='Summer Cartwright' src='https://secure.gravatar.com/avatar/c692391875be03f223f30b866babefbc?s=96&#038;d=identicon&#038;r=g' class='sc-desaturate-image scpin-no avatar avatar-96 photo' height='96' width='96' loading='lazy' /></div>
                                                                              <span class="sc-post-author">by<span itemprop="author"><a href="https://stylecaster.com/author/summercartwright13/" title="Posts by Summer Cartwright" class="author url fn" rel="author">Summer Cartwright</a></span></span>

                                       
                                                                              <span itemprop="datePublished" content="2021-10-15T17:08:26-04:00" class="sc-post-date">Oct 15, 2021 at 5:08 pm EDT</span>
                                       <meta itemprop="dateModified" content="2021-10-15T17:08:26-04:00" />
                                                                          </div>
                               </div>
                           </div>

                           
                <div class="sc_feature_image_container " itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <img src="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" title="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" alt="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" />
            <meta itemprop="url" content="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" />
            <meta itemprop="width" content="712" />
            <meta itemprop="height" content="400" />
                    </div>

                            <div class="photo-detail">Photo:
                                    <span class="source">Courtesy: xxxiticat.</span>
                            </div>
        
                
                           
                           
                       </header>
                       <div class="post_content format clearfix" data-gtm-pin-location="PostContent" itemprop="articleBody">
                                                          <p class="scroll-to-see-more d-none">Scroll To See More Images</p>
                                                      <?xml encoding="utf-8" ?><p class="big_first_letter">As a shopping editor, my job is to <a href="https://stylecaster.com/october-shopping-trends/">scour the internet for the best fashion, beauty, and lifestyle finds</a> out there in order to help readers like you make the best decisions possible. This means I cover everything from <a href="https://shop-links.co/cfNontG31Gp" rel="nofollow" target="_blank" target="_blank">Bed Bath &amp; Beyond’s incredible anniversary sale</a> (that has vacuums, area rugs, and coffee makers <a href="https://stylecaster.com/bed-bath-beyond-anniversary-sale/">on sale for as low as $13</a>) to anti-aging moisturizers that <a href="https://stylecaster.com/beauty/aveneusa-hydrance-aqua-gel/">shoppers swear help them look decades younger</a>. Part of my role is to keep up-to-date on all things Amazon, including its ever-expanding fashion selections.</p>
<p>During one of my daily perusals of the site, I landed upon a cocktail dress that looked almost too good to believe. The silky slip style is as chic as can be, and comes in dozens of colors—I’m much too lazy to count how many—yet, by some miracle, <a href="https://www.amazon.com/dp/B095W3CHJC?tag=stylecaster0d-20&amp;linkCode=ogi&amp;th=1&amp;psc=1&amp;language=en_US&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F"data-pmc-sp-product="664a0e7e6ccb029e2d51c1860aacf066"  custom-ga-data="{&quot;category&quot;:&quot;article-page&quot;,&quot;details&quot;:&quot;it costs under $20&quot;,&quot;label&quot;:&quot;buy-now&quot;,&quot;url&quot;:true,&quot;product&quot;:{&quot;dimension1&quot;:&quot;%=href=%&quot;,&quot;name&quot;:&quot;xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress Cocktail Beach Evening Party Cowl Neck Dot Leopard Midi Dresses(GR2,XS)&quot;,&quot;id&quot;:&quot;B095W3CHJC&quot;,&quot;price&quot;:&quot;18.99&quot;,&quot;category&quot;:&quot;Dresses&quot;},&quot;id&quot;:1232236,&quot;location&quot;:true}" custom-ga-track="click" target="_blank" rel="nofollow" target="_blank">it costs under $20</a>.</p>
<p>See, the reason I was so enthralled by this discovery is because of the incredible versatility a dress like this has. The length is ideal for layering in the fall or wearing alone in the summer, and the shape of it is flattering but not overly sexy, so you can wear it to essentially any and every event you have coming up on your calendar. Better yet, the drop neckline is something I know is flattering on people with small and large busts. I know this from studying bridesmaid dress after bridesmaid dress at all of the weddings I’ve been to. It’s a fact (according to me) that nobody can look bad in this style.</p>
<p class="p1"><span class="s1"><i>Our mission at STYLECASTER is to bring style to the people, and we only feature products we think you’ll love as much as we do. Please note that if you purchase something by clicking on a link within this story, we may receive a small commission of the sale.</i></span></p>
<p> </p>
<div id="attachment_1232243" style="width: 551px" class="wp-caption alignnone"><noscript><img src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?w=541"></noscript><img aria-describedby="caption-attachment-1232243" loading="lazy" class="size-medium wp-image-1232243" alt="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" width="541" height="670" sizes="(max-width: 541px) 100vw, 541px" title="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" data-lazy-src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?w=541" src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-lazy-srcset="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png 772w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?resize=121,150 121w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?resize=541,670 541w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?resize=768,951 768w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?resize=150,186 150w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.42.03-PM.png?resize=40,50 40w" srcset="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-1232243" class="wp-caption-text">Courtesy: xxxiticat.</p></div>
<h2>Xxxiticat Slip Dress in Wine</h2>

<div class="sc__buy-now-wrapper pmc-product-wrapper">
	<div class="sc__btn sc__btn-skew sc">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Wine" data-price="$17.99" class="sc__link" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07MX4B62Y/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Wine","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" target="_blank" rel="nofollow">
			<span class="buy-now-title" itemprop="name">
				Xxxiticat Slip Dress in Wine				<span class="buy-now-price pmc-product-price">$17.99</span>
			</span>
		</a>
	</div>
	<div class="sc__btn sc__btn-skew buy">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Wine" data-price="$17.99" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07MX4B62Y/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Wine","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" class="sc__link" target="_blank" rel="nofollow">
			<span>Buy Now</span>
		</a>
	</div>
</div>



<p>Prices for this dress depend on the size and style you select, but just know that <a href="https://www.amazon.com/dp/B095W3CHJC?tag=stylecaster0d-20&amp;linkCode=ogi&amp;th=1&amp;psc=1&amp;language=en_US&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F"data-pmc-sp-product="aebd3ae5540e6fa07ff94ca2c80bfc81"  custom-ga-data="{&quot;category&quot;:&quot;article-page&quot;,&quot;details&quot;:&quot;they start at just $18&quot;,&quot;label&quot;:&quot;buy-now&quot;,&quot;url&quot;:true,&quot;product&quot;:{&quot;dimension1&quot;:&quot;%=href=%&quot;,&quot;name&quot;:&quot;xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress Cocktail Beach Evening Party Cowl Neck Dot Leopard Midi Dresses(GR2,XS)&quot;,&quot;id&quot;:&quot;B095W3CHJC&quot;,&quot;price&quot;:&quot;18.99&quot;,&quot;category&quot;:&quot;Dresses&quot;},&quot;id&quot;:1232236,&quot;location&quot;:true}" custom-ga-track="click" target="_blank" rel="nofollow" target="_blank">they start at just $18</a>. I’m planning on buying this dress in just about every color. And no, it’s not because I’m an irresponsible spender. In fact, I’m quite the opposite. I penny pinch harder and stronger than basically everyone I know. But, this is the kind of dress that I’ll be able to wear again and again.</p>
<p>This fall, I’m going to wear turtlenecks underneath it, top it with chunky sweaters, and throw on cardigans above it to keep my looks casual yet classy. This is the kind of vibe that’s ideal for work, brunch, or date nights. Plus, when I wear a sweater on top of it, it’ll look like I’m wearing a cute midi skirt rather than the same dress I’ve donned before. Nobody will notice I’m repeating outfits this way. All you really need to do is <a href="https://stylecaster.com/2022-jewelry-trends/">add on your favorite jewelry</a> and maybe slip your feet into <a href="https://stylecaster.com/sneaker-trends-2021/">a cute pair of fall sneakers</a>.</p>
<div id="attachment_1232240" style="width: 573px" class="wp-caption alignnone"><noscript><img src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?w=563"></noscript><img aria-describedby="caption-attachment-1232240" loading="lazy" class="size-medium wp-image-1232240" alt="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" width="563" height="670" sizes="(max-width: 563px) 100vw, 563px" title="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" data-lazy-src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?w=563" src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-lazy-srcset="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png 792w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?resize=126,150 126w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?resize=563,670 563w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?resize=768,913 768w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?resize=150,178 150w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.40.43-PM.png?resize=42,50 42w" srcset="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-1232240" class="wp-caption-text">Courtesy: xxxiticat.</p></div>
<h2>Xxxiticat Slip Dress in Emerald</h2>

<div class="sc__buy-now-wrapper pmc-product-wrapper">
	<div class="sc__btn sc__btn-skew sc">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Emerald" data-price="$17.99" class="sc__link" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B095W3CHJC/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Emerald","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" target="_blank" rel="nofollow">
			<span class="buy-now-title" itemprop="name">
				Xxxiticat Slip Dress in Emerald				<span class="buy-now-price pmc-product-price">$17.99</span>
			</span>
		</a>
	</div>
	<div class="sc__btn sc__btn-skew buy">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Emerald" data-price="$17.99" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B095W3CHJC/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Emerald","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" class="sc__link" target="_blank" rel="nofollow">
			<span>Buy Now</span>
		</a>
	</div>
</div>



<p>I’m in my mid-twenties and now have a laundry list of weddings I’m attending from fall to summer. Though I love my friends dearly and plan on attending each of their celebrations (with glee!!!), I refuse to overspend on my own attire. So, to stay within budget, I’m going with two shimmering color options of this beloved dress. Did I mention that <a href="https://www.amazon.com/dp/B095W3CHJC?tag=stylecaster0d-20&amp;linkCode=ogi&amp;th=1&amp;psc=1&amp;language=en_US&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F"data-pmc-sp-product="e7b513969252f9017fd7ab4d83cf5fd8"  custom-ga-data="{&quot;category&quot;:&quot;article-page&quot;,&quot;details&quot;:&quot;more than 3,000 shoppers have given it a perfect five-star rating&quot;,&quot;label&quot;:&quot;buy-now&quot;,&quot;url&quot;:true,&quot;product&quot;:{&quot;dimension1&quot;:&quot;%=href=%&quot;,&quot;name&quot;:&quot;xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress Cocktail Beach Evening Party Cowl Neck Dot Leopard Midi Dresses(GR2,XS)&quot;,&quot;id&quot;:&quot;B095W3CHJC&quot;,&quot;price&quot;:&quot;18.99&quot;,&quot;category&quot;:&quot;Dresses&quot;},&quot;id&quot;:1232236,&quot;location&quot;:true}" custom-ga-track="click" target="_blank" rel="nofollow" target="_blank">more than 3,000 shoppers have given it a perfect five-star rating</a>?</p>
<div id="attachment_1232241" style="width: 496px" class="wp-caption alignnone"><noscript><img src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?w=486"></noscript><img aria-describedby="caption-attachment-1232241" loading="lazy" class="size-medium wp-image-1232241" alt="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" width="486" height="670" sizes="(max-width: 486px) 100vw, 486px" title="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" data-lazy-src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?w=486" src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-lazy-srcset="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png 692w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?resize=109,150 109w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?resize=486,670 486w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?resize=150,207 150w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.39-PM.png?resize=36,50 36w" srcset="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-1232241" class="wp-caption-text">Courtesy: xxxiticat.</p></div>
<h2>Xxxiticat Slip Dress in Shimmering Blue</h2>
<p>This cobalt blue option is going to be great for the spring and summer months. It’s a pop of color that won’t outshine any of the wedding decor (and certainly not the groom or bride), plus the satin/polyester/spandex combo of materials it’s made with will remain cooling and flexible no matter how hard I break it down on the dance floor.</p>

<div class="sc__buy-now-wrapper pmc-product-wrapper">
	<div class="sc__btn sc__btn-skew sc">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Shimmering Blue" data-price="$17.99" class="sc__link" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07ZRDSLTP/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Shimmering Blue","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" target="_blank" rel="nofollow">
			<span class="buy-now-title" itemprop="name">
				Xxxiticat Slip Dress in Shimmering Blue				<span class="buy-now-price pmc-product-price">$17.99</span>
			</span>
		</a>
	</div>
	<div class="sc__btn sc__btn-skew buy">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Shimmering Blue" data-price="$17.99" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07ZRDSLTP/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Shimmering Blue","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" class="sc__link" target="_blank" rel="nofollow">
			<span>Buy Now</span>
		</a>
	</div>
</div>



<div id="attachment_1232242" style="width: 478px" class="wp-caption alignnone"><noscript><img src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?w=468"></noscript><img aria-describedby="caption-attachment-1232242" loading="lazy" class="size-medium wp-image-1232242" alt="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" width="468" height="670" sizes="(max-width: 468px) 100vw, 468px" title="xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress" data-lazy-src="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?w=468" src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-lazy-srcset="https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png 674w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?resize=105,150 105w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?resize=468,670 468w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?resize=150,215 150w, https://stylecaster.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-15-at-4.41.50-PM.png?resize=35,50 35w" srcset="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif"><p id="caption-attachment-1232242" class="wp-caption-text">Courtesy: xxxiticat.</p></div>
<h2>Xxxiticat Slip Dress in Shimmering Wine</h2>

<div class="sc__buy-now-wrapper pmc-product-wrapper">
	<div class="sc__btn sc__btn-skew sc">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Shimmering Wine" data-price="$17.99" class="sc__link" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07ZRG8H3X/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Shimmering Wine","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" target="_blank" rel="nofollow">
			<span class="buy-now-title" itemprop="name">
				Xxxiticat Slip Dress in Shimmering Wine				<span class="buy-now-price pmc-product-price">$17.99</span>
			</span>
		</a>
	</div>
	<div class="sc__btn sc__btn-skew buy">
		<a data-sc-buy-button data-title="Xxxiticat Slip Dress in Shimmering Wine" data-price="$17.99" href="https://www.amazon.com/xxxiticat-Sleeveless-Spaghetti-Cocktail-Evening/dp/B07ZRG8H3X/?tag=stylecaster0d-20&amp;th=1&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F" custom-ga-data='{"category":"article-page","details":true,"label":"buy-now","url":true,"product":{"dimension1":"%=href=%","name":"Xxxiticat Slip Dress in Shimmering Wine","price":"17.99"},"id":1232236,"location":true}' custom-ga-track="click" class="sc__link" target="_blank" rel="nofollow">
			<span>Buy Now</span>
		</a>
	</div>
</div>



<p>For a sexier vibe, I’m buying this wine-colored dress. It’s longer and curve-hugging, and would look absolutely stellar paired with a matching lip. I just have to figure out what pair of boots I want to wear with it — thigh-highs or combats.</p>
<p>If, like me, you’re excited by the cost, look, and color options that come with this dress, then I think you know what to do. Add the flattering style to your cart and give yourself a dress that’ll pair with just about everything you <em>already </em>have in your closet.</p>
<p>Shop it <a href="https://www.amazon.com/dp/B07MWXZRF8?tag=stylecaster0d-20&amp;linkCode=ogi&amp;th=1&amp;psc=1&amp;language=en_US&amp;asc_source=web&amp;asc_campaign=web&amp;asc_refurl=https%3A%2F%2Fstylecaster.com%2Faffordable-cocktail-dress%2F"data-pmc-sp-product="876fc0007a5313800cf8048dd4143ba9"  custom-ga-data="{&quot;category&quot;:&quot;article-page&quot;,&quot;details&quot;:&quot;starting at $18 here&quot;,&quot;label&quot;:&quot;buy-now&quot;,&quot;url&quot;:true,&quot;product&quot;:{&quot;dimension1&quot;:&quot;%=href=%&quot;,&quot;name&quot;:&quot;xxxiticat Women's Sleeveless Spaghetti Strap Satin Dress Cocktail Beach Evening Party Cowl Neck Dot Leopard Midi Dresses&quot;,&quot;id&quot;:&quot;B07MWXZRF8&quot;,&quot;category&quot;:&quot;Club &amp; Night Out&quot;},&quot;id&quot;:1232236,&quot;location&quot;:true}" custom-ga-track="click" target="_blank" rel="nofollow" target="_blank">starting at $18 here</a>.</p>                                                                                                                                   </div>
                       <script>
                           // wrapper for adding responsive styles, and fix embed overlapping sidebar
                           jQuery('.post_content .wpcom-protected-iframe').wrap('<p class="embed-video-wrapper"></p>')
                       </script>
                               <div class="post_share  comments-visible  pretty_socials clearfix" data-gtm-button-location="Post Share" data-gtm-pin-location="Post Share">
            <ul>
                <li class="facebook">
                    <div>
                        <a href="#" class="pretty_social sc-icon-facebook" data-type="facebook" data-url="https://stylecaster.com/affordable-cocktail-dress/"><span>share</span></a>
                    </div>
                </li><!--
                --><li class="pinterest">
                    <div>
                        <a href="#" class="pretty_social sc-icon-pinterest" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20 | StyleCaster" data-media="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" data-type="pinterest" data-url="https://stylecaster.com/affordable-cocktail-dress/"><span>pin</span></a>
                    </div>
                </li><!--
                --><li class="twitter">
                    <div>
                        <a href="#" class="pretty_social sc-icon-twitter" data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20" data-type="twitter" data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster"><span>tweet</span></a>
                    </div>
                </li><!---
                --><li class="tumblr">
                    <div>
                        <a href="#" class="pretty_social sc-icon-tumblr" data-type="tumblr" data-url="https://stylecaster.com/affordable-cocktail-dress/"><span>tumblr</span></a>
                    </div>
                </li>
                                    <li class="comments">
                        <div>
                            <a href="javascript:void(0);" class="pretty_social sc-icon-comment" data-type="comments"><span class="sc-comments-count spot-im-replies-count" data-post-id="1232236">0</span><span>comments</span></a>
                        </div>
                    </li>
                            </ul>
        </div>
                                       <section class="post_tags modal clearfix">
            <div class="post_tags_category">
                    <span class="more_tag">Tags:</span>
                    <ul>
                                                                                <li><a href="https://stylecaster.com/tag/amazon/" class="tag-item small">amazon</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/dresses/" class="tag-item small">dresses</a></li>
                                                                                <li><a href="https://stylecaster.com/tag/shop/" class="tag-item small">shop</a></li>
                                            </ul>
            </div>
        </section>
                           </div>
                   <div class="sidebar_after_post_content">
                                              
<div id="taboola-below-article-thumbnails"></div>

<script type="text/javascript">
	if ( 'undefined' !== window.taboolaDivCount ) {
		document.getElementById("taboola-below-article-thumbnails").setAttribute("id", "taboola-below-article-thumbnails-" + window.taboolaDivCount);

		if (0 === window.taboolaDivCount) {
			window._taboola = window._taboola || [];

			_taboola.push({
				mode: 'thumbnails-a',
				container: "taboola-below-article-thumbnails-" + window.taboolaDivCount,
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
			});

			_taboola.push({
				article: 'auto',
				url: 'https://stylecaster.com/affordable-cocktail-dress/'
			});

			window.taboolaDivsLoaded[window.taboolaDivCount] = true;
		} else {
			window.taboolaDivsLoaded[window.taboolaDivCount] = false;
		}

		window.taboolaDivCount++;
	}
</script>
                   </div>

                   
        <div data-spotim-module="recirculation" data-spot-id="sp_YAI3K1BD"></div>
        <script async src="https://recirculation.spot.im/spot/sp_YAI3K1BD"></script>
        <script async src="https://launcher.spot.im/spot/sp_YAI3K1BD"
                data-spotim-module="spotim-launcher"
                data-post-url="https://stylecaster.com/affordable-cocktail-dress/"
                data-post-id="1232236">
        </script>
        
                                  </div>
           </article>
        </div>
    </div>

    <div class="post-splitter"></div>
</div>
        </div>
    </div>

    
    <!--Use list element of the schema org for pages there list is present-->
    
    
    <footer class="footer" data-gtm-link-location="Footer">
        <div class="footer-wraper">
            <div class="stretch-clns">

  <div class="hp-column main-logo">
    <a href="https://stylecaster.com"><div class="logo"></div></a>
  </div>

  <div class="hp-column">
    <div class="footer_menu">
      <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" rel="noopener" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-1132115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1132115"><a href="https://stylecaster.com/accessibility/">Accessibility</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="https://www.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" rel="noopener" href="https://www.shemedia.com/contact-us">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" rel="noopener" href="https://pmc.com/careers-listing/">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" rel="noopener" href="https://www.shemedia.com/news">Press</a></li>
</ul></div>    </div>
  </div>

  <div class="hp-column">
    <div class="social_menu" data-gtm-button-location="Footer">
      <div class="menu-global-social-profiles-container"><ul id="menu-global-social-profiles" class="menu"><li id="menu-item-593286" class="sc-icon-mail menu-item menu-item-type-post_type menu-item-object-page menu-item-593286"><a target="_blank" rel="noopener" href="https://stylecaster.com/signup/">Signup</a></li>
<li id="menu-item-218288" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-218288"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-218287" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-218287"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-218289" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-218289"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-218291" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-218291"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>    </div>
  </div>

</div>

<div class="copy stretch-clns">
    <div class="hp-column sheknows-wrapper">
        <a class="sheknows-copy" href="http://www.sheknows.com/beauty-and-style" target="_blank"><span>Sheknows Media</span><i>Beauty and Style</i></a>
    </div>
    <div class="hp-column">
        <p class="copyright">
            copyright 2021 &copy; all rights reserved by stylecaster        </p>
        <div class="menu-copyright-menu-container"><ul id="menu-copyright-menu" class="menu"><li id="menu-item-341577" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341577"><a target="_blank" rel="noopener" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735575" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735575"><a>EU Privacy Preferences</a></li>
<li id="menu-item-341579" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341579"><a target="_blank" rel="noopener" href="https://pmc.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-1073616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1073616"><a href="https://pmc.com/privacy-policy/#california">California Privacy Rights</a></li>
<li id="menu-item-1073615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1073615"><a href="https://pmc.com/opt-out">Do Not Sell My Personal Information</a></li>
<li id="menu-item-218296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218296"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694233"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>    </div>
</div>
<div class="footer-right-bottom-block">
	<div class="footer-copy-right">
		<p class="powered-by">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=stylecaster.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></p>
	</div>
</div>        </div>
    </footer>

    </div>
<div class="mobile_splash" id="sc-mobile-splash"></div>
<div class="mobile_menu">
    <div class="logo"><a href="https://stylecaster.com">StyleCaster</a></div>
    <div class="close_btn sc-icon-close"></div>
    <div class="mobile_menu_inner">
        <div class="mobile_menu_swipe">
            <div class="menu-new-main-navigation-container"><ul id="menu-new-main-navigation" class="menu"><li id="menu-item-218309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218309"><a href="https://stylecaster.com/fashion/">Fashion</a>
<ul class="sub-menu">
	<li id="menu-item-218313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218313"><a href="https://stylecaster.com/fashion-news/">Fashion News</a></li>
	<li id="menu-item-218314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218314"><a href="https://stylecaster.com/street-style/">Street Style</a></li>
	<li id="menu-item-476084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476084"><a href="https://stylecaster.com/tips-trends/">Tips + Trends</a></li>
	<li id="menu-item-218335" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218335"><a href="https://stylecaster.com/shopping/">Shopping</a></li>
	<li id="menu-item-476085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476085"><a href="https://stylecaster.com/celebrity-looks/">Celebrity Looks</a></li>
</ul>
</li>
<li id="menu-item-218321" class="beautyhigh-submenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218321"><a href="https://stylecaster.com/beauty/">Beauty</a>
<ul class="sub-menu">
	<li id="menu-item-441672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441672"><a href="https://stylecaster.com/beauty/makeup/">Makeup</a></li>
	<li id="menu-item-476090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476090"><a href="https://stylecaster.com/beauty/hair-nails/">Hair + Nails</a></li>
	<li id="menu-item-441674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441674"><a href="https://stylecaster.com/beauty/skin-care/">Skin Care</a></li>
	<li id="menu-item-503638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-503638"><a href="https://stylecaster.com/beauty/health-fitness/">Health + Fitness</a></li>
</ul>
</li>
<li id="menu-item-218316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218316"><a href="https://stylecaster.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-476086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476086"><a href="https://stylecaster.com/home/">Home</a></li>
	<li id="menu-item-476290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476290"><a href="https://stylecaster.com/travel/">Travel</a></li>
	<li id="menu-item-319491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319491"><a href="https://stylecaster.com/food-and-drink/">Food + Drink</a></li>
	<li id="menu-item-476088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476088"><a href="https://stylecaster.com/love-sex/">Love + Sex</a></li>
</ul>
</li>
<li id="menu-item-218842" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-218842"><a href="https://stylecaster.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-218330" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-218330"><a href="https://stylecaster.com/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-218332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218332"><a href="https://stylecaster.com/tv-movies/">TV + Movies</a></li>
	<li id="menu-item-218331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218331"><a href="https://stylecaster.com/music/">Music</a></li>
	<li id="menu-item-476292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476292"><a href="https://stylecaster.com/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-1168716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1168716"><a href="https://stylecaster.com/digital-issues/">Digital Issues</a></li>
<li id="menu-item-1188518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1188518"><a href="https://stylecaster.com/tag/shop/">Shopping</a></li>
<li id="menu-item-513736" class="menu-item-sctv menu-item menu-item-type-taxonomy menu-item-object-category menu-item-513736"><a href="https://stylecaster.com/sctv/">SCTV</a></li>
</ul></div>
            <div class="newsletter_signup signup-form">
	<h5 class="subscribed-status">WANT <span>MORE?</span></h5>
	<h6 class="subscribed-message">Get STYLECASTER in your inbox</h6>
		<form method="post" class="sc-newsletter-form" autocomplete="off" data-location="expanded-menu" data-source="SignUp-Hamburger">
		<div id="email-validation"></div>
		<input name="additional_information" class="additional_information" type="text" placeholder="Enter Your Email Address" />
		<input name="email" class="email-field" type="text" placeholder="Enter Your Email Address">
		<!-- <div class="newsletter-item">
			<input type="checkbox" checked name="daily" class="daily_newsletter" id="daily_checkbox2" value="1" data-newsletter="daily" />
			<label for="daily_checkbox2"><span></span><p>STYLECASTER Daily</p></label>
		</div>
		<div class="newsletter-item">
			<input type="checkbox" checked name="beauty" class="beauty_newsletter" id="beauty_checkbox2" value="1" data-newsletter="beauty" />
			<label for="beauty_checkbox2"><span></span><p>STYLECASTER Beauty</p></label>
		</div> SPT-135: disabled because of always "yes" value -->
		<input type="submit" class="subscribe-button" value="Submit" />
		<input type="hidden" name="source" value="SC_Menu" />
	</form>
</div>

            <div class="social_menu">
                <div class="menu-expanded-menu-social-container"><ul id="menu-expanded-menu-social" class="menu"><li id="menu-item-609237" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-609237"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-609238" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-609238"><a target="_blank" rel="me" href="https://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-609239" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-609239"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-609241" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-609241"><a target="_blank" rel="me" href="https://www.instagram.com/stylecaster">Instagram</a></li>
</ul></div>            </div>
            <div class="mobile_footer_menu">
                <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" rel="noopener" href="https://stylecaster.com/about-us/">About Us</a></li>
<li id="menu-item-1132115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1132115"><a href="https://stylecaster.com/accessibility/">Accessibility</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="https://www.shemedia.com/advertise">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" rel="noopener" href="https://www.shemedia.com/contact-us">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" rel="noopener" href="https://pmc.com/careers-listing/">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" rel="noopener" href="https://www.shemedia.com/news">Press</a></li>
</ul></div>            </div>
            <div class="mobile_copyright_menu">
                <div class="menu-expanded-menu-copyright-container"><ul id="menu-expanded-menu-copyright" class="menu"><li id="menu-item-646562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-646562"><a target="_blank" rel="noopener" href="https://pmc.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-735578" class="btn-privacy-preference menu-item menu-item-type-custom menu-item-object-custom menu-item-735578"><a>Privacy Preferences</a></li>
<li id="menu-item-646563" class="sc-new-line menu-item menu-item-type-custom menu-item-object-custom menu-item-646563"><a target="_blank" rel="noopener" href="https://pmc.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-1073618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1073618"><a href="https://pmc.com/privacy-policy/#california">California Privacy Rights</a></li>
<li id="menu-item-1073617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1073617"><a href="https://www.pmc.com/opt-out">Do Not Sell My Personal Information</a></li>
<li id="menu-item-646564" class="no-delimiter menu-item menu-item-type-custom menu-item-object-custom menu-item-646564"><a href="https://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694234"><a href="https://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
<li id="menu-item-1089771" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1089771"><a href="https://stylecaster.com/accessibility/">Accessibility</a></li>
</ul></div>            </div>
        </div>
    </div>
</div>
<script>
window.twttr = (function (d,s,id) {
    var t, js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.async=true;
    js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
    return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
}(document, "script", "twitter-wjs"));
</script>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>

<div id="amzn-assoc-ad-f9a0ea9a-9983-469a-a29f-aa6edce656ca"></div>
<script async src="https://z-na.associates-amazon.com/onetag/v2?MarketPlace=US&instanceId=f9a0ea9a-9983-469a-a29f-aa6edce656ca"></script>
<script>
	var ccpa = document.querySelector( "a[href='https:\/\/pmc.com\/opt-out']" );
	var gdpr = document.querySelector( ".menu-item.btn-privacy-preference" );
	var ca_privacy_link = document.querySelector( "a[href='https:\/\/pmc.com\/privacy-policy\/#california']" );

	ccpa = ( ccpa.parentNode.nodeName.toLowerCase() === 'li' ) ? ccpa.parentElement : ccpa;
	gdpr = ( gdpr.parentNode.nodeName.toLowerCase() === 'li' ) ? gdpr.parentElement : gdpr;
	ca_privacy_link = ( ca_privacy_link.parentNode.nodeName.toLowerCase() === 'li' ) ? ca_privacy_link.parentElement : ca_privacy_link;

	if ( ccpa && gdpr && ca_privacy_link ) {
		if ( pmc_fastly_geo_data.region !== 'CA' && pmc_fastly_geo_data.continent !== 'EU' ) {
			ccpa.remove();
			gdpr.remove();
			ca_privacy_link.remove();
		} else if ( pmc_fastly_geo_data.region === 'CA' ) {
			gdpr.remove();

			ccpa.addEventListener("click", function( e ) {
				e.preventDefault();
				OneTrust.ToggleInfoDisplay();
			} );
		} else if (  pmc_fastly_geo_data.continent === 'EU' ) {
			ccpa.remove();
			ca_privacy_link.remove();

			gdpr.addEventListener("click", function( e ) {
				e.preventDefault();
				OneTrust.ToggleInfoDisplay();
			} );
		}
	}
</script>
	<script>
		window.dataLayer = window.dataLayer || [];
		</script>
			<div id="amzn-assoc-ad-46b2a569-85af-49b7-bb16-f343ea35b2cc"></div>
		<script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=46b2a569-85af-49b7-bb16-f343ea35b2cc"></script>
		<div class="inline-slideshow-zoom-popup">
	<div class="slide-content"></div>
	<i class="sc-close-icon"></i>
</div>
		<div id="single-social-header" class="visible-phone">
			<span class="social-header-text">share</span>
			<ul data-gtm-button-location="Post Sticky Header" data-gtm-link-location="Post Sticky Header">
				<li class="sc-icon-facebook">
					<a class="pretty_social" data-type="facebook" data-url="https://stylecaster.com/affordable-cocktail-dress/">Facebook</a>
				</li>
				<li class="sc-icon-pinterest">
					<a class="pretty_social"
					   data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20 | StyleCaster"
					   data-media="https://stylecaster.com/wp-content/uploads/2021/10/dres.jpg" data-type="pinterest"
					   data-url="https://stylecaster.com/affordable-cocktail-dress/">Pinterest</a>
				</li>
				<li class="sc-icon-twitter">
					<a class="pretty_social" data-type="twitter"
					   data-description="I Found The Most Versatile Slip Dress Ever, &#038; It&#8217;s Just $20"
					   data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster">Twitter</a>
				</li>
				<li class="sc-icon-tumblr">
					<a class="pretty_social" data-type="tumblr"
					   data-url="https://stylecaster.com/affordable-cocktail-dress/" data-via="StyleCaster">Tumblr</a>
				</li>
			</ul>
		</div>
		<div class="mobile-vertical-slideshow">
	<div class="close-mobile-slideshow-container">
		<a href="javascript:void(0);" class="close-mobile-slideshow"></a>
	</div>
	<div class="slideshow-scroll-container">
		<div class="sc-mobile-slideshow">
			<div class='main-gallery'>
				<div class="scroll-to-see">
					<span></span>
				</div>
				<div class="main-post-title"></div>
				<div class="social_menu">
					<ul id="mobile-slideshow-social-menu"  data-gtm-button-location="mobile slideshow header" class="social-menu-container">
						<li class="sc-icon-facebook menu-item">
							<a class="pretty_social" data-type="facebook" data-url="">Facebook</a>
						</li>
						<li class="sc-icon-pinterest menu-item">
							<a class="pretty_social" data-type="pinterest" data-description="" data-media="" data-url="">Pinterest</a>
						</li>
						<li class="sc-icon-twitter menu-item">
							<a class="pretty_social" data-type="twitter" data-description="" data-url="" data-via="StyleCaster">Twitter</a>
						</li>
					</ul>
				</div>
				<ul class="slides-list slide-images"></ul>
			</div>
			<div class="more-slideshows"></div>
			<ul></ul>
		</div>
	</div>
</div>

<script type="text/template" id="slide-view-template">
	<div class="mobile-slide" data-num="<%- slide.slideNumber %>" data-id="<%- slide.galleryId %>-<%- slide.slideNumber %>" data-name="<%- slide.title %>">
		<div class="slide-number"><%- slide.slideNumber %> <span>of</span> <%- countSlides %></div>
		<% if ( slide.type == "instagram") { %>
		<div class="embedded-instagram-container">
			<div class="embedded-instagram">
				<%= slide.instagram %>
			</div>
		</div>
		<% } else if( slide.type == "tumblr" ) { %>
		<div class="embedded-tumblr-container">
			<%= slide.tumblr %>
		</div>
		<% } else { %>
		<div class="slide-img">
			<img src="https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-original="<%- slide.mobileUrl %>" height="<%- slide.sizes.height %>" width="<%- slide.sizes.width %>" <% if ( slide.slide_alt) { %>alt="<%= slide.slide_alt %>"<% } %> />
			<noscript><img src="<%- slide.mobileUrl %>" alt="<%- slide.caption %>" /></noscript>
		</div>
		<% } %>
		<% if ( slide.caption || slide.author || slide.title || slide.is_sponsored ) { %>
		<div class="slide-description format">
			<% if ( slide.author ) { %>
				<p class="author ">
				<% if ( slide.creditLabel) { %>
					<%= slide.creditLabel %>:
									 <% } else { %>
					Photo:
				<% } %>
				<span><%= slide.author %></span></p>
			<% } %>
			<% if ( slide.is_sponsored ) { %>
				<p class="slide-sponsored">sponsored</p>
			<% } %>
			<% if ( slide.caption || slide.title ) { %>
				<div class="caption ">
					<% if ( slide.title ) { %>
						<p class="image-title"><strong><%= slide.title %></strong></p>
					<% } %>
					<%= slide.caption %>
				</div>
			 <% } %>
		</div>
		<% } %>
	</div>
</script>

<script type="text/template" id="more_slideshows-view-template">
	<div class="more-slideshow-background-image">
		<img src="<%- slideshow.thumbnail %>" alt="<%- slideshow.title %>"/>
	</div>
	<div class="more-slideshow-background"></div>
	<div class="more-slideshow-content">
		<span><%- slideshow.slideshowTitle %></span>
		<h2 class="slideshow-title" ><%= slideshow.title %></h2>
		<div class="social_menu">
			<ul class="social-menu-container">
				<li class="sc-icon-facebook menu-item">
					<a class="pretty_social" data-type="facebook" data-url="<%- slideshow.permalink %>">Facebook</a>
				</li>
				<li class="sc-icon-pinterest menu-item">
					<a class="pretty_social" data-description="<%= slideshow.pinterestShareCaption %>" data-media="<%= slideshow.pinterestShareImage %>" data-type="pinterest" data-url="<%- slideshow.permalink %>">Pinterest</a>
				</li>
				<li class="sc-icon-twitter menu-item">
					<a class="pretty_social" data-type="twitter" data-description="<%= slideshow.title %>" data-url="<%- slideshow.permalink %>" data-via="StyleCaster">Twitter</a>
				</li>
			</ul>
		</div>
		<a href="<%- slideshow.permalink %>#autoplay" class="start-slideshow" title="<%= slideshow.title %>">
			<%- slideshow.btnTitle %>
		</a>
	</div>
</script>

<script>
	// start slideshow immediately
	if ( location.hash == '#autoplay' && scGetDocumentWidth() < 768) {
		var elem = document.getElementsByClassName("mobile-vertical-slideshow");
		if (typeof elem[0] != 'undefined') {
			elem[0].style.display = 'block';
			document.getElementsByTagName('html')[0].className+='active-popup'
		}
	}
</script>

        <script type="text/javascript" class="optanon-category-C0004">
            var _sf_async_config = _sf_async_config || {};
            /** CONFIGURATION START **/
            _sf_async_config.uid = 7673; // hardcoded Chartbeat ID
            _sf_async_config.domain = 'stylecaster.com';
            /** Doesn't track custom canonical path **/
                            _sf_async_config.useCanonical = true;
             
                        _sf_async_config.authors = "Summer Cartwright";
            
                        _sf_async_config.sections = "fashion,shopping";
                        /** CONFIGURATION END **/

                (function() {
                    function loadChartbeat() {
                        window._sf_endpt = (new Date()).getTime();
                        var e = document.createElement('script');
                        e.setAttribute('language', 'javascript');
                        e.setAttribute('type', 'text/javascript');
                                                    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
                                                document.body.appendChild(e);
                    }
                    var oldonload = window.onload;
                    window.onload = (typeof window.onload != 'function') ?
                        loadChartbeat : function() {
                        oldonload();
                        loadChartbeat();
                    };
                })();
        </script>
    <script>
	( function() {
		var newAmazonAffiliateId  = false,
			amazonUtmReplacements = [{"utm":"utm_campaign=sc-apple-news","id":"scapplenews-20"},{"utm":"utm_campaign=sc-sharethrough","id":"scsharethrough-20"},{"utm":"utm_campaign=sc-cube","id":"sccubeads-20"}],
			// Regex: https://regex101.com/r/9vLK4m/1
			utm_campaign          = window.location.href.match( /utm_campaign=[^&|#]+/i );

		if ( utm_campaign && 'object' === typeof utm_campaign ) {
			utm_campaign = utm_campaign[0].toLowerCase();

			// Regex: https://regex101.com/r/vkRe3Z/1
			var variant = utm_campaign.match( /-(\d+)$/ );

			if ( variant && 'object' === typeof variant ) {
				variant = variant[1];
			} else {
				variant = '';
			}

			for ( var i = amazonUtmReplacements.length - 1; i >= 0; i-- ) {
				var utm = amazonUtmReplacements[i].utm;
					id  = amazonUtmReplacements[i].id;

				// The variant feature appends a number to the Tracking ID if it exists in the UTM campaign.
				if ( variant ) {
					// append variant to UTM if it exists, eg, change utm_campaign=spy-fb-unpaid to utm_campaign=spy-fb-unpaid-1 if variant is 1
					utm += '-' + variant;

					// add variant to ID if it exists, eg, change spyfb-20 to spyfb1-20 if variant is 1
					id = id.replace( /(-\d+)$/, variant + '$1' );
				}

				if ( utm_campaign === utm ) {
					newAmazonAffiliateId = id;
					break;
				}
			}

		}

		if ( newAmazonAffiliateId ) {
			var links = document.getElementsByTagName('a');

			for ( var i = links.length - 1; i >= 0; i-- ) {
				var link = links[i];

				if ( ! link.getAttribute( 'data-pmc-sp-product' ) ) {
					continue;
				}
				if ( -1 === link.host.indexOf( 'amazon.com' ) ) {
					continue;
				}

				var href = link.getAttribute( 'href' );

				href = href.replace( /tag=[A-Za-z0-9\-]+/, 'tag=' + newAmazonAffiliateId );
				link.setAttribute( 'href', href );
			}
		}
	}() );
</script>
	<script>
		if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"https:\/\/stylecaster.com\/wp.serviceworker",
							{"scope":"\/"}						).then( reg => {
													} );
					}
							} );
		}
	</script>
	<script id='pmc-video-player-ads-js-js-extra'>
var pmc_video_player_ads = {"is_jwplayer_cc_enabled":"0"};
</script>
<script id='pmc-ga-event-tracking-js-extra'>
var pmc_ga_event_tracking = {"events":[{"action":"click","selector":"a[custom-ga-track=click]","custom":true},{"action":"click","selector":"article a[href*=\"mktp.cc\"]","category":"affiliate_link","custom":true,"url":true}],"device":"[D]"};
</script>
<script type='text/javascript' src='https://stylecaster.com/_static/??-eJytld1OwzAMhV+IrOuYhrhAPATcIzd1W2/5w0la+vZk2SaBVIS25a510s/Hx7ZaTU5IawKaUDkVezK+clqKn8+9sg0o0UUjA9kU3PtqgtlZMsGv9v6hShAyUsUW82E0LbKXlnGlyVxu/JdmpBZtisCMfKSc3qH110D2XihqGJiSlBFNa/kU/4zIs8Cv9LXPRdSr9fLJvenOQDIj4ZTT/Ipcg++t7RWKaGhMhqYegAE1B5LZZkwJgwgM8kCmX+KGAXUS5qXwYVYowQdksVnXu8rFRpHMPmfZ/qIygCuGslEObxO5xTm4hZhLvhnWIYTIx2sDMDTJWdLQ42LHb1FHHYPG3BDk+1X28JHrLabPp8k5oBYy+mB1KWokgV2HspzOYNOtAgZ6CigGhLZEN7xkq9S7LUBCYDmIBoqoyvtVgKRtQ2kjNJpYyixsy7l/HN00wemfUMS3c7V//F2u3VPhGDXFy0q96pd697jdbJ/r+mn/DaR/vM8='></script>
<script type='text/javascript' class='optanon-category-C0004'  src='https://stylecaster.com/wp-content/themes/sc-stylecaster-2016/public/js/features/geo-target.min.js?ver=1' id='sc_geo-js'></script>
<script type='text/javascript' src='https://stylecaster.com/_static/??-eJyVzM0NwjAMQOGFCG5K1YoDYggmSI0RifKH7RRle3pggR7e7emDbzVYslJW0DclEhA0oj0SOlFiMw52htrW6BGCwIucNt635Hw+p70gJziqbJSfhQXCpxF3U5lU+6Ogd/Fv3tPNzpdpnK7WLuEHKOU8IQ=='></script>
<script async="async" src='//www.anrdoezrs.net/am/8725733/include/joined/generate/onLoad/impressions/page/am.js?ver=1' id='cj-js'></script>
<script id='facebook-jssdk-js-extra'>
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"channelUrl":"https:\/\/stylecaster.com\/wp-content\/plugins\/facebook\/channel.php","xfbml":true,"appId":"134683123322801"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
</script>
<div id="fb-root"></div><script type="text/javascript">(function(d){var id="facebook-jssdk";if(!d.getElementById(id)){var js=d.createElement("script"),ref=d.getElementsByTagName("script")[0];js.id=id,js.async=true,js.src="https:\/\/connect.facebook.net\/en_US\/all.js",ref.parentNode.insertBefore(js,ref)}})(document)</script>
<script type='text/javascript' src='https://stylecaster.com/wp-includes/js/wp-embed.min.js?m=1632251572g'></script>
<script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.8.1' async='async' id='onesignal_remote_sdk-js'></script>
<script id='onesignal_sdk_initialize-js-extra'>
var oneSignalConfig = {"default_url":"https:\/\/stylecaster.com","initOptions":{"wordpress":true,"appId":"3b71ea42-bdd8-4859-a7e5-bbd0abd3142a","welcomeNotification":{"disable":true},"path":"https:\/\/stylecaster.com\/onesignal-api\/js\/","safari_web_id":"web.onesignal.auto.2bb5f943-5f36-4c5b-98f3-fab8c5252044","promptOptions":[]},"should_initialize_sdk":"","should_prompt_auto_register":"","should_use_native_prompt":"","should_use_modal_prompt":"","service_worker_updater_path":"updater","service_worker_path":"worker","service_worker_scope":"\/pmc-onesignal.serviceworker\/","should_use_pmc_custom_sdk_init":"1"};
</script>
<script type='text/javascript' src='https://stylecaster.com/_static/??-eJy1lM1uwjAQhF+oixuKqHqoeqvUA6c+QOWfTbLBf3htIt6+TgUI9UjCzZJHn2dnVhZjBB18Rp9FtKUjzyI6DZdz8MjUeWmhTYgwooJYuAcfMrWkZaZQVWz2Py1ZZEGe8mrgJ3HDzT26esUaOJ8saskZE6yfm62IRVnSYmBxRG9CYjEcCqYTaJlC+UxovtHCduXI30VtUeaSqixiItYh4t2oi0HWKVi7C3XQkBYwJjuEEo2solsaeW2LqYIqVlLvVW1i/msuqFoTHDHlWp4FtlTf6MM4O5Zzbz1xjeU032m1tc9hysGSxwWMXslXFFip0C41OQcv79+H/7C/JXOyI/0AJBhUpZuf5OPWKI3mq1rFnYw83ydNKHAyRvILjC31oRDT9PVNhBZzpjP1w70325fNevPWNK/DL+Q1/Jo='></script>
<script src='https://platform.instagram.com/en_US/embeds.js?ver=5.8.1' id='sc_instagram_embed-js'></script>
<script type='text/javascript' src='https://stylecaster.com/_static/??-eJyt0kFOAzEMBdAL4ZopVRELxFnS1NMmxLGJnaJyelK1F4AZycv/nyzZ+K0QpTpVRz8Tk6FFML8WisGcGmyfpz1qP5QUMRteqB6lGeavTu0KOYYm3ahsONVNtif8KzhT8N5usbOopnoClmMvtAIYm5QCLmN0OReFebQM7u5y0IMCzTNFX25x+CS5jICuslricCIbZdbQVjgFyyEVgh8Rhrv9b1NvbbTxKGv8SKpzqsnpcdShPswPfp/2L7vt7m2aXvMv3iwoUw=='></script>
<script src='https://stats.wp.com/e-202141.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2',blog:'179321684',post:'1232236',tz:'-4',srv:'stylecaster.com'} ]);
	_stq.push([ 'clickTrackerInit', '179321684', '1232236' ]);
</script>
<!-- pmc-tags-bottom Instinctive -->
	<script type="text/javascript" class="script-mobile optanon-category-C0004" async src="https://load.instinctiveads.com/i.js"></script>
<!-- end pmc-tags-bottom Instinctive --><!-- pmc-tags-bottom Digioh -->
<!--START Lightbox Javascript-->
<script type="text/javascript" class="optanon-category-C0004">
	var digiohVisitorFromEmail = !! 0;

	(function(){
		window.setTimeout(
			function() {
				var tag = document.createElement( 'script' );
				tag.type = "text/javascript";
				tag.src   = "https://www.lightboxcdn.com/vendor/0e0459c9-d60e-4c87-a0c0-a4cdaae103a3/lightbox_inline.js";
				tag.async = true;

				var parent = document.getElementsByTagName( 'script' )[0];
				parent.parentNode.insertBefore( tag, parent );
			},
			500
		);
	})();
</script>
<!--END Lightbox Javascript-->

<!-- end pmc-tags-bottom Digioh --><!-- pmc-tags-bottom Comscore -->
	<script type="text/javascript" class="optanon-category-C0002">
		var comscore_vals = { c1: "2", c2: "6035310", c3: "", c4: "", c5: "", c6: "", c15: "" };
		var _comscore = _comscore || []; _comscore.push(comscore_vals); (function() { var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js"; el.parentNode.insertBefore(s, el); })();

		// Added to ensure that Comscore tags are triggered to fire on each slide of galleries
		(function(history){
			var pushState = history.pushState;
			history.pushState = function(state) {
			if (typeof history.onpushstate == "function") {
				history.onpushstate({state: state});
			}

			return pushState.apply(history, arguments);
			}
		})(window.history);

		// Trigger comscore beacon on change location.href
		window.onpopstate = history.onpushstate = function() {
			if ( COMSCORE !== undefined ) {
				setTimeout( function() {
					COMSCORE.beacon(comscore_vals);
				}, 1);
			}
		};
	</script>
<!-- end pmc-tags-bottom Comscore --><!-- pmc-tags-bottom Trackonomics -->
<!--START Trackonomics Tag-->
<script type="text/javascript" class="optanon-category-C0004" id="funnel-relay-installer" data-property-id="PROPERTY_ID" data-customer-id="pmc_0aaa4_stylecaster" src="https://cdn-magiclinks.trackonomics.net/client/static/v2/pmc_0aaa4_stylecaster.js" async="async"></script>
<!--END Trackonomics Tag-->
<!-- end pmc-tags-bottom Trackonomics -->
</body>
</html>