<!doctype html>
<!--[if lt IE 7]>      <html class="ie6" lang="en"> <![endif]-->
<!--[if IE 7]>         <html class="ie7" lang="en"> <![endif]-->
<!--[if IE 8]>         <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>         <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en">         <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<title>Taylor Swift Refused to Be on Karlie Kloss&#8217;s Talk Show | StyleCaster</title>

    <link rel="apple-touch-icon" sizes="192x192" href="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/apple-touch-icon-192x192.png" />
    <link rel="shortcut icon"  href="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.ico" />

    <link rel="icon" sizes="32x32" type="image/png"  href="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-32x32.png" />
    <link rel="icon" sizes="192x192" type="image/png" href="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/favicon-192x192.png" />

	        <script type='text/javascript'>
            /**
             * Restoring jQuery object if 3rd party plugins is removed/override jQuery
             */
            (function (w) {
                // Latest jQuery value
                var latestValue = undefined;
                
                // First jQuery value
                var firstValue = undefined;
                
                // Add getter and setter for jQuery
                Object.defineProperty(w, 'jQuery', {
                    
                    // jQuery getter
                    get: function () {
                        // if latest version jQuery is a function then return latest jQuery version
                        // if latest version jQuery is not a function then return first jQuery version
                        return ( 'function' === typeof latestValue ) ? latestValue : firstValue;
                    },

                    // jQuery setter
                    set: function (value) {
                        // override latesr jQuery version
                        latestValue = value;
                        // set up first jQuery version
                        if ('undefined' === typeof firstValue && 'function' === typeof value) {
                            firstValue = value;
                        }
                    }
                });

            })(window);
        </script>
        
	
<meta name="description" content="Taylor Swift and Karlie Kloss&#039;s friendship is officially over after the singer reportedly rejected the model&#039;s invitation to be on her new talk show, &quot;Movie Night with Karlie.&quot; Learn more information about Swift and Kloss&#039;s feud, here." />
<meta name="keywords" content="taylor swift, karlie kloss, celebrity friendships, celebrity breakups, movie night with karlie, rejected, feud, fight, breakup, refused, talk show" /><meta name="msvalidate.01" content="7A34A1C1904BAFB83691E8B3718CA9A2" />
<meta property="article:publisher" content="http://www.facebook.com/stylecaster" />
<meta name="google-site-verification" content="yB_5UwT5pPNnn93Mba5HIaFkNtbrafDQWP_Rj34Iw08" />

        <meta id="ad_wrapper_script" data-unit-name="entertainment/celebrity-gossip" />
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />            <script type="text/javascript" src="//content.jwplatform.com/libraries/ZNyazssg.js"></script>
                <!-- Facebook Pixel Code -->
        <script>
            !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
                n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
                n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
                t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
                document,'script','//connect.facebook.net/en_US/fbevents.js');
            // Insert Your Facebook Pixel ID below. 
            fbq('init', '1130306277008218');
            fbq('track', 'PageView');
        </script>
        <noscript>
            <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1130306277008218&amp;ev=PageView&amp;noscript=1" />
        </noscript>
        <!-- End Facebook Pixel Code -->

        <!--Additional template-specific events for Facebook Pixel-->
                            <script id="facebook-page-type" data-facebook-page-type="page-default">
                if ( typeof fbq != 'undefined' ) {
                    fbq('track', "page-default");
                }
            </script>    
        
                <script>
            (function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//comfortablecheese.com/0d54dab07da3e2c70e4c904001da3e0bcca526db5e6852893a5d2314eea316b18afeeb8af05e9b4e159a27858787b043438981d6a081e3ab397073de7b62');
        </script>
        		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=stylecaster.com&amp;id=35011528&amp;t=1508509830&amp;back=http%3A%2F%2Fstylecaster.com%2Ftaylor-swift-karlie-kloss-refused-talk-show-feud%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//scstylecaster.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Feed" href="http://stylecaster.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Comments Feed" href="http://stylecaster.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="StyleCaster &raquo; Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show Comments Feed" href="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJx9jsEOgkAMRH/ItUAM4MH4LUutsrCFhu5K+HtXiBc1XJrOZF5mYBaD4xBoCMDRiI8PNyjMgiMbZedp+VJHVD3Af8y7nhQ6CmKxN6vai+M4UfJZbHgnmG7OkidOsT2MpfxQ77dNXbs12/ymkYlUTbrsIpvQpqJfbrPh6QQUjYbFE1oNNJkiy0uQ2HiHkCi4J2Llr3zJT3VWZVVdnLsXwGZ9ag==' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJytkeFOwzAMhF+I1C1bkfoD8SxOlqUGNymxw7S3J2s3oQlRIcE/X3T+crnAaTYuRfVRQUc/eYEPmkGcET2zdyjqs3lsuyeYi2Vy4ERgxlCNQjGwb+rBA/wZY9C9FxJSSvG/kLvWHPAs33BTMTOXQFHgRIfgtW4kR8iGquVebGW5QQSJdcxlSbASGylWXCZ77YcgJl3pt2ErVvDJcHJ4aeNOmCMj5a3V7C2nUMewxPmSv3nJEZ23Kb2BaL1urXSpu5nox28Z9xA4WeSL4WV67vq2H7qhH4bXTy2y4U4=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var sc_ajax_script = {"ajaxurl":"\/wp-admin\/admin-ajax.php","siteurl":"http:\/\/stylecaster.com"};
var scMainData = {"isPreview":"false"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var scAdvertisingConfig = {"vertical":"entertainment\/celebrity-gossip","globalTargeting":{"liveinsite":"segments","url":["http:\/\/stylecaster.com\/taylor-swift-karlie-kloss-refused-talk-show-feud\/"],"dm_content":"false","tag":["celebrity breakups","celebrity friendships","karlie kloss","taylor swift"],"Article_Category":["Celebrity News","Entertainment"],"ci":"698158"},"pageType":"single"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sc_newsletter_wp_vars = {"nonce":"fc61720f51"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJytkttOwzAMhl+ILCuHjRvEDeKaV3ATr3WXE7HTqjw9qcQuEBUTopKlSPanL38U6ykpCsYVi6yHWu8F8/x17Aa+0b8BylOXQXDnKVxgE4NgkIX1sSWHqjBm6Gqvik5xhUuRxSNzhVam3yNRGAmnq9iAksCcVUamjx9W6bHep0dKmo1imR0aYMGsbvfNQafSOjKL9IQgpTp0yugiWMxrT/27zgMF1SPYbXRg1ZQhpa3isXl5ffuXasRgY778SiXJnGdlCkv0G2WkLpR0xZVc6ShUGMhJn8timMh2KDsuLZtM7bIcz/6pedgfj4e7x+Z++ARaJyO3'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scstylecaster.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" />
<link rel='shortlink' href='http://wp.me/p2mU64-2VCC' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fstylecaster.com%2Ftaylor-swift-karlie-kloss-refused-talk-show-feud%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fstylecaster.com%2Ftaylor-swift-karlie-kloss-refused-talk-show-feud%2F&amp;for=wpcom-auto-discovery" /><link rel='openid.server' href='http://scstylecaster.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='http://scstylecaster.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="http://stylecaster.com/osd.xml" title="StyleCaster" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />


<!-- BEGIN Sailthru Horizon Meta Information -->
<meta name="sailthru.date" content="2017-10-20 09:30:38" />
<meta name="sailthru.title" content="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" />
<meta name="sailthru.tags" content="celebrity breakups, celebrity friendships, karlie kloss, taylor swift" />
<meta name="sailthru.description" content="Swifties, you&#039;re going to want to cover your ears." />
<meta name="sailthru.image.full" content="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" />
<meta name="sailthru.image.thumb" content="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg?w=50" />
<!-- END Sailthru Horizon Meta Information -->

        <script>
            var _alcTag = _alcTag || [];
            (function() {
                var atag = document.createElement('script');
                atag.async = 1;
                atag.src = '//sc-p.alcmpn.com/wt/297/webtag.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(atag, node);
            })();
        </script>
        	<script class="gtm-script-container" type="text/javascript">
            ;(function(){
                // save url from which user came to the site to cookies.
                // We set cookie with help js because wordpress vip prohibits the cookies on the server side  
                if (document.referrer && document.referrer.split('/')[2] != document.domain) {
                    setCookie('sc_gtm_original_url', document.referrer, null);
                }

    	    	_gtmq = [{
                    'page_version':     isLayout.get(),
                    'full_URL':          "http:\/\/stylecaster.com\/taylor-swift-karlie-kloss-refused-talk-show-feud\/",
                    'base_URL':          "http:\/\/stylecaster.com\/taylor-swift-karlie-kloss-refused-talk-show-feud\/",
                    'query_Parameters':  "",
                    'is_Parallax':       "false",
                    'is_OriginalVideo':  "false",
                    'is_OriginalPhoto':  "false",
                    'is_Slideshow':      "false",
                    'is_ContentCreator': "false",
                    'is_Shoppable':       "false",


                                        'site_section': "stylecaster",
                    
                    'source_site_of_post' : "stylecaster",

                    'dm2sc': "0",

                    // post params
                                            'post_author': "Jason Pham",
                        'post_published': "10 2017",
                        'post_published_full': "10-20-2017 09:30",
                        'post_published_date': "2017-10-20",
                        'post_url': "http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/",
                        'post_title': "Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show",
                        'histurl': null,
                        // add type to characterize same events on different slideshows
                                                                            'post_tags': "|1151423||424192||4399793||972681|",
                                                                            'post_categories': "Celebrity News|Entertainment",
                                                                            'main_categories': "Entertainment",
                                                                            'sub_categories': "Celebrity News",
                                                    'article_id': "698158",
                                                'slide_num': null,
                                                'virtual_page_url': "\/taylor-swift-karlie-kloss-refused-talk-show-feud\/",
                        'post_position_in_page': '1',
                    
                    // tag page params
                    
                    // result search page params
                                        
                    // category page params
                    
                    // author page params
                    
                    // archive page params
                    
                    // meta data
                    'meta_title': jQuery("title").text(),

                    // page params
                    'page_type': "single-default",
                    'referrer_original': getCookie('sc_gtm_original_url') ? getCookie('sc_gtm_original_url') : '',

                                        // Original WP post data
                    'wp_post_type' : "post",
                    
                    'user_ip': "",
                    'user_agent': navigator.userAgent
                }];

                // loading the user_ip for the _gtmq
                // initial _pageView may receive empty user_ip since response from ip-api.com may be delayed
                jQuery.ajax({
                    url: "//ip-api.com/json",
                    dataType: 'json',
                    success: function (json){
                        _gtmq.push({
                            'event': 'UserIPReceived',
                            'user_ip': json.query
                        });
                    }
                });

                // add utm params to _gtmq
                var temp;
                if (temp = getUrlParam(window.location.href, 'utm_source')) {
                    _gtmq[0].utm_source = temp;
                }
                if (temp = getUrlParam(window.location.href, 'utm_medium')) {
                    _gtmq[0].utm_medium = temp;
                }
                if (temp = getUrlParam(window.location.href, 'utm_campaign')) {
                    _gtmq[0].utm_campaign = temp;
                }
                if (temp = getUrlParam(window.location.href, 'utm_term')) {
                    _gtmq[0].utm_term = temp;
                }
                if (temp = getUrlParam(window.location.href, 'utm_content')) {
                    _gtmq[0].utm_content = temp;
                }
            })();
    	</script>
    	        <script>
            (function(w){
                w.dataLayer_SKM = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Entertainment","subchannel":"Celebrity News","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":698158,"contentArticleTitle":"Taylor Swift Reportedly Rejected Karlie Kloss\u2019s Invitation to Be on Her New Talk\u00a0Show","contentPublishedDate":"2017-10-20","contentPublishedMonthYear":"2017-10","contentPublishedTimestamp":"2017-10-20-09-30-38","contentOriginalPublishedTimestamp":"2017-10-20-08-37-38","cmsAuthorId":"676479","momentumAuthorId":"_na_","contentAuthorName":"Jason Pham","articleCategories":"Celebrity News|Entertainment","contentTags":"celebrity breakups|celebrity friendships|karlie kloss|taylor swift","geoTarget":"US","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Editorial","scrollable":true,"infiniteScrollPageNum":1},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
            })(window);
        </script>
                <meta id="ad_wrapper_script" data-unit-name="entertainment/celebrity-gossip" />
                <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
        		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<script type="text/javascript">var ajaxurl = "http://stylecaster.com/wp-admin/admin-ajax.php"</script><meta name="application-name" content="StyleCaster" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Style News and Trends" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://stylecaster.com/feed/;icon-uri=http://1.gravatar.com/blavatar/f95e80beb275448b98a924f84cc3473a?s=16" /><meta property="og:site_name" content="StyleCaster" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="134683123322801" />
<meta property="og:url" content="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" />
<meta property="og:title" content="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" />
<meta property="og:description" content="Swifties, you&#039;re going to want to cover your ears." />
<meta property="article:published_time" content="2017-10-20T13:30:38+00:00" />
<meta property="article:modified_time" content="2017-10-20T13:37:47+00:00" />
<meta property="article:author" content="Jason Pham" />
<meta property="article:section" content="Celebrity News" />
<meta property="article:tag" content="Entertainment" />
<meta property="article:tag" content="celebrity breakups" />
<meta property="article:tag" content="celebrity friendships" />
<meta property="article:tag" content="karlie kloss" />
<meta property="article:tag" content="taylor swift" />
<meta property="og:image" content="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="540" />
<style type="text/css" id="syntaxhighlighteranchor"></style>
        <script type="text/javascript">
            !function(t,e,n){
                function a(t){
                    var a=e.createElement("script");
                    a.type="text/javascript",
                    a.async=!1,
                    a.src=("https:"===e.location.protocol?"https":"http")+":"+n,
                    (t||e.body||e.head).appendChild(a)
                }
                function o(){
                    var t=e.getElementsByTagName("script"),
                    n=t[t.length-1];
                    return n.parentNode
                }
                var p=o();
                t.spotId="sp_YAI3K1BD",
                t.parentElement=p,
                a(p)
            }(window.SPOTIM={},document,"//www.spot.im/launcher/bundle.js");
        </script>
        
	<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@stylecaster" /><meta name="twitter:creator" content="@stylecaster" /><meta name="twitter:title" content="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show"/><meta name="twitter:description" content="Swifties, you&#039;re going to want to cover your ears."/><meta name="twitter:image" content="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg"/><meta property="twitter:account_id" content="55678606" />        <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
        <!--[if lt IE 9]>
        <script src="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/html5shiv.min.js"></script>
        <script src="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/js/vendors/respond.min.js"></script>
        <![endif]-->
                <meta property="fb:pages" content="48566051011" />
        <meta property="fb:article_style" content="scdefault">
        </head>
<body class="post-template-default single single-post postid-698158 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light" data-paged="1" data-siteurl="http://stylecaster.com">
            <!-- Google Tag Manager -->
            <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TJWQRK"
                              height="0" width="0" class="ds-none hidden"></iframe></noscript>
            <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
                    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
                })(window,document,'script','_gtmq','GTM-TJWQRK');</script>
                <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P3KHGM"
                          height="0" width="0" class="ds-none hidden"></iframe></noscript>
        <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
                '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer_SKM','GTM-P3KHGM');</script>
            <!-- End Google Tag Manager -->
        
<div class="wrapper">
    
        <header class="header hide-when-active-popup" id="siteheader" data-gtm-link-location="Header"  >
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="http://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="http://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="http://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="http://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="http://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="http://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="http://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="http://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="http://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li> 
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </header>
    
        <div class="siteheadersticky header" id="siteheadersticky" data-gtm-link-location="Header">
        <div class="container container_top header_skinny" >

    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    
    <div class="logo_delimiter"></div>
    
    <div class="logo-small visible-desktop visible-tablet">
        <a href="http://stylecaster.com">StyleCaster</a>
    </div>

    <div class="logo visible-phone"><div class="ratio"></div><a href="http://stylecaster.com">StyleCaster</a></div>

    <div class="main_menu">
        <div class="main_menu">
    <ul class="mainmenu">
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/fashion/" />
	            <meta itemprop="name" content="Fashion" />
            	            		<a href="http://stylecaster.com/fashion/">Fashion</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/beauty/" />
	            <meta itemprop="name" content="Beauty" />
            	            		<a href="http://stylecaster.com/beauty/">Beauty</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/lifestyle/" />
	            <meta itemprop="name" content="Lifestyle" />
            	            		<a href="http://stylecaster.com/lifestyle/">Lifestyle</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/entertainment/" />
	            <meta itemprop="name" content="Entertainment" />
            	            		<a href="http://stylecaster.com/entertainment/">Entertainment</a>
            	            </li>
                    <li itemscope itemtype="http://www.schema.org/SiteNavigationElement">
	            <meta itemprop="url" content="http://stylecaster.com/sctv/" />
	            <meta itemprop="name" content="SCTV" />
            	            		<a href="http://stylecaster.com/sctv/">SC<span class="sc-icon-play-circle">tv</span></a>
            	            </li>
            </ul>
</div>    </div>

            <div class="search_container">
            <ul class="stretch-clns">
                <li>
                    <div class="mobile_menu_trigger">
                        <div class="border-menu"></div>
                    </div>

                    <div class="logo_delimiter"></div>

                    <div class="logo-small">
                        <a href="http://stylecaster.com">StyleCaster</a>
                    </div>
                </li>
                <li class="search-form-helper">
                    <form role="search" method="get" name="searchform" class="sc-search-form default-search-form" action="http://stylecaster.com/">
    <div class="search-button sc-icon-search-right">    
            <input class="" type="submit" value="" tabindex="-1">
        </div>
        <div class="search-field" >     
            <input class="" type="text" value=""  name="s" id="s"   tabindex="-1" />
        </div>
</form>
                </li>
                <li> 
                    <div class="close_btn sc-icon-close"></div>
                </li>
            </ul>
        </div>
        
    <div class="search_btn">
        <ul class="menu">
            <li class="search main-menu-search">
                <i class="sc-icon-search-right"></i>
            </li>
        </ul>
    </div>
</div>

<hr class="header_divider hidden-phone" />    </div>
        
            <div class="header" id="singleheader"  data-gtm-nav-show="0" data-gtm-link-location="PostNavBar">
        <div class="container shadow">
            
<div class="main">
    <div class="mobile_menu_trigger">
        <div class="border-menu"></div>
    </div>
    <div class="logo_delimiter"></div>
    <div class="logo hidden-phone">
        <a href="http://stylecaster.com">StyleCaster</a>
    </div>
    <div class="post_header_title">
                    <span>Share</span>
                <div class="social_menu square">
            <ul id="single-header-social-menu" class="social-menu-container" data-gtm-button-location="PostNavBar">
                <li class="sc-icon-facebook menu-item">
                    <a class="pretty_social" data-type="facebook" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Facebook</a>
                </li>
                <li class="sc-icon-pinterest menu-item">
                    <a class="pretty_social" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" data-type="pinterest" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Pinterest</a>
                </li>
                <li class="sc-icon-twitter menu-item">
                    <a class="pretty_social" data-type="twitter" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster">Twitter</a>
                </li>
                <li class="sc-icon-tumblr menu-item">
                    <a class="pretty_social" data-type="tumblr" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster">Tumblr</a>
                </li>
            </ul>
        </div>
        <h2 itemprop="name">Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show</h2>

    </div>
</div>


<div class="main_menu">
    <div class="hot-block">
        <i class="icon-fire"></i>
        <span>What's hot</span>        
    </div>
    <div class="post_prev_next_vav">
        <span class="trigger next">
            <i class="sc-icon-arrow-right"></i>
        </span>
        <span class="trigger back inactive">
            <i class="sc-icon-arrow-left"></i>
        </span>
    </div>
    <div id="sliderNexPrev" class="iner">
        <div class="post_prev_next next hidden-phone hidden-tablet-portrait scpin-no">
							<div class="post-item">
					<a class="next_post_link" href="http://stylecaster.com/demi-lovato-before-and-after-eating-disorder-photo/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2017/10/demi-lovato-feat.jpg?w=120&#038;h=120&#038;crop=1" alt="Demi Lovato Shares Powerful Before-and-After Recovery..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Demi Lovato Shares Powerful Before-and-After Recovery...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="http://stylecaster.com/beyonce-michelle-williams-prank-call-video/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2017/10/michelle-williams-beyonce.jpg?w=120&#038;h=120&#038;crop=1" alt="What Happened When Michelle Williams Prank Called..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									What Happened When Michelle Williams Prank Called...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="http://stylecaster.com/topless-nude-celebrity-pictures-pets/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2017/10/celeb_dogs_720.png?w=120&#038;h=120&#038;crop=1" alt="10 Celebrities Who Posed Topless with Their Pets" />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									10 Celebrities Who Posed Topless with Their Pets								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="http://stylecaster.com/shay-mitchell-roman-numerals-wrist-tattoo/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2017/10/shay-mitchell-2016-feat.jpg?w=120&#038;h=120&#038;crop=1" alt="Shay Mitchell Just Got a New, Delicate Wrist Tattoo..." />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Shay Mitchell Just Got a New, Delicate Wrist Tattoo...								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
							<div class="post-item">
					<a class="next_post_link" href="http://stylecaster.com/chris-evans-jenny-slate-back-together-couple/" rel="next">
						<div class="prev_next_image">
														<img src="https://scstylecaster.files.wordpress.com/2017/10/chris-evans-jenny-slate-feat.jpg?w=120&#038;h=120&#038;crop=1" alt="Are Chris Evans and Jenny Slate Back Together?" />
						</div>
						<div class="prev_next_title">
							<div>
								<p>
									Are Chris Evans and Jenny Slate Back Together?								</p>
							</div>
						</div>
						<div class="clear-both"></div>
					</a>
				</div>
			        </div>
    </div>
</div>        </div>
    </div>
    
    <div class="wrapper-header-ad-slot hidden-phone">
	<div class="header-ad-slot">
		<div class="header slideshow-header sc-top-ad">
			<div class="container">
				<div class="mobile_menu_trigger">
					<div class="border-menu"></div>
				</div>
				<div class="logo_delimiter"></div>
				<div class="logo-small visible-desktop visible-tablet">
					<a href="http://stylecaster.com">StyleCaster</a>
				</div>
								<div class="slideshow-ad-top-block">
					<div id="oas_Top2" class="sc-ad-init" data-position="Top2" data-internal-section="SlideShow"></div>
				</div>
			</div>
		</div>
	</div>
</div>
            <div class="page_content_container ">
        <div id="skin">
            <div class="isa_post_container " data-viglink-disable="false" data-post-id="698158" data-post-type="" data-post-authors="Jason Pham" data-categories-slug="celebrity-news,entertainment" data-categories="Celebrity News,Entertainment" data-tags="celebrity breakups,celebrity friendships,karlie kloss,taylor swift" data-page-title="Taylor Swift Refused to Be on Karlie Kloss&#8217;s Talk Show &laquo;  StyleCaster" data-gtm-article-type="" data-facebook-page-type="page-default" data-page-title-gtm="Taylor Swift Refused to Be on Karlie Kloss&#8217;s Talk Show | StyleCaster" href="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">
            <script>
            if( 'undefined' == typeof scGtmPremiumData ) {
                window.scGtmPremiumData = {};
            }
            window.scGtmPremiumData[698158] = [{"pageDetails":{"siteVersion":"2.0.8","siteId":2208790,"channel":"Entertainment","subchannel":"Celebrity News","channelLvl3":"_na_","channelLvl4":"_na_","cmsTemplateName":"single","contentCMS":"WordPress VIP StyleCaster","contentArticleId":698158,"contentArticleTitle":"Taylor Swift Reportedly Rejected Karlie Kloss\u2019s Invitation to Be on Her New Talk\u00a0Show","contentPublishedDate":"2017-10-20","contentPublishedMonthYear":"2017-10","contentPublishedTimestamp":"2017-10-20-09-30-38","contentOriginalPublishedTimestamp":"2017-10-20-08-37-38","cmsAuthorId":"676479","momentumAuthorId":"_na_","contentAuthorName":"Jason Pham","articleCategories":"Celebrity News|Entertainment","contentTags":"celebrity breakups|celebrity friendships|karlie kloss|taylor swift","geoTarget":"US","contentAuthorType":"Staff","isShoppable":false,"sponsorshipProducedId":"_na_","sponsorshipRunningId":"_na_","sponsorshipRunningName":"_na_","sponsorshipBucketId":"_na_","sponsorshipBucketName":"_na_","contentProductionType":"Editorial"},"dfp":{"adUnitLvl1":"8352","adUnitLvl2":"stylecaster","adUnitLvl3":"_na_","adUnitLvl4":"_na_","adUnitLvl5":"_na_"},"siteSpecific":{"variableGroup1":"_na_","variableGroup2":"_na_","variableGroup3":"_na_","variableGroup4":"_na_","variableGroup5":"_na_"},"videoDetails":{"country":"_na_","sponsored":"_na_","sponsorshipCampaignId":"_na_","sponsorshipCampaignLineID":"_na_","season":"_na_","authorID":"_na_","publishedBy":"_na_","publisherType":"_na_","clickable":"_na_","subChannel":"_na_","videoBrand":"_na_","channel":"_na_","playerType":"_na_","show":"_na_","publishDate":"_na_","title":"_na_","playerId":"_na_","author":"_na_","sourceFile":"_na_","type":"_na_","sheknowsId":"_na_","authorType":"_na_","autoPlay":"_na_","sound":"_na_","preroll":"_na_","fullScreen":"_na_","playlistId":"_na_","playlistTitle":"_na_","playlistVideoCount":"_na_","playlistPosition":"_na_","uploadedDate":"_na_","videoLength":"_na_","playerLocation":"_na_"}}];
        </script>
                <div class="container">
        <div class="content-split sc-section_single sc-section-can-stiky">
            <aside class="sc-sidebar sc-sidebar-single visible-desktop">
              <div class="sc-adv-wrap">
                  <div class="sc-adv-wrap-help">
                      <div id="sc_adwrapperunit-4" class="widget widget_sc_adwrapperunit">
        <div class="sc-ad-init" id="oas_Middle3" data-position="Middle3"></div>
        
        </div>
                  </div>
              </div>
            </aside>
            <article class="main_content_area sc-main_content  " itemscope itemtype="http://schema.org/Article">
                <meta itemprop="mainEntityOfPage" content="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" />
                <meta itemprop="name" content="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" />
               <div class="sc-single-column">
                   <div class="article " data-current-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/"   data-next-url="http://stylecaster.com/kourtney-kardashian-healthy-starbucks-drink-order/" >
                       <header>
                           
                           
                           
                                                                                     <h1 itemprop="headline">Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show</h1>
                           
                           <div class="post_detail">
                               <div class="post_head_detials" data-gtm-button-location="Post Shared Count">
                                   <div class="sc-column">
                                               <ul class="sharecount-social-btns social_menu colored ">
            <li class="menu-item sc-icon-facebook"><a href="javascript:void(0);" class="pretty_social" data-type="facebook" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Facebook</a></li>
            <li class="menu-item sc-icon-pinterest"><a href="javascript:void(0);" class="pretty_social" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" data-type="pinterest" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Pinterest</a></li>            
            <li class="menu-item sc-icon-twitter"><a href="javascript:void(0);" class="pretty_social icon-twitter" data-type="twitter" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster">Twitter</a></li>
            <li class="menu-item sc-icon-tumblr"><a href="javascript:void(0);" class="pretty_social" data-type="tumblr" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Tumblr</a></li>
                            <li class="menu-item sc-icon-comment"><span class="sc-comments-count spot-im-replies-count" data-post-id="698158">0</span></li>
                    </ul>
                                           </div>
                                   
                                   <div class="sc-column">

                                       <div class="sc-post-avatar"><img width="0" height="0" src="http://scstylecaster.files.wordpress.com/2017/05/5814f0acb4e987d10d263e3e6210e2a8.jpeg?resize=%2C" class="sc-desaturate-image scpin-no avatar avatar-0 photo wp-post-image"></div>                                       
                                                                              <span class="sc-post-author">by<span itemprop="author"><a href="http://stylecaster.com/author/jasonapham/" title="Posts by Jason Pham" class="author url fn" rel="author">Jason Pham</a></span></span>

                                                                              
                                                                              <span itemprop="datePublished" content="2017-10-20T09:30:38+00:00" class="sc-post-date hidden-phone">60 mins ago</span>
                                       <meta itemprop="dateModified" content="2017-10-20T09:37:47+00:00" />
                                               <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
            <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                <meta itemprop="url" content="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/base64/Stylecaster-logo.png">
                <meta itemprop="width" content="600">
                <meta itemprop="height" content="60">
            </div>
            <meta itemprop="name" content="StyleCaster">
        </div>

                                           </div>
                               </div>
                           </div>
                           
                                   
                <div class="sc_feature_image_container " itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <img src="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" title="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" alt="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" />
            <meta itemprop="url" content="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" />
            <meta itemprop="width" content="712" />
            <meta itemprop="height" content="400" />
                    </div>
        
                            <div class="photo-detail">Photo:
                                    <span class="source">Getty Images</span>
                            </div>
            
        
                                           
                                                      
                                                      
                       </header>
                       <div class="post_content format clearfix" data-gtm-pin-location="PostContent" itemprop="articleBody">
                                                      <p class="big_first_letter">New evidence has emerged leading fans to believe that <strong>Taylor Swift</strong>‘s friendship with <strong>Karlie Kloss</strong> is officially over. (Swifties, you’re going to want to close your ears for this one.) On Wednesday, the 25-year-old model announced that she would be hosting a new talk show on Freeform titled, “Movie Night with Karlie Kloss.” The premise is simple: Kloss would invite her A-list friends to her studio where they would do girls’ night in things like bake, play board games, and watch movies.</p>
<p>Given the premise, it seemed like the perfect opportunity for Kloss to bring her one-time BFF, Swift, to her show to squash rumors once and for all that the two are feuding. As you might expect, that’s not going to happen. According to <a href="https://theblast.com/taylor-swift-karlie-kloss-movie-night/" target="_blank" rel="noopener" target="_blank">The Blas</a>t, Kloss actually reached out to Swift to appear on the program. But, due to “scheduling issues,” the singer “politely declined,” sources close to the show’s production told the site.</p>
<p>“Scheduling issues” isn’t a totally B.S. excuse. Swift’s sixth album, <em>Reputation</em>, drops next month. And, with an international tour to follow, the singer’s months are clearly booked. Still, it hasn’t quieted rumors that Kaylor is officially donezo.</p>
<h2>MORE: <a href="http://stylecaster.com/taylor-swift-karlie-kloss-feud/" target="_blank" rel="noopener">Here’s Why Fans Think Taylor Swift and Karlie Kloss Are Feuding Hardcore</a>
</h2>
<div class="sc-instagram-wrapper sc-inst-center">
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-version="7" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:650px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:8px;"> <div style=" background:#F8F8F8; line-height:0; margin-top:40px; padding:50% 0; text-align:center; width:100%;"> <div style=" background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;"></div>
</div> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/BaXC1v9FbQV/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" target="_blank">#MovieNightWithKarlie and friends coming to your living room this winter on @Freeform!!! 📺 🍿👯</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by Karlie Kloss (@karliekloss) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2017-10-17T18:59:50+00:00">Oct 17, 2017 at 11:59am PDT</time></p>
</div></blockquote>
</div>
<p>As for who is appearing on the show, Kloss confirmed on her Instagram that fellow supermodels like <strong>Ashley Graham</strong> and <strong>Jourdan Dunn</strong> will be there. Also confirmed is <strong>Kendall Jenner</strong>, the little sister of Swift’s nemesis, <strong>Kim Kardashian</strong>—a move that also raised eyebrows among fans. The Blast reports that <strong>Kaia Gerber</strong>, <strong>Rachel Bilson</strong>, and<strong> Serena Williams</strong>, another frequent squad member, will also appear.</p>
<p>As Swifties know, this isn’t the first time bad blood rumors have stirred between Kloss and Swift. Over the summer, at Paris Fashion Week, <a href="http://stylecaster.com/taylor-swift-karlie-kloss-feud/" target="_blank" rel="noopener">Kloss took a selfie with Jenner</a>—sparking rumors that the one-time Swift squad captain jumped ships to the Kardashian-Jenner side.</p>
<p>Then, in August, Swift dropped the music video for <a href="http://stylecaster.com/omg-moments-2017-vmas/" target="_blank" rel="noopener">“Look What You Made Me Do” at the Video Music Awards</a>. In one scene, the singer can be seen sporting a t-shirt with the names of her friends like <strong>Blake Lively</strong> and the <strong>HAIM</strong> sisters. Noticeably missing was Kloss’s name, further leading fans to believe that the two are no more.</p>
<h2>MORE: <a href="http://stylecaster.com/celebrities-who-dislike-taylor-swift/">10 Celebrities Who You Didn’t Know Have Beef with Taylor Swift</a>
</h2>
<p>However, it’s important to note that right now, everything is speculation. There’s no confirmation either way to the status of Kloss and Swift’s friendship. Still, if we know anything about Swift, she’s not going to leave any stone unturned. So we guess we’ll just have to wait until November 10 when <em>Reputation</em> drops to see what’s really up.</p>                                                                                                                                   </div>
                       <script>
                           // wrapper for adding responsive styles, and fix embed overlapping sidebar
                           jQuery('.post_content .wpcom-protected-iframe').wrap('<p class="embed-video-wrapper"></p>')
                       </script>
                                   <!-- BEGIN Bringhub MSF -->
            <iframe class="bh-mini-storefront"
            data-bh-container=".isa_post_container"
            data-bh-url-attr="href"
            data-bh-url-selector=".isa_post_container"
            onload="(function(a,b,c){a[b]=a[b]||[];a[b].push(['_initMktpl',c])})(window,'_bh', this)" style="display: none;">
            </iframe>
            <!-- END Bringhub MSF -->
                                       <div class="post_share  comments-visible  pretty_socials clearfix" data-gtm-button-location="Post Share" data-gtm-pin-location="Post Share">
            <ul>
                <li class="facebook">
                    <div>
                        <a href="#" class="pretty_social sc-icon-facebook" data-type="facebook" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/"><span>share</span></a>
                    </div>
                </li><!--
                --><li class="pinterest">
                    <div>
                        <a href="#" class="pretty_social sc-icon-pinterest" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show | StyleCaster" data-media="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" data-type="pinterest" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/"><span>pin</span></a>
                    </div>
                </li><!--
                --><li class="twitter">
                    <div>
                        <a href="#" class="pretty_social sc-icon-twitter" data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show" data-type="twitter" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster"><span>tweet</span></a>
                    </div>
                </li><!---
                --><li class="tumblr">
                    <div>
                        <a href="#" class="pretty_social sc-icon-tumblr" data-type="tumblr" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/"><span>tumblr</span></a>
                    </div>
                </li>
                                    <li class="comments">
                        <div>
                            <a href="javascript:void(0);" class="pretty_social sc-icon-comment" data-type="comments"><span class="sc-comments-count spot-im-replies-count" data-post-id="698158">0</span><span>comments</span></a>
                        </div>
                    </li>
                            </ul>
        </div>
                                       <section class="post_tags modal clearfix">
            <div class="post_tags_category">
                    <span class="more_tag">Tags:</span>
                    <ul>
                                                                                <li><a href="http://stylecaster.com/tag/celebrity-breakups/" class="tag-item small">celebrity breakups</a></li>
                                                                                <li><a href="http://stylecaster.com/tag/celebrity-friendships/" class="tag-item small">celebrity friendships</a></li>
                                                                                <li><a href="http://stylecaster.com/tag/karlie-kloss/" class="tag-item small">karlie kloss</a></li>
                                                                                <li><a href="http://stylecaster.com/tag/taylor-swift/" class="tag-item small">taylor swift</a></li>
                                            </ul>
            </div>
        </section>
                           </div>
                   <div class="sidebar_after_post_content">
                                          </div>

                   <div class="zergnet-container d-none">
                       <p class="zergnet-header">Promoted Stories</p>
                   </div>

                           <div class="sc_comments">
            <div class="sc-comment-wrapper">
                <div class="spot-im-frame-inpage" data-post-id="698158"  data-post-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-messages-count="3" data-sort-by="best"></div>
            </div>
        </div>
        <div class="sc-spotim-recirculation-wrapper">
            <div class="sc-spotim-recirculation-border"></div>
            <div data-spotim-module="recirculation" data-spot-id="sp_YAI3K1BD"></div>
            <script src="https://recirculation.spot.im/spot/sp_YAI3K1BD" data-spotim-script="recirculation"></script>
        </div>
        
                                  </div>
           </article>
        </div>
    </div>
    
    <div id="oas_300x250_mobile" class="oas_300x250_mobile sc-ad-init" data-position="Middle2" ></div>
    
    <div class="post-splitter"></div>
</div>        </div>
    </div>

    
    
    <footer class="footer" data-gtm-link-location="Footer">
        <div class="footer-wraper">
            <div class="stretch-clns">

  <div class="hp-column main-logo">
    <a href="http://stylecaster.com"><div class="logo"></div></a>
  </div>

  <div class="hp-column">
    <div class="footer_menu">
      <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" href="http://corporate.sheknows.com/team">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://stylecaster.com/advertise/">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" href="http://corporate.sheknows.com/contact">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" href="http://corporate.sheknows.com/careers">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" href="http://corporate.sheknows.com/news">Press</a></li>
</ul></div>    </div>
  </div>

  <div class="hp-column">
    <div class="social_menu" data-gtm-button-location="Footer">
      <div class="menu-global-social-profiles-container"><ul id="menu-global-social-profiles" class="menu"><li id="menu-item-593286" class="sc-icon-mail menu-item menu-item-type-post_type menu-item-object-page menu-item-593286"><a target="_blank" href="http://stylecaster.com/signup/">Signup</a></li>
<li id="menu-item-218288" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-218288"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-218287" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-218287"><a target="_blank" rel="me" href="http://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-593287" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-593287"><a target="_blank" rel="me" href="http://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-218289" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-218289"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-218291" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-218291"><a target="_blank" rel="me" href="http://instagram.com/stylecaster">Instagram</a></li>
</ul></div>    </div>
  </div>

</div>

<div class="copy stretch-clns">
    <div class="hp-column sheknows-wrapper">
        <a class="sheknows-copy" href="http://www.sheknows.com/beauty-and-style" target="_blank"><span>Sheknows Media</span><i>Beauty and Style</i></a>
    </div>
    <div class="hp-column">
        <p class="copyright">
            copyright 2017 &copy; all rights reserved by stylecaster        </p>
        <div class="menu-copyright-menu-container"><ul id="menu-copyright-menu" class="menu"><li id="menu-item-341577" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341577"><a target="_blank" href="http://www.sheknows.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-341579" class="norewrite menu-item menu-item-type-custom menu-item-object-custom menu-item-341579"><a target="_blank" href="http://www.sheknows.com/terms-of-use">Terms Of Use Agreement</a></li>
<li id="menu-item-218296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218296"><a href="http://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-694233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694233"><a href="http://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>    </div>
</div>
<div class="footer-right-bottom-block">
	<div class="footer-copy-right">
		<p class="powered-by">Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=stylecaster.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></p>
	</div>
</div>        </div>
    </footer>

    </div>
<div class="mobile_splash" id="sc-mobile-splash"></div>
<div class="mobile_menu">
    <div class="logo"><a href="http://stylecaster.com">StyleCaster</a></div>
    <div class="close_btn sc-icon-close"></div>
    <div class="mobile_menu_inner">
        <div class="mobile_menu_swipe">
            <div class="menu-new-main-navigation-container"><ul id="menu-new-main-navigation" class="menu"><li id="menu-item-218309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218309"><a href="http://stylecaster.com/fashion/">Fashion</a>
<ul class="sub-menu">
	<li id="menu-item-218313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218313"><a href="http://stylecaster.com/fashion-news/">Fashion News</a></li>
	<li id="menu-item-218314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218314"><a href="http://stylecaster.com/street-style/">Street Style</a></li>
	<li id="menu-item-476084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476084"><a href="http://stylecaster.com/tips-trends/">Tips + Trends</a></li>
	<li id="menu-item-218335" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218335"><a href="http://stylecaster.com/shopping/">Shopping</a></li>
	<li id="menu-item-476085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476085"><a href="http://stylecaster.com/celebrity-looks/">Celebrity Looks</a></li>
</ul>
</li>
<li id="menu-item-218321" class="beautyhigh-submenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218321"><a href="http://stylecaster.com/beauty/">Beauty</a>
<ul class="sub-menu">
	<li id="menu-item-441672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441672"><a href="http://stylecaster.com/beauty/makeup/">Makeup</a></li>
	<li id="menu-item-476090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476090"><a href="http://stylecaster.com/beauty/hair-nails/">Hair + Nails</a></li>
	<li id="menu-item-441674" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441674"><a href="http://stylecaster.com/beauty/skin-care/">Skin Care</a></li>
	<li id="menu-item-503638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-503638"><a href="http://stylecaster.com/beauty/health-fitness/">Health + Fitness</a></li>
</ul>
</li>
<li id="menu-item-218316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-218316"><a href="http://stylecaster.com/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-476086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476086"><a href="http://stylecaster.com/home/">Home</a></li>
	<li id="menu-item-476290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476290"><a href="http://stylecaster.com/travel/">Travel</a></li>
	<li id="menu-item-319491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-319491"><a href="http://stylecaster.com/food-and-drink/">Food + Drink</a></li>
	<li id="menu-item-476088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476088"><a href="http://stylecaster.com/love-sex/">Love + Sex</a></li>
</ul>
</li>
<li id="menu-item-218842" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-218842"><a href="http://stylecaster.com/entertainment/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-218330" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-218330"><a href="http://stylecaster.com/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-218332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218332"><a href="http://stylecaster.com/tv-movies/">TV + Movies</a></li>
	<li id="menu-item-218331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218331"><a href="http://stylecaster.com/music/">Music</a></li>
	<li id="menu-item-476292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-476292"><a href="http://stylecaster.com/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-513736" class="menu-item-sctv menu-item menu-item-type-taxonomy menu-item-object-category menu-item-513736"><a href="http://stylecaster.com/sctv/">SCTV</a></li>
</ul></div>
            <div class="newsletter_signup signup-form">
	<h5 class="subscribed-status">WANT <span>MORE?</span></h5>
	<h6 class="subscribed-message">Get STYLECASTER in your inbox</h6>
		<form method="post" class="sc-newsletter-form" autocomplete="off" data-location="expanded-menu" data-source="SignUp-Hamburger">
		<div id="email-validation"></div>
		<input name="additional_information" class="additional_information" type="text" placeholder="Enter Your Email Address" />
		<input name="email" class="email-field" type="text" placeholder="Enter Your Email Address">
		<div class="newsletter-item">
			<input type="checkbox" checked name="daily" class="daily_newsletter" id="daily_checkbox2" value="1" data-newsletter="daily" />
			<label for="daily_checkbox2"><span></span><p>STYLECASTER Daily</p></label>
		</div>
		<div class="newsletter-item">
			<input type="checkbox" checked name="beauty" class="beauty_newsletter" id="beauty_checkbox2" value="1" data-newsletter="beauty" />
			<label for="beauty_checkbox2"><span></span><p>STYLECASTER Beauty</p></label>
		</div>
		<input type="submit" class="subscribe-button" value="Submit" />
		<input type="hidden" name="source" value="SC_Menu" />
	</form>
</div>
            <div class="social_menu">
                <div class="menu-expanded-menu-social-container"><ul id="menu-expanded-menu-social" class="menu"><li id="menu-item-609237" class="sc-icon-facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-609237"><a target="_blank" rel="me" href="https://www.facebook.com/stylecaster">Facebook</a></li>
<li id="menu-item-609238" class="sc-icon-pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-609238"><a target="_blank" rel="me" href="http://www.pinterest.com/stylecaster/">Pinterest</a></li>
<li id="menu-item-609239" class="sc-icon-twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-609239"><a target="_blank" rel="me" href="https://twitter.com/StyleCaster">Twitter</a></li>
<li id="menu-item-609240" class="sc-icon-tumblr menu-item menu-item-type-custom menu-item-object-custom menu-item-609240"><a target="_blank" rel="me" href="http://stylecaster.tumblr.com/">Tumblr</a></li>
<li id="menu-item-609241" class="sc-icon-instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-609241"><a target="_blank" rel="me" href="http://instagram.com/stylecaster">Instagram</a></li>
</ul></div>            </div>
            <div class="mobile_footer_menu">
                <div class="menu-new-footer-menu-container"><ul id="menu-new-footer-menu" class="menu"><li id="menu-item-218301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218301"><a target="_blank" href="http://corporate.sheknows.com/team">About Us</a></li>
<li id="menu-item-218303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218303"><a href="http://stylecaster.com/advertise/">Advertise</a></li>
<li id="menu-item-218304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218304"><a target="_blank" href="http://corporate.sheknows.com/contact">Contact Us</a></li>
<li id="menu-item-218305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218305"><a target="_blank" href="http://corporate.sheknows.com/careers">Careers</a></li>
<li id="menu-item-218306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218306"><a target="_blank" href="http://corporate.sheknows.com/news">Press</a></li>
</ul></div>            </div>
            <div class="mobile_copyright_menu">
                <div class="menu-expanded-menu-copyright-container"><ul id="menu-expanded-menu-copyright" class="menu"><li id="menu-item-646562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-646562"><a target="_blank" href="http://www.sheknows.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-646563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-646563"><a target="_blank" href="http://www.sheknows.com/terms-of-use">Terms Of Use</a></li>
<li id="menu-item-646564" class="sc-new-line menu-item menu-item-type-custom menu-item-object-custom menu-item-646564"><a href="http://www.stylecaster.com/feed">RSS</a></li>
<li id="menu-item-646561" class="sc-round-forest-expanded no-delimiter menu-item menu-item-type-custom menu-item-object-custom menu-item-646561"><a target="_blank" href="http://www.sheknows.com/bestdeals/">Best Deals</a></li>
<li id="menu-item-680918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-680918"><a target="_blank" href="http://www.sheknows.com/best-reviews">Best Reviews</a></li>
<li id="menu-item-680919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-680919"><a target="_blank" href="http://www.sheknows.com/top-fashion">Top Fashion</a></li>
<li id="menu-item-680920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-680920"><a target="_blank" href="http://www.sheknows.com/tv-guide">TV Guide</a></li>
<li id="menu-item-694234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694234"><a href="http://stylecaster.com/amazon-affiliate-disclosure/">Amazon Affiliate Disclosure</a></li>
</ul></div>            </div>
        </div>
    </div>
</div>
<script>
window.twttr = (function (d,s,id) {
    var t, js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return; js=d.createElement(s); js.id=id; js.async=true;
    js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
    return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
}(document, "script", "twitter-wjs"));
</script>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>        <div id="oas_Bottom" class="blogher-ad" data-position="Bottom"></div>
        
<!-- wpcom_wp_footer -->
        <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebSite","name":"StyleCaster","url":"http:\/\/stylecaster.com"}</script>
        <div class="inline-slideshow-zoom-popup">
	<div class="slide-content"></div>
	<i class="sc-close-icon"></i>
</div>
		<div id="single-social-header" class="visible-phone">
			<span class="social-header-text">share</span>
			<ul data-gtm-button-location="Post Sticky Header" data-gtm-link-location="Post Sticky Header">
				<li class="sc-icon-facebook">
					<a class="pretty_social" data-type="facebook" data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Facebook</a>
				</li>
				<li class="sc-icon-pinterest">
					<a class="pretty_social"
					   data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show | StyleCaster"
					   data-media="https://scstylecaster.files.wordpress.com/2017/10/karlie-kloss-taylor-swift-feat.jpg" data-type="pinterest"
					   data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/">Pinterest</a>
				</li>
				<li class="sc-icon-twitter">
					<a class="pretty_social" data-type="twitter"
					   data-description="Taylor Swift Reportedly Rejected Karlie Kloss&#8217;s Invitation to Be on Her New Talk&nbsp;Show"
					   data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster">Twitter</a>
				</li>
				<li class="sc-icon-tumblr">
					<a class="pretty_social" data-type="tumblr"
					   data-url="http://stylecaster.com/taylor-swift-karlie-kloss-refused-talk-show-feud/" data-via="StyleCaster">Tumblr</a>
				</li>
			</ul>
		</div>
		<div class="mobile-vertical-slideshow">
    <div class="close-mobile-slideshow-container">
        <a href="javascript:void(0);" class="close-mobile-slideshow"></a>
    </div>
    <div class="slideshow-scroll-container">
        <div class="sc-mobile-slideshow">
            <div class='main-gallery'>
                <div class="scroll-to-see">
                    <span></span>
                </div>
                <div class="main-post-title"></div>
                <div class="social_menu">
                    <ul id="mobile-slideshow-social-menu"  data-gtm-button-location="mobile slideshow header" class="social-menu-container">
                        <li class="sc-icon-facebook menu-item">
                            <a class="pretty_social" data-type="facebook" data-url="">Facebook</a>
                        </li>
                        <li class="sc-icon-pinterest menu-item">
                            <a class="pretty_social" data-type="pinterest" data-description="" data-media="" data-url="">Pinterest</a>
                        </li>
                        <li class="sc-icon-twitter menu-item">
                            <a class="pretty_social" data-type="twitter" data-description="" data-url="" data-via="StyleCaster">Twitter</a>
                        </li>
                    </ul>
                </div>
                <ul class="slides-list slide-images"></ul>
            </div>
            <div class="more-slideshows"></div>
            <ul></ul>
        </div>
    </div>
</div>

<script type="text/template" id="slide-view-template">
    <div class="mobile-slide">
        <div class="slide-number"><%- slide.slideNumber %> <span>of</span> <%- countSlides %></div>
        <% if ( slide.type == "instagram") { %>
        <div class="embedded-instagram-container">
            <div class="embedded-instagram">
                <%= slide.instagram %>
            </div>
        </div>
        <% } else if( slide.type == "tumblr" ) { %>
        <div class="embedded-tumblr-container">
            <%= slide.tumblr %>
        </div>
        <% } else { %>
        <div class="slide-img">
            <img src="https://s0.wp.com/wp-content/themes/vip/sc-stylecaster-2016/public/assets/images/1x1.trans.gif" data-original="<%- slide.mobileUrl %>" height="<%- slide.sizes.height %>" width="<%- slide.sizes.width %>" <% if ( slide.slide_alt) { %>alt="<%= slide.slide_alt %>"<% } %> />
            <noscript><img src="<%- slide.mobileUrl %>" alt="<%- slide.caption %>" /></noscript>
        </div>
        <% } %>
        <% if ( slide.caption || slide.author || slide.title || slide.is_sponsored ) { %>
        <div class="slide-description format">
            <% if ( slide.author ) { %>
                <p class="author ">
                <% if ( slide.creditLabel) { %>
                    <%= slide.creditLabel %>:
                                     <% } else { %>
                    Photo:
                <% } %>
                <span><%= slide.author %></span></p>
            <% } %>
            <% if ( slide.is_sponsored ) { %>
                <p class="slide-sponsored">sponsored</p>
            <% } %>
            <% if ( slide.caption || slide.title ) { %>
                <div class="caption ">
                    <% if ( slide.title ) { %>
                        <p class="image-title"><strong><%= slide.title %></strong></p>
                    <% } %>
                    <%= slide.caption %>
                </div>
             <% } %>
        </div>
        <% } %>
    </div>
</script>

<script type="text/template" id="more_slideshows-view-template">
    <div class="more-slideshow-background-image">
        <img src="<%- slideshow.thumbnail %>" alt="<%- slideshow.title %>"/>
    </div>
    <div class="more-slideshow-background"></div>
    <div class="more-slideshow-content">
        <span><%- slideshow.slideshowTitle %></span>
        <h2 class="slideshow-title" ><%= slideshow.title %></h2>
        <div class="social_menu">
            <ul class="social-menu-container">
                <li class="sc-icon-facebook menu-item">
                    <a class="pretty_social" data-type="facebook" data-url="<%- slideshow.permalink %>">Facebook</a>
                </li>
                <li class="sc-icon-pinterest menu-item">
                    <a class="pretty_social" data-description="<%= slideshow.pinterestShareCaption %>" data-media="<%= slideshow.pinterestShareImage %>" data-type="pinterest" data-url="<%- slideshow.permalink %>">Pinterest</a>
                </li>
                <li class="sc-icon-twitter menu-item">
                    <a class="pretty_social" data-type="twitter" data-description="<%= slideshow.title %>" data-url="<%- slideshow.permalink %>" data-via="StyleCaster">Twitter</a>
                </li>
            </ul>
        </div>
        <a href="<%- slideshow.permalink %>#autoplay" class="start-slideshow" title="<%= slideshow.title %>">
            <%- slideshow.btnTitle %>
        </a>
    </div>
</script>

<script>
    // start slideshow immediately
    if ( location.hash == '#autoplay' && scGetDocumentWidth() < 768) {
        var elem = document.getElementsByClassName("mobile-vertical-slideshow");
        if (typeof elem[0] != 'undefined') {
            elem[0].style.display = 'block';
            document.getElementsByTagName('html')[0].className+='active-popup'
        }
    }
</script>        <script type='text/javascript'>
            var _sf_async_config = _sf_async_config || {};
            /** CONFIGURATION START **/
            _sf_async_config.uid = 7673; // hardcoded Chartbeat ID
            _sf_async_config.domain = 'stylecaster.com';
            /** Doesn't track custom canonical path **/
                            _sf_async_config.useCanonical = true;
             
                        _sf_async_config.authors = "Jason Pham";
            
                        _sf_async_config.sections = "celebrity-news,entertainment";
                        /** CONFIGURATION END **/

                (function() {
                    function loadChartbeat() {
                        window._sf_endpt = (new Date()).getTime();
                        var e = document.createElement('script');
                        e.setAttribute('language', 'javascript');
                        e.setAttribute('type', 'text/javascript');
                                                    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
                                                document.body.appendChild(e);
                    }
                    var oldonload = window.onload;
                    window.onload = (typeof window.onload != 'function') ?
                        loadChartbeat : function() {
                        oldonload();
                        loadChartbeat();
                    };
                })();
        </script>
    <script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201742y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/scstylecaster.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/scstylecaster.wordpress.com\/wp-login.php?action=logout&_wpnonce=4a5db4a2f9","homeURL":"http:\/\/stylecaster.com\/","postID":"698158","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>
<!-- Sailthru Horizon  Async-->
<script type="text/javascript">
(function() {
     function loadHorizon() {
           var s = document.createElement('script');
           s.type = 'text/javascript';
          s.async = true;
          s.src = location.protocol + '//ak.sail-horizon.com/horizon/v1.js';
         var x = document.getElementsByTagName('script')[0];
         x.parentNode.insertBefore(s, x);
      }
     loadHorizon();
      var oldOnLoad = window.onload;
      window.onload = function() {
          if (typeof oldOnLoad === 'function') {
            oldOnLoad();
         }
           Sailthru.setup({
              domain: 'horizon.dailymakeover.com,horizon.stylecaster.com'
         });
     };
  })();
 </script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytlUtuAjEMhi/UEECCikXVQ9B95cl4Zjzk1diBzu0bUCVQ1R1eRnE+/37GXrJxKQpGsTPbHs/kMH+vZn6xD1ehmuzrSJGtpxOy/apYcYLYeyx/jWXC0EzOlC07w7J4dMCCxWzXm73NtfPkrt7OGPtU2M6NVhYjkFeBohouVTcdL5RRk4rtLE8BBwSppZnyBAU6j4YCjMiaKmkoEFAKuFOrj4raET5vsavqZKGmMBhXWVLQJFcyOAzontR7LxYJmgmh18onu5K8/0hKNITiJtOBmrrb5CjRQuqo9XnAWDWTh71uRa7N2HqSelTL42/k0Cu14QgmFwxUnxuWOw9T27tlRKWdFqBRFMe4BSuyHJMj8P9xHz6mrbnS55sTAxH80urJ7cF7eNvs1rvDZn943c0/9p+PXw=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"channelUrl":"https:\/\/scstylecaster.wordpress.com\/wp-content\/themes\/vip\/plugins\/facebook\/channel.php","xfbml":true,"appId":"134683123322801"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<div id="fb-root"></div><script type="text/javascript">(function(d){var id="facebook-jssdk";if(!d.getElementById(id)){var js=d.createElement("script"),ref=d.getElementsByTagName("script")[0];js.id=id,js.async=true,js.src="http:\/\/connect.facebook.net\/en_US\/all.js",ref.parentNode.insertBefore(js,ref)}})(document)</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJy1ks1OQjEQRl/IoWAChoVxZ+KClU/Qn+Eyl7ZTpi03vL29xiAxcaNl17RfTr85GTUlsBwLxqJCheTrQDEr7QJFMFpU0LmgtBPwGUXIYf6+W4z5Qd0QygFDez9TUtlCLheP9jMLj8vVRqVqPFk1tgRGx5LVeKooF7BauL4Kunf0sFm0v/9M3qMuVVo0oVC2nPAWR9H6Oo/QkjU6lJaQXxNG26PhiH0KBTbkEZrFQlZ7yH6WeeDpX/gfJg+UC8ulT+NW71h4duIpYqfCV/oVB14b9D0tZI5tOXsCrbD3QQ9k74QFh6YOfczed8Vkcm+tMu50yn360oyDoFOi2EmBtqdKmQpxnCl7LIW+yC/hebVerrerzfZpPX4A5/Xadg=='></script>
<script type='text/javascript' src='https://platform.instagram.com/en_US/embeds.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyt0sFOwzAMBuAXIsuK1KEdEM+SpW6XEMcmdjptT0/G0E6caCQf/X+y5N9e2HjKClmtngFB7BrYijei1wTeiUIxr/vhYLmeUvA2ip3BaS1t9QZlyaA7DHkX5cX+B1shT1TExq8K5Wqid4WqQNqEPi+UMzGHvBikqSbohPpCKRmlNtyH9ITYkmIedh9UHRuYZ/DbPvT00H0CrW2Bu50Y0C0gDUB2pdN7kE4hgbkRoXn4m1y+C1ZaiXr1J+Q55KDw++wm/+ViNZzqEvJPi4t6mlo23uOibikOW+ID34dxPx6Hw/FtjN/yfmbX'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>            <!-- Begin Bringhub -->
            <script>
                (function(b,d,e,f,a,c,h,k){b[a]=b[a]||[];b[a+h]=function(g){b[a].unshift(['_setVersion',g]);b[a+c](e+'mini-widget.js?version='+g)};b[a+c]=function(b){var a=d.createElement('script'),c=f;a.src=k+b;a.async=true;c.parentNode.insertBefore(a,c)};b[a+c](e+'loader.js?'+Date.now())})(window,document,'/msf/',document.querySelector('script'),'_bh','_sl','_lw','//static.bh-cdn.com');
            </script>
            <!-- End Bringhub -->
        <script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'35011528','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'35011528','v':'wpcom','tz':'-4','user_id':'0','post':'698158','subd':'scstylecaster'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=35011528&v=wpcomvt&tz=-4&user_id=0&post=698158&subd=scstylecaster&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcweC5+TS4lUFRfaG98WnVnRmpSQyxOLitPcGlZM3Y1YnQ0UXd+M1NddTE4eXVIPzVfY2kmXU5NQTZ5OT14TU02Z1hVSiVsT2hNJW55aVpZJVpVP3lpYjVwZ0MtZmJiNTl4Y1VKVUh6QmYvdzlielJZcmo4ND8rSTV6Qlo2LlkzWzBtTiY2RVtETCx1WCVBeUloLUFIVVBZbHEsN3pMdlQmWnpKRD8zNy9wfGtWP3w1cXl4T0RzT3FUeUVUT2Q0ak4ufjJ6UXBiRmQ='}]);
_stq.push([ 'clickTrackerInit', '35011528', '698158' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated 297 seconds ago
	generated in 0.107 seconds
	served from batcache in 0.002 seconds
	expires in 3 seconds
-->
